4899 matches found
CVE-2025-8778
The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the nitropacksetcompressionajax function in all versions up to, and including, 1.18.4. This makes it possible for authenticated attackers, with Subscriber-level access and...
CVE-2025-8778
The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the nitropacksetcompressionajax function in all versions up to, and including, 1.18.4. This makes it possible for authenticated attackers, with Subscriber-level access and...
CVE-2025-8778 NitroPack <= 1.18.4 - Missing Authorization to Authenticated (Subscriber+) Limited Settings Update via nitropack_set_compression_ajax Function
The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the nitropacksetcompressionajax function in all versions up to, and including, 1.18.4. This makes it possible for authenticated attackers, with Subscriber-level access and...
CVE-2025-8778 NitroPack <= 1.18.4 - Missing Authorization to Authenticated (Subscriber+) Limited Settings Update via nitropack_set_compression_ajax Function
The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the nitropacksetcompressionajax function in all versions up to, and including, 1.18.4. This makes it possible for authenticated attackers, with Subscriber-level access and...
CVE-2025-8778
Summary (CVE-2025-8778): The NitroPack plugin for WordPress (versions up to 1.18.4) has a missing capability check in nitropack_set_compression_ajax(), enabling authenticated attackers with Subscriber-level access or higher to modify nitropack-enableCompression and alter plugin compression settin...
PT-2025-37019
Name of the Vulnerable Software and Affected Versions: NitroPack versions up to and including 1.18.4 Description: The NitroPack plugin for WordPress is susceptible to unauthorized data modification. This is due to a missing capability check within the nitropack set compression ajax function...
Linux Distros Unpatched Vulnerability : CVE-2022-4104
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A loop with an unreachable exit condition can be triggered by passing a crafted JPEG file to the Lepton image compression tool, resulting in a denial-of-service...
Huawei EulerOS: Security Advisory for ghostscript (EulerOS-SA-2025-2128)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Linux Distros Unpatched Vulnerability : CVE-2021-43086
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - ARM astcenc 3.2.0 is vulnerable to Buffer Overflow. When the compression function of the astc-encoder project with -cl option was used, a stack-buffer-overflow...
EulerOS 2.0 SP9 : ghostscript (EulerOS-SA-2025-2127)
According to the versions of the ghostscript packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : An issue was discovered in Artifex Ghostscript before 10.05.0. The NPDL device has a Compression buffer overflow for...
A Non-Monotonic Relationship: an Empirical Analysis of Hybrid Quantum Classifiers for Unseen Ransomware Detection
Detecting unseen ransomware is a critical cybersecurity challenge where classical machine learning often fails. While Quantum Machine Learning QML presents a potential alternative, its application is hindered by the dimensionality gap between classical data and quantum hardware. This paper...
PT-2025-44131
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A flaw exists in the Linux kernel's crypto component related to context allocation and freeing operations within the compression framework. A discrepancy in the definition and order of...
Exploit for Improper Restriction of Operations within the Bounds of a Memory Buffer in Microsoft
SMBGhost Simple scanner for CVE-2020-0796 - SMBv3 RCE. The scanner is for meant only for testing whether a server is vulnerable. It is not meant for research or development, hence the fixed payload. It checks for SMB dialect 3.1.1 and compression capability through a negotiate request. A network...
SUSE CVE-2025-58057
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted...
zram: fix NULL pointer in comp_algorithm_show()
...
HPACK table poisoning in gRPC C++, Python & Ruby
...
CVE-2025-58057: Improper Handling of Highly Compressed Data (Data Amplification)
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted...
app.fmgp:did-framework_3 (>=0.1.0-m26, <=0.1.0-m35), app.fmgp:did-method-prism_3 (>=0.1.0-m26, <=0.1.0-m35) +2021 more potentially affected by CVE-2025-58057 via io.netty:netty-codec-compression (>=4.2.0.alpha3, <=4.2.4.final)
io.netty:netty-codec-compression MAVEN version =4.2.0.alpha3, =0.1.0-m26, =0.1.0-m26, =1.0.5, =25.4.0, =25.4.0, =4.0.0-beta.1, =4.0.0-beta.5 - cn.hserver:hserver-plugin-beetlsql 3.7.0 - cn.hserver:hserver-plugin-cloud 3.7.0 - cn.hserver:hserver-plugin-druid 3.7.0 - cn.hserver:hserver-plugin-fores...
f2fs: compress: fix UAF of f2fs_inode_info in f2fs_free_dic
...
app.fmgp:did-framework_3 (>=0.1.0-m26, <=0.1.0-m35), app.fmgp:did-method-prism_3 (>=0.1.0-m26, <=0.1.0-m35) +2021 more potentially affected by CVE-2025-58057 via io.netty:netty-codec-compression (>=4.2.0.alpha3, <=4.2.4.final)
io.netty:netty-codec-compression MAVEN version =4.2.0.alpha3, =0.1.0-m26, =0.1.0-m26, =1.0.5, =25.4.0, =25.4.0, =4.0.0-beta.1, =4.0.0-beta.5 - cn.hserver:hserver-plugin-beetlsql 3.7.0 - cn.hserver:hserver-plugin-cloud 3.7.0 - cn.hserver:hserver-plugin-druid 3.7.0 - cn.hserver:hserver-plugin-fores...