17820 matches found
CVE-2025-27026
CVE-2025-27026 affects Infinera G42 version R6.1.3. A missing double‑check feature in the WebGUI CLI deactivation allows an authenticated administrator to disable multiple management interfaces across local and network access. The WebGUI‑driven CLI deactivation not only stops the CLI but also dea...
CVE-2025-27026 Improper Access Control Granularity impacting Infinera G42
A missing double-check feature in the WebGUI for CLI deactivation in Infinera G42 version R6.1.3 allows an authenticated administrator to make other management interfaces unavailable via local and network interfaces. The CLI deactivation via the WebGUI does not only stop CLI interface but...
SUSE-RU-2025:02204-1 Recommended update for aws-nitro-enclaves-cli
This update for aws-nitro-enclaves-cli fixes the following issues: - Fix idna accepts Punycode labels that do not produce any non-ASCII when decoded bsc1243859 - Update to version 1.4.2 - Update aws-nitro-enclaves-sdk-bootstrap to version f718dea6 - Update to version 1.3.3git0.afb7264 - Update...
SUSE-RU-2025:02203-1 Recommended update for aws-nitro-enclaves-cli
This update for aws-nitro-enclaves-cli fixes the following issues: - Fix idna accepts Punycode labels that do not produce any non-ASCII when decoded bsc1243859 - Update to version 1.4.2 - Update aws-nitro-enclaves-sdk-bootstrap to version f718dea6 - Update to version 1.3.3git0.afb7264 - Update...
CVE-2025-27023
Lack or insufficent input validation in WebGUI CLI web in Infinera G42 version R6.1.3 allows remote authenticated users to read all OS files via crafted CLI commands. Details: The web interface based management of the Infinera G42 appliance enables the feature of executing a restricted set of...
CVE-2025-27023
CVE-2025-27023 affects Infinera G42, specifically version R6.1.3. The issue is improper input validation in the WebGUI CLI web interface, enabling remote authenticated users to read all OS files by crafting CLI commands (and by triggering execution of a script-file present on the device). The roo...
CVE-2025-27023: Improper Input Validation
Lack or insufficent input validation in WebGUI CLI web in Infinera G42 version R6.1.3 allows remote authenticated users to read all OS files via crafted CLI commands. Details: The web interface based management of the Infinera G42 appliance enables the feature of executing a restricted set of...
PT-2025-27618 · Infinera · Infinera G42
Name of the Vulnerable Software and Affected Versions: Infinera G42 version R6.1.3 Description: The issue is related to insufficient input validation in the WebGUI CLI web interface of the Infinera G42 appliance. This allows remote authenticated users to read all OS files via crafted CLI commands...
@kakashi-ventures-accelerator/catalyst-cli (0.1.0), @mew-protocol/mew (>=0.5.0, <=0.11.0) +1 more potentially affected by CVE-2025-53110 via @modelcontextprotocol/server-filesystem (0.6.2)
@modelcontextprotocol/server-filesystem NPM version 0.6.2 is affected by a known vulnerability. The following packages have a transitive dependency on @modelcontextprotocol/server-filesystem and may be impacted: - @kakashi-ventures-accelerator/catalyst-cli 0.1.0 - @mew-protocol/mew =0.5.0, =0.11....
Insertion Of Sensitive Information Into Log File
snyk is vulnerable to Insertion of Sensitive Information into Log File. The vulnerability is due to improper logging of sensitive data because of debug and trace log modes capturing container registry credentials, authentication tokens, and access tokens when certain CLI commands are executed...
@devsoutinho/alfred-currency-converter (>=2.0.0, <=2.1.1), @felixcatto/ui (>=0.0.14, <=0.0.32) +13 more potentially affected by CVE-2025-45143 via string-math (1.2.2)
string-math NPM version 1.2.2 is affected by a known vulnerability. The following packages have a transitive dependency on string-math and may be impacted: - @devsoutinho/alfred-currency-converter =2.0.0, =0.0.14, =0.4.0-beta.2, =1.5.12, =0.1.47, =0.0.32, =2.0.0, =4.0.0, =1.0.0, =1.2.0, =1.0.8,...
Sensitive Data Exposure
Infinispan CLI is vulnerable to sensitive data exposure. The vulnerability is due to processing a Base64-decoded Kubernetes secret password in plaintext and including it in a command string, which may expose the data in error messages when a command is not found, allowing attackers to exploit thi...
CVE-2025-6624
Versions of the package snyk before 1.1297.3 are vulnerable to Insertion of Sensitive Information into Log File through local Snyk CLI debug logs. Container Registry credentials provided via environment variables or command line arguments can be exposed when executing Snyk CLI in DEBUG or...
org.infinispan:infinispan-persistence-cli (9.4.11.final) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (9.4.11.final)
org.infinispan:infinispan-cli-client MAVEN version 9.4.11.final is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-persistence-cli 9.4.11.final Source cves: CVE-2025-573...
org.infinispan:infinispan-persistence-cli (9.4.13.final) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (9.4.13.final)
org.infinispan:infinispan-cli-client MAVEN version 9.4.13.final is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-persistence-cli 9.4.13.final Source cves: CVE-2025-573...
org.infinispan:infinispan-persistence-cli (9.4.0.cr2) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (9.4.0.cr2)
org.infinispan:infinispan-cli-client MAVEN version 9.4.0.cr2 is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-persistence-cli 9.4.0.cr2 Source cves: CVE-2025-5731 Sour...
org.infinispan:infinispan-persistence-cli (9.4.1.final) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (9.4.1.final)
org.infinispan:infinispan-cli-client MAVEN version 9.4.1.final is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-persistence-cli 9.4.1.final Source cves: CVE-2025-5731...
org.infinispan:infinispan-server-runtime (11.0.0.alpha1) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (11.0.0.alpha1)
org.infinispan:infinispan-cli-client MAVEN version 11.0.0.alpha1 is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-server-runtime 11.0.0.alpha1 Source cves: CVE-2025-57...
org.infinispan:infinispan-persistence-cli (9.4.22.final) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (9.4.22.final)
org.infinispan:infinispan-cli-client MAVEN version 9.4.22.final is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-persistence-cli 9.4.22.final Source cves: CVE-2025-573...
org.infinispan:infinispan-persistence-cli (9.4.23.final) potentially affected by CVE-2025-5731 via org.infinispan:infinispan-cli-client (9.4.23.final)
org.infinispan:infinispan-cli-client MAVEN version 9.4.23.final is affected by a known vulnerability. The following packages have a transitive dependency on org.infinispan:infinispan-cli-client and may be impacted: - org.infinispan:infinispan-persistence-cli 9.4.23.final Source cves: CVE-2025-573...