5281 matches found
Code injection
cPanel before 82.0.15 allows API token credentials to persist after an account has been renamed or terminated SEC-517...
Design/Logic Flaw
cPanel before 82.0.15 allows self stored XSS in the WHM SSL Storage Manager interface SEC-527...
CVE-2019-17380
cPanel before 82.0.15 allows self XSS in the WHM Update Preferences interface SEC-528...
CVE-2019-17380
CVE-2019-17380 affects cPanel's WHM Update Preferences interface, where versions prior to 82.0.15 are vulnerable to a self‑XSS due to lack of proper validation of client‑side data. The issue arises within the WHM Update Preferences UI and can lead to execution of client‑side code, as described ac...
CVE-2019-17379
cPanel before 82.0.15 allows self stored XSS in the WHM SSL Storage Manager interface SEC-527...
CVE-2019-17379
CVE-2019-17379 affects cPanel before 82.0.15, introducing a self-stored XSS in the WHM SSL Storage Manager interface. The underlying issue is lack of proper validation of client-side data in the web application, enabling an attacker to inject and execute script through stored input. Impact per so...
CVE-2019-17378
cPanel before 82.0.15 allows self XSS in the SSL Key Delete interface SEC-526...
CVE-2019-17378
CVE-2019-17378 affects cPanel prior to 82.0.15, where the SSL Key Delete interface is vulnerable to self XSS (SEC-526). The issue originates from inadequate input validation on a client-side operation, enabling injection of script in the SSL Key Delete flow. Impact is described as a self XSS vuln...
CVE-2019-17377
cPanel before 82.0.15 allows self XSS in LiveAPI example scripts SEC-524...
CVE-2019-17377
The CVE-2019-17377 issue affects cPanel prior to 82.0.15, where the LiveAPI sample scripts are vulnerable to self-XSS due to insufficient validation of client‑side data in the web application. Exploitation could allow an attacker to execute arbitrary client-side code within affected sessions. Rem...
CVE-2019-17376
cPanel before 82.0.15 allows self XSS in the SSL Certificate Upload interface SEC-521...
CVE-2019-17376
CVE-2019-17376 affects cPanel prior to 82.0.15, where the SSL Certificate Upload interface is vulnerable to self-XSS due to insufficient validation in client-side data handling. Multiple sources confirm the flaw exists in the SSL Certificate Upload feature and is tied to versions older than 82.0....
CVE-2019-17375
cPanel before 82.0.15 allows API token credentials to persist after an account has been renamed or terminated SEC-517...
CVE-2019-17375
CVE-2019-17375 affects cPanel prior to 82.0.15. The vulnerability allows API token credentials to persist after an account is renamed or terminated (SEC-517). Impact includes persistence of credentials that may enable access after account changes, with CVSS v3.1 base score high (8.8) and CVSS v2 ...
CVE-2019-17377: Improper Neutralization of Input During Web Page Generation
cPanel before 82.0.15 allows self XSS in LiveAPI example scripts SEC-524...
CVE-2019-17375: Insufficient Session Expiration
cPanel before 82.0.15 allows API token credentials to persist after an account has been renamed or terminated SEC-517...
CVE-2019-17376: Improper Neutralization of Input During Web Page Generation
cPanel before 82.0.15 allows self XSS in the SSL Certificate Upload interface SEC-521...
PT-2019-15115
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 82.0.15 Description The issue allows self XSS in LiveAPI example scripts. Recommendations For versions prior to 82.0.15, update to version 82.0.15 or later to resolve the issue...
PT-2019-15118
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 82.0.15 Description The issue allows self XSS in the WHM Update Preferences interface. Recommendations For versions prior to 82.0.15, update to version 82.0.15 or later to resolve the issue...
PT-2019-15114
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 82.0.15 Description The issue allows self XSS in the SSL Certificate Upload interface. Recommendations For versions prior to 82.0.15, update to version 82.0.15 or later to resolve the issue...