1897 matches found
Glib buffer error vulnerability
Glib is a generic, portable utility library for the GNOME project. It provides many useful data types, macros, type conversions, string utilities, file utilities, and main loop abstractions. Glib has a buffer overflow vulnerability, which stems from a buffer underflow in the content type parsing...
CVE-2026-1485: Buffer Underwrite
A flaw was found in Glib's content type parsing logic. This buffer underflow vulnerability occurs because the length of a header line is stored in a signed integer, which can lead to integer wraparound for very large inputs. This results in pointer underflow and out-of-bounds memory access...
Linux Distros Unpatched Vulnerability : CVE-2026-1485
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - A flaw was found in Glib's content type parsing logic. This buffer underflow vulnerability occurs because the length of a header line is stored in a signed...
Azure Linux 3.0 Security Update: espeak-ng (CVE-2023-49991)
The version of espeak-ng installed on the remote Azure Linux 3.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2023-49991 advisory. - Espeak-ng 1.52-dev was discovered to contain a Stack Buffer Underflow via the function CountVowelPosition...
MiracleLinux 3 : libxml2-2.6.26-2.1.15.6.0.1.AXS3 (AXSA:2013-07:01)
The remote MiracleLinux 3 host has packages installed that are affected by a vulnerability as referenced in the AXSA:2013-07:01 advisory. This library allows to manipulate XML files. It includes support to read, modify and write XML and HTML files. There is DTDs support this includes parsing and...
MiracleLinux 7 : mercurial-2.6.2-10.el7 (AXSA:2019-4114:01)
The remote MiracleLinux 7 host has a package installed that is affected by multiple vulnerabilities as referenced in the AXSA:2019-4114:01 advisory. mercurial: Buffer underflow in mpatch.c:mpatchapply CVE-2018-13347 mercurial: HTTP server permissions bypass CVE-2018-1000132 mercurial: Missing che...
MiracleLinux 3 : libtiff-3.8.2-7.4.1AXS3 (AXSA:2009-380:01)
The remote MiracleLinux 3 host has packages installed that are affected by multiple vulnerabilities as referenced in the AXSA:2009-380:01 advisory. The libtiff package contains a library of functions for manipulating TIFF Tagged Image File Format image format files. TIFF is a widely used file...
CVE-2025-71098 ip6_gre: make ip6gre_header() robust
In the Linux kernel, the following vulnerability has been resolved: ip6gre: make ip6greheader robust Over the years, syzbot found many ways to crash the kernel in ip6greheader 1. This involves team or bonding drivers ability to dynamically change their dev-neededheadroom and/or dev-hardheaderlen ...
CVE-2025-68794: Integer Overflow or Wraparound
In the Linux kernel, the following vulnerability has been resolved: iomap: adjust read range correctly for non-block-aligned positions iomapadjustreadrange assumes that the position and length passed in are block-aligned. This is not always the case however, as shown in the syzbot generated case...
MiracleLinux 9 : glib2-2.68.4-16.el9_6.2 (AXSA:2025-10648:03)
The remote MiracleLinux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the AXSA:2025-10648:03 advisory. glib: buffer overflow in setconnectmsg CVE-2024-52533 glib: Buffer Underflow on GLib through glib/gstring.c via function gstringinsertunichar...
OPENSUSE-SU-2026:20018-1 Security update for glib2
This update for glib2 fixes the following issues: Update to version 2.84.4. Security issues fixed: - CVE-2025-14512: integer overflow in the GIO escapebytestring function when processing malicious files or remote filesystem attribute values can lead to denial-of-service bsc1254878. -...
CVE-2020-24658
Arm Compiler 5 through 5.06u6 has an error in a stack protection feature designed to help spot stack-based buffer overflows in local arrays. When this feature is enabled, a protected function writes a guard value to the stack prior to above any vulnerable arrays in the stack. The guard value is...
Amazon Linux 2023 : glib2, glib2-devel, glib2-static (ALAS2023-2025-1349)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1349 advisory. Buffer underflow on Glib through glib/gvariant via bytestringparse or stringparse leads to OOB Write. CVE-2025-14087 Tenable has extracted the preceding description block directly from the tested produ...
CVE-2026-22185
OpenLDAP Lightning Memory-Mapped Database LMDB versions up to and including 0.9.14, prior to commit 8e1fda8, contain a heap buffer underflow in the readline function of mdbload. When processing malformed input containing an embedded NUL byte, an unsigned offset calculation can underflow and cause...
CVE-2026-22185: Out-of-bounds Read
OpenLDAP Lightning Memory-Mapped Database LMDB versions up to and including 0.9.14, prior to commit 8e1fda8, contain a heap buffer underflow in the readline function of mdbload. When processing malformed input containing an embedded NUL byte, an unsigned offset calculation can underflow and cause...
Important: glib2
Issue Overview: Buffer underflow on Glib through glib/gvariant via bytestringparse or stringparse leads to OOB Write. CVE-2025-14087 Affected Packages: glib2 Issue Correction: Run dnf update glib2 --releasever 2023.10.20260105 or dnf update --advisory ALAS2023-2025-1349 --releasever...
Security update for glib2
This update for glib2 fixes the following issues: CVE-2025-14512: integer overflow in the GIO escapebytestring function when processing malicious files or remote filesystem attribute values can lead to denial-of-service bsc1254878. CVE-2025-14087: buffer underflow in the GVariant parser...
Important: glib2
Issue Overview: Buffer underflow on Glib through glib/gvariant via bytestringparse or stringparse leads to OOB Write. CVE-2025-14087 Affected Packages: glib2 Note: This advisory is applicable to Amazon Linux 2 AL2 Core repository. Visit this FAQ section for the difference between AL2 Core and AL2...
Amazon Linux 2 : glib2, --advisory ALAS2-2025-3117 (ALAS-2025-3117)
The version of glib2 installed on the remote host is prior to 2.56.1-9. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2025-3117 advisory. Buffer underflow on Glib through glib/gvariant via bytestringparse or stringparse leads to OOB Write. CVE-2025-14087 Tenable has...
PT-2026-4916
Name of the Vulnerable Software and Affected Versions Glib affected versions not specified Description A buffer underflow issue exists in Glib's content type parsing logic. The issue stems from storing the length of a header line in a signed integer, potentially causing integer wraparound with...