6099 matches found
DIAL
DIAL 云上的工作负载为黑客提供了与内部团队同等的机会。云原生公司既面临外部攻击,也面临内部攻击。随着安全漏洞风险的不断增长,云配置错误成为最常见的因素之一,平均检测时间应缩短到秒级而非分钟/小时/天。因此,我们推出了内部工具DIAL(我是否触发了Lambda?),它可以帮助我们在任何时间段内监控任意数量的AWS账户。 DIAL是什么? DIAL(我是否触发了Lambda?) 是一个集中式的安全配置错误检测框架,完全运行在AWS托管服务上,例如AWS API Gateway、AWS Event Bridge和AWS Lambda。以下是DIAL的一些关键特性:...
IPRotate_Burp_Extension
IPRotateBurpExtension Burp Suite扩展,利用AWS API Gateway在每次请求时更换IP。 更多信息:使用AWS绕过基于IP的封锁 - Rhino Security Labs 注意/警告 根据AWS的渗透测试政策,使用AWS API Gateway混淆源IP的方法现已被视为禁止:https://aws.amazon.com/security/penetration-testing/ 描述 此扩展允许您轻松地在多个区域启动API Gateway。然后,针对目标主机的所有Burp Suite流量都通过API...
outpost
Outpost Gestión de Pruebas e Informes de AWS Outpost es una herramienta sencilla para generar archivos de configuración de AWS para AssumeRole, una capacidad de prueba para verificar que las cuentas funcionan, y un generador de informes para los resultados de escaneo de ScoutSuite. Ejecutar...
cloud-audit
项目简介 cloud-audit (云安全审计助手)是检测公有云厂商AK/SK泄漏被利用的工具,通过定期调用云平台接口审计日志,基于异常行为/黑特征/基线发现疑似入侵行为。 当前仅支持腾讯云与AWS 特性 支持检测腾讯云平台AK/SK利用告警(异常行为) 调用AK/SK创建命令/执行命令监控 调用AK/SK添加子账户/删除子账户监控 调用AK/SK跨region列DB 调用AK/SK跨region列实例 支持检测AWS云平台AK/SK利用告警(基线检测) 调用AK/SK创建用户监控 调用AK/SK列用户监控 调用AK/SK列S3监控 调用AK/SK列DB监控 调用AK/SK提权监控...
pytm
pytm: A Pythonic framework for threat modeling Introduction Traditional threat modeling too often comes late to the party, or sometimes not at all. In addition, creating manual data flows and reports can be extremely time-consuming. The goal of pytm is to shift threat modeling to the left, making...
CVE-2026-106493
A flaw was found in Backstage. Cloud storage catalog providers do not sufficiently validate object paths. An attacker with permissions to create or rename objects in a configured cloud storage source, such as Amazon Web Services AWS S3 or Azure Blob Storage, can cause catalog descriptors to be re...
cloudsploit
Aqua 旗下 CloudSploit - 云安全扫描 快速开始 通用方式 $ git clone https://github.com/aquasecurity/cloudsploit.git $ cd cloudsploit $ npm install $ ./index.js -h Docker 方式 $ git clone https://github.com/aquasecurity/cloudsploit.git $ cd cloudsploit $ docker build . -t cloudsploit:0.0.1 $ docker run...
cloudsploit
CloudSploit by Aqua - Cloud Security Scans Quick Start Generic $ git clone https://github.com/aquasecurity/cloudsploit.git $ cd cloudsploit $ npm install $ ./index.js -h Docker $ git clone https://github.com/aquasecurity/cloudsploit.git $ cd cloudsploit $ docker build . -t cloudsploit:0.0.1 $...
sandcastle
受与 Instacart 的 @nickelser 在 HackerOne 上的一次对话启发,我优化并发布了 Sandcastle——一个用于 AWS S3 bucket 枚举的 Python 脚本,原名 bucketCrawler。 该脚本以目标名称为词干参数(例如 shopify),并遍历一个包含 bucket 名称排列的文件,如下列排列: -training -bucket -dev -attachments -photos -elasticsearch ... 开始使用 以下是入门步骤: 1. 克隆此仓库(PyPi 分发暂时禁用)。 2. 使用目标名称和输入文件运行...
s3-leaks
s3-leaks Lista de fugas de AWS S3 No dudes en enviar un PR si conoces otras fugas Fecha| Descripción| Notas ---|---|--- April 2025| Pensamientos de IDs de claves de acceso de AWS de un bucket S3| Las llaves del reino de AWS March 2025| 16,000 suscriptores de los periódicos Nine de Australia|...
domain-protect
domain-protect Domain Protect is now an OWASP project moved to: github.com/domain-protect/domain-protect...
http-desync-guardian
概览 HTTP/1.1 从 1991 年到 2014 年经历了漫长的演进: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 这意味着存在多种服务器和客户端,它们对请求边界的理解可能不同,从而产生反同步攻击(即 HTTP Desync)的机会。 遵循最新的 RFC 建议看似简单。然而,对于已运行多年的大型系统,这可能会带来不可接受的可用性影响。 httpdesyncguardian 库旨在分析 HTTP 请求以防范 HTTP Desync...
prowler
Prowler is the Open Cloud Security Platform trusted by thousands to automate security and compliance in any cloud environment. With thousands of ready-to-use checks and compliance frameworks, Prowler delivers real-time, customizable monitoring and seamless integrations, making cloud security...
terragoat
TerraGoat - Vulnerable Terraform Infrastructure TerraGoat is Bridgecrew's "Vulnerable by Design" Terraform repository. TerraGoat is Bridgecrew's "Vulnerable by Design" Terraform repository. TerraGoat is a learning and training project that demonstrates how common configuration errors can find the...
terraform-aws-security-group
terraform-aws-security-group 用于管理 AWS 安全组的 Terraform 模块。目前,入站和出站规则支持 IPv4、IPv6 以及安全组 ID 输入。 要求 名称| 版本 ---|--- terraform| = 1.6 aws| = 5.0 提供者 名称| 版本 ---|--- aws| = 5.0 模块 无模块。 资源 名称| 类型 ---|--- awssecuritygroup.securitygroup| resource awssecuritygrouprule.egressip| resource...
cloud-sniper
Cloud Sniper:检测即代码平台 Cloud Sniper 是一个全面设计的平台,旨在简化云安全运营。它通过分析和关联云工件,迅速响应安全事件,确保护航公司云安全态势的全局视图。 作为集中式事件响应枢纽,我们的平台利用云原生工件和开源技术执行自动化操作。这种方法赋能社区以多样化的安全用例丰富项目。 Cloud Sniper 高效处理安全信息流,自主保护云基础设施。其分析模块关联入侵指标(IOC),揭示攻击者的战术、技术与程序(TTP),为分析师提供增强的安全发现。 用户通过 Cloud Sniper...
yatas
YATAS 又一个测试与审计解决方案 YATAS 的目标是帮助你无需过多麻烦地创建一个安全的 AWS 环境。它不会检查所有最佳实践,只会根据我的经验检查对你重要的那部分。如果你发现任何未涵盖的内容,请随时告诉我。 特性 YATAS 是一个简单易用的工具,用于审计你的基础设施是否存在错误配置或潜在安全问题。 无详情| 详情 ---|--- | 安装 brew tap padok-team/tap brew install yatas yatas --init 根据你的需求修改 .yatas.yml 文件。 yatas --install 安装你需要的插件。 用法 yatas -h 参数:...
CyberRange
概述: 此CyberRange项目代表世界上第一个开源网络靶场蓝图。 该项目提供了一个引导框架,用于在AWS云上的私有研究实验室中构建完整的攻击性、防御性、逆向工程及安全情报工具。 该项目包含易受攻击的系统以及一套对渗透测试人员、开发人员、恶意软件分析师、取证/逆向工程师、威胁猎手等人而言最强大的开源/社区版工具的工具包。 开始使用 要获得访问权限,您必须将您的AWS账户号码发送给我,以便我分享30多个Amazon Machine Image(AMI)。 请使用我的安全FormAssembly表单 - CyberRange注册表单 然后 - 阅读入门指南 范围历史 发布说明: 查看变更日...
awsEnum
awsEnum 枚举AWS服务!无噪音 awsEnum是一个Python脚本,通过提供的凭证枚举AWS服务。 :book: 目录 目录 1. 截图 2. 免责声明 3. 特性 4. 前提条件 5. 安装方法 6. 结果与常见问题 7. 待办事项 :clapper: 截图 ▄▄▄▄▄▄ ▄ ▄ ▄▄▄▄▄▄▄ ▄▄▄▄▄▄▄ ▄▄ ▄ ▄▄ ▄▄ ▄▄ ▄▄ █ █ █ ▄ █ █ █ █ █ █ █ █ █ █ █▄█ █ █ ▄ █ ██ ██ █ ▄▄▄▄▄█ ▄▄▄█ █▄█ █ █ █ █ █ █ █▄█ █ █ █▄▄▄▄▄█ █▄▄▄█ █ █▄█ █ █ █ █ █▄▄▄▄...
terraform-aws-secure-baseline
terraform-aws-secure-baseline Terraform Module Registry A terraform module to set up your AWS account with the reasonably secure configuration baseline. Most configurations are based on CIS Amazon Web Services Foundations v1.4.0 and AWS Foundational Security Best Practices v1.0.0. See Benchmark...