365 matches found
aws-lambda-sls (0.1.0), chalice (1.6.1) +4 more potentially affected by CVE-2026-13346 via pip (18.0.0)
pip PYPI version 18.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pip and may be impacted: - aws-lambda-sls 0.1.0 - chalice 1.6.1 - lucterios =2.3.0.18073018, =2.3.0.18070609, =2.3.0.18070422, =2.3.1.18112821 - venv-update 3.1.1 Source cves:...
Qualys Expands Serverless Security with Vulnerability Scanning for AWS Lambda
Key Takeaways Qualys now delivers automated AWS Lambda vulnerability scanning , extending serverless security beyond posture checks CSPM into workload-level risk visibility. CSPM alone only catches misconfigurations excessive permissions, exposure, logging, encryption — it can't detect vulnerable...
aws-lambda-sls (0.1.0), chalice (1.6.1) +4 more potentially affected by CVE-2026-6357 via pip (18.0.0)
pip PYPI version 18.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pip and may be impacted: - aws-lambda-sls 0.1.0 - chalice 1.6.1 - lucterios =2.3.0.18073018, =2.3.0.18070609, =2.3.0.18070422, =2.3.1.18112821 - venv-update 3.1.1 Source cves:...
aws-lambda-sls (0.1.0), chalice (1.6.1) +4 more potentially affected by CVE-2026-3219 via pip (18.0.0)
pip PYPI version 18.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pip and may be impacted: - aws-lambda-sls 0.1.0 - chalice 1.6.1 - lucterios =2.3.0.18073018, =2.3.0.18070609, =2.3.0.18070422, =2.3.1.18112821 - venv-update 3.1.1 Source cves:...
CVE-2026-54288
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, the Body Limit Middleware trusts the request's Content-Length header to decide whether a body is within the limit. On AWS Lambda API Gateway v1/v2, ALB, VPC Lattice, and Lambda@Edge the body is...
CVE-2026-54288
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, the Body Limit Middleware trusts the request's Content-Length header to decide whether a body is within the limit. On AWS Lambda API Gateway v1/v2, ALB, VPC Lattice, and Lambda@Edge the body is...
CVE-2026-54288
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, the Body Limit Middleware trusts the request's Content-Length header to decide whether a body is within the limit. On AWS Lambda API Gateway v1/v2, ALB, VPC Lattice, and Lambda@Edge the body is...
CVE-2026-54289
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, on AWS Lambda@Edge, CloudFront delivers a request header that appears more than once as several separate entries. The adapter writes each value with Headers.set instead of Headers.append, so...
CVE-2026-54289
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, on AWS Lambda@Edge, CloudFront delivers a request header that appears more than once as several separate entries. The adapter writes each value with Headers.set instead of Headers.append, so...
CVE-2026-54287
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, on AWS Lambda, the ALB single-header response and the VPC Lattice v2 response join multiple Set-Cookie headers into one comma-separated value. Because commas also appear inside cookie attribute...
CVE-2026-54289: Use of Less Trusted Source
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, on AWS Lambda@Edge, CloudFront delivers a request header that appears more than once as several separate entries. The adapter writes each value with Headers.set instead of Headers.append, so...
CVE-2026-54287: Improper Encoding or Escaping of Output
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, on AWS Lambda, the ALB single-header response and the VPC Lattice v2 response join multiple Set-Cookie headers into one comma-separated value. Because commas also appear inside cookie attribute...
CVE-2026-54288: Insufficient Verification of Data Authenticity
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.25, the Body Limit Middleware trusts the request's Content-Length header to decide whether a body is within the limit. On AWS Lambda API Gateway v1/v2, ALB, VPC Lattice, and Lambda@Edge the body is...
Insufficient Verification of Data Authenticity
Overview org.webjars.npm:hono is an Ultrafast web framework for the Edges Affected versions of this package are vulnerable to Insufficient Verification of Data Authenticity in the Body Limit Middleware. An attacker can cause the application to process payloads larger than the configured maximum b...
Improper Encoding or Escaping of Output
Overview org.webjars.npm:hono is an Ultrafast web framework for the Edges Affected versions of this package are vulnerable to Improper Encoding or Escaping of Output in the AWS Lambda adapter's handling of multiple Set-Cookie headers. An attacker can cause clients to drop or misinterpret cookies ...
com.xti.jenkins.plugins:aws-lambda-jenkins-plugin (0.0.1), org.jenkins-ci.main:jenkins-test-harness (1.599) +7 more potentially affected by CVE-2026-53440 via org.jenkins-ci.main:jenkins-core (1.599)
org.jenkins-ci.main:jenkins-core MAVEN version 1.599 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.xti.jenkins.plugins:aws-lambda-jenkins-plugin 0.0.1 -...
com.xti.jenkins.plugins:aws-lambda-jenkins-plugin (0.0.1), org.jenkins-ci.main:jenkins-test-harness (1.599) +7 more potentially affected by CVE-2026-53437 via org.jenkins-ci.main:jenkins-core (1.599)
org.jenkins-ci.main:jenkins-core MAVEN version 1.599 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.xti.jenkins.plugins:aws-lambda-jenkins-plugin 0.0.1 -...
com.xti.jenkins.plugins:aws-lambda-jenkins-plugin (0.0.1), org.jenkins-ci.main:jenkins-test-harness (1.599) +7 more potentially affected by CVE-2026-53439 via org.jenkins-ci.main:jenkins-core (1.599)
org.jenkins-ci.main:jenkins-core MAVEN version 1.599 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.xti.jenkins.plugins:aws-lambda-jenkins-plugin 0.0.1 -...
io.jenkins.plugins:aws-lambda-cloud (>=0.3, <=0.4), org.jenkins-ci.main:jenkins-test-harness (1.635) +2 more potentially affected by CVE-2026-53442 via org.jenkins-ci.main:jenkins-core (1.635)
org.jenkins-ci.main:jenkins-core MAVEN version 1.635 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - io.jenkins.plugins:aws-lambda-cloud =0.3, =0.4 - org.jenkins-ci.main:jenkins-test-harness 1.635...
io.jenkins.plugins:aws-lambda-cloud (>=0.3, <=0.4), org.jenkins-ci.main:jenkins-test-harness (1.635) +2 more potentially affected by CVE-2026-53440 via org.jenkins-ci.main:jenkins-core (1.635)
org.jenkins-ci.main:jenkins-core MAVEN version 1.635 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - io.jenkins.plugins:aws-lambda-cloud =0.3, =0.4 - org.jenkins-ci.main:jenkins-test-harness 1.635...