365 matches found
CVE-2026-104002 Fail-open error handling in the data masking utility in Powertools for AWS Lambda (Python)
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
CVE-2026-104002
The data masking utility in Powertools for AWS Lambda (Python) is vulnerable to a fail-open error handling issue in versions prior to 3.35.0 . This flaw allows actors to read sensitive field values that the application intended to mask because the system continues to operate rather than denying a...
awsidr (>=1.0.0, <=1.0.9), rds-proxy-password-rotation (>=0.5.8, <=0.6.556) potentially affected by CVE-2026-104002 via aws-lambda-powertools (>=3.7.0, <=3.34.0)
aws-lambda-powertools PYPI version =3.7.0, =1.0.0, =0.5.8, =0.6.556 Source cves: CVE-2026-104002 Source advisory: MEND:CVE-2026-104002...
CVE-2026-104002 Fail-open error handling in the data masking utility in Powertools for AWS Lambda (Python)
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
EUVD-2026-91063
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
CVE-2026-104002 Fail-open error handling in the data masking utility in Powertools for AWS Lambda (Python)
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
Malicious code in spo365-graph (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 091649f7b927b27a5bd7a35b53784433050bf58e0dc11acc95316b650a13f60b SPO365-GRAPH presents itself as a SharePoint Online Graph client, but the shipped library module SPO365GRAPH/SPO365GRAPH.py consists entirely of stub...
MAL-2026-17421 Malicious code in spo365-graph (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 091649f7b927b27a5bd7a35b53784433050bf58e0dc11acc95316b650a13f60b SPO365-GRAPH presents itself as a SharePoint Online Graph client, but the shipped library module SPO365GRAPH/SPO365GRAPH.py consists entirely of stub...
CVE-2026-104002: Detection of Error Condition Without Action
A fail-open error handling issue within the data masking utility of Powertools for AWS Lambda Python might allow actors to read sensitive field values that the application intended to mask. To remediate this issue, users should upgrade to version 3.35.0...
PT-2026-104018
Name of the Vulnerable Software and Affected Versions Powertools for AWS Lambda Python versions prior to 3.35.0 Description A fail-open error handling issue exists within the data masking utility. This flaw may allow actors to read sensitive field values that the application intended to mask...
serverless [email protected]
Website • Documentation • X / Twitter • Community Slack • Forum The Serverless Framework – Makes it easy to use AWS Lambda and other managed cloud services to build applications that auto-scale, cost nothing when idle, and result in radically low maintenance. The Serverless Framework is a...
GO-2026-4316 vulnerabilities
Vulnerabilities for packages: cloudbeat-fips, aws-lambda-runtime-interface-emulator-fips, aws-lambda-runtime-interface-emulator, commercial-kyverno, fleet-server-fips, custom-pod-autoscaler-fips, kyverno-fips, cloudbeat, custom-pod-autoscaler...
GO-2026-5013 vulnerabilities
Vulnerabilities for packages: pulumi-language-java, gatus, step, argo-events, istio, kots, crossplane-provider-azure-managedidentity, terraform-provider-acme, tkn, tw, ksops, gomplate, atlantis, crossplane-provider-aws-route53, prometheus, skaffold, crossplane-provider-aws-eks, k3s,...
Serverless Function URL Detection
Finds AWS Lambda Function URLs, GCP Cloud Functions, and Azure Functions references in page source and probes common /api paths for unauthenticated invoke. !/usr/bin/env python3 -- coding: utf-8 -- """Detect exposed serverless function URLs and unauthenticated invoke endpoints.""" from kittysploi...
CVE-2026-18248 @fastify/aws-lambda vulnerable to Lambda event spoofing via client-controlled x-apigateway-event header
@fastify/aws-lambda version 6.4.0 decorates each Fastify request with request.awsLambda.event and request.awsLambda.context, values that applications are documented to use for authorization decisions such as reading API Gateway authorizer claims. In the default configuration, the getter that...
CVE-2026-18248
@fastify/aws-lambda version 6.4.0 decorates each Fastify request with request.awsLambda.event and request.awsLambda.context, values that applications are documented to use for authorization decisions such as reading API Gateway authorizer claims. In the default configuration, the getter that...
CVE-2026-18248
@fastify/aws-lambda version 6.4.0 decorates each Fastify request with request.awsLambda.event and request.awsLambda.context, values that applications are documented to use for authorization decisions such as reading API Gateway authorizer claims. In the default configuration, the getter that...
@leighton-digital/api-test-harness (>=1.1.2, <=1.1.3), @webiny/ai-powerups (>=0.0.0-unstable.9f53ea597d, <=6.5.0-beta.4) +67 more potentially affected by CVE-2026-18248 via @fastify/aws-lambda (6.4.0)
@fastify/aws-lambda NPM version 6.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on @fastify/aws-lambda and may be impacted: - @leighton-digital/api-test-harness =1.1.2, =0.0.0-unstable.9f53ea597d, =0.0.0-unstable.6844005670,...
CVE-2026-18248
CVE-2026-18248 affects @fastify/aws-lambda 6.4.0, where request.awsLambda.event and request.awsLambda.context are decorated using client-controlled x-apigateway-event and x-apigateway-context headers. The getter may read untrusted headers before the internal per-invocation token, leaving reserved...
CVE-2026-18248: Insufficient Verification of Data Authenticity
@fastify/aws-lambda version 6.4.0 decorates each Fastify request with request.awsLambda.event and request.awsLambda.context, values that applications are documented to use for authorization decisions such as reading API Gateway authorizer claims. In the default configuration, the getter that...