14996 matches found
Zephyr security vulnerabilities
Zephyr is an open source, small, scalable, real-time operating system. a security vulnerability exists in Zephyr, which stems from the ZephyrJSON decoder incorrectly decoding arrays. No details of the vulnerability are currently available...
PT-2021-20825
Name of the Vulnerable Software and Affected Versions: Zephyr versions 1.14.0 and later, 2.5.0 and later Description: The Zephyr JSON decoder incorrectly decodes an array of arrays, which can lead to an attempt to access a child of a non-structure pointer. This issue is related to CWE-588...
CVE-2021-3510: Attempt to Access Child of a Non-structure Pointer
Zephyr JSON decoder incorrectly decodes array of array. Zephyr versions = 1.14.0, = 2.5.0 contain Attempt to Access Child of a Non-structure Pointer CWE-588. For more information, see https://github.com/zephyrproject-rtos/zephyr/security/advisories/GHSA-289f-7mw3-2qf4...
GHSA-M7H5-FJJQ-559F SQL Injection in topthink/thinkphp
ThinkPHP v3.2.3 and below contains a SQL injection vulnerability which is triggered when the array is not passed to the "where" and "query" methods...
SQL Injection in topthink/thinkphp
ThinkPHP v3.2.3 and below contains a SQL injection vulnerability which is triggered when the array is not passed to the "where" and "query" methods...
Denial Of Service (DoS)
GnuPG is vulnerable to denial of service. Due to an array overflow, it causes a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error...
GoGolang Protobuf Library Data Compromise
The vulnerability in the plugin/unmarshal/unmarshal.go library of GoGo Protobuf is related to incorrect array indexing. Exploiting this vulnerability can allow an attacker to compromise the confidentiality, integrity, and accessibility of the protected information...
GHSA-H73Q-5WMJ-Q8PJ Cross site scripting in datatables.net
This affects the package datatables.net before 1.11.3. If an array is passed to the HTML escape entities function it would not have its contents escaped...
CVE-2020-20120
ThinkPHP v3.2.3 and below contains a SQL injection vulnerability which is triggered when the array is not passed to the "where" and "query" methods...
CVE-2020-20120
ThinkPHP v3.2.3 and below contains a SQL injection vulnerability which is triggered when the array is not passed to the "where" and "query" methods...
Sql injection
ThinkPHP v3.2.3 and below contains a SQL injection vulnerability which is triggered when the array is not passed to the "where" and "query" methods...
AZL-66567 CVE-2021-23445 affecting package reaper 3.1.1-22
This affects the package datatables.net before 1.11.3. If an array is passed to the HTML escape entities function it would not have its contents escaped...
DEBIAN-CVE-2021-23445
This affects the package datatables.net before 1.11.3. If an array is passed to the HTML escape entities function it would not have its contents escaped...
CVE-2021-23445
This affects the package datatables.net before 1.11.3. If an array is passed to the HTML escape entities function it would not have its contents escaped...
CVE-2021-41329
Datalust Seq before 2021.2.6259 allows users with view filters applied to their accounts to see query results not constrained by their view filter. This information exposure, caused by an internal cache key collision, occurs when the user's view filter includes an array or IN clause, and when...
Datalust Seq security vulnerabilities
Datalust Seq is a logging server from Datalust Australia. It is used to speed up diagnostics in complex, asynchronous and distributed applications. A security vulnerability exists in Datalust Seq versions prior to 2021.2.6259, which stems from software that allows a user who applies a view filter...
PT-2021-23281
Name of the Vulnerable Software and Affected Versions Datalust Seq versions prior to 2021.2.6259 Description The issue allows users with view filters applied to their accounts to see query results not constrained by their view filter. This information exposure is caused by an internal cache key...
PT-2021-4756
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 5.14.15 Description An issue was discovered in the Linux kernel, specifically an array-index-out-of-bounds flaw in the detach capi ctr function in drivers/isdn/capi/kcapi.c. This flaw can lead to a buffer overflo...
Updated apr packages fix security vulnerability
An out-of-bounds array read in the aprtimeexp functions was fixed in the Apache Portable Runtime 1.6.3 release CVE-2017-12613. The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue...
Mozilla Rust Memory Corruption Vulnerability (CNVD-2021-78747)
Rust is a general-purpose, compiled programming language from the Mozilla Foundation.A memory corruption vulnerability exists in versions of Mozilla Rust prior to 0.3.2, which stems from Rust's array-tools crate. for fixedcapacitydequelikes:: clone has an uninitialized memory. An attacker could...