14893 matches found
CVE-2024-1874
CVE-2024-1874 Proof Of Concept for CVE-2024-1874 Command Injection via Array-ish $command Parameter of procopen bypass CVE-2024-1874 fix The CVE: In PHP versions 8.1. before 8.1.29, 8.2. before 8.2.20, 8.3. before 8.3.8, the fix for CVE-2024-1874 does not work if the command name includes trailin...
CVE-2026-119283
A flaw was found in joserfc. When decrypting a JSON Web Encryption JWE object, the library fails to limit the number of recipient entries processed in a single request. A remote, unauthenticated attacker can exploit this flaw by sending a crafted JWE token with an arbitrarily large recipients...
CVE-2020-11019
CVE-2020-11019 In FreeRDP less than or equal to 2.0.0, when running with logger set to "WLOGTRACE", a possible crash of application could occur due to a read of an invalid array index. Data could be printed as string to local terminal. This has been fixed in 2.1.0. authentication| complexity|...
CVE-2018-7600
CVE-2018-7600 - Drupal 7 Remote Code Execution A Rust implementation of the CVE-2018-7600 exploit targeting vulnerable Drupal 7 installations = 7.57. This CLI reproduces this following PoC flow: it poisons a cached renderable form via the user/password path, extracts a formbuildid, then triggers...
ByteCaster
ByteCaster Swiss Army Knife for payload encryption, obfuscation, and conversion to byte arrays – all in a single command! It supports 3 encryption algorithms, 4 encoding / obfuscation algorithms and 14 output formats. Installation Download the compiled binary or compile Go source code. Usage...
CVE-2025-30144
Summary The fast-jwt library does not properly validate the iss claim based on the RFC https://datatracker.ietf.org/doc/html/rfc7519page-9. Details The iss issuer claim validation within the fast-jwt library permits an array of strings as a valid iss value. This design flaw enables a potential...
Nextjs_RCE_Exploit_Tool
Next.js RCE Exploit Tool CVE-2025-55182 !CAUTION 免责声明 / Disclaimer 本工具仅供安全研究与教学 使用。用户在使用本工具进行测试时,必须确保已获得目标系统的合法授权 。 严禁用于非授权的渗透测试、恶意攻击或任何非法用途。用户感知和利用漏洞所产生的一切风险与法律后果由用户自行承担 ,与本项目开发者无关。 如果不接受此条款,请立即停止下载或使用本工具。 本工具基于公开文章开发,不提供编译好的二进制发布版本,请自行审计代码并编译。 🙏 致谢 / Credits...
cvelistV5
Note 2026-2-17 Adding Additional day of processing for date normalization to addreess potential inconsistencies New Date Normalization schedule: 2/16/26 - 2/28/26 Note 2026-2-10 Record Date NormalizationdeltaLog.json file change The deltaLog.json file normally retains a rolling 30 days worth of C...
CVE-2020-0674-Exploit
CVE-2020-0674 CVE-2020-0674 is a use-after-free vulnerability in the legacy jscript engine. It can be triggered in Internet Explorer. The exploit here is written by maxpl0it but the vulnerability itself was discovered by Qihoo 360 being used in the wild. This exploit simply pops calc. Exploit...
CVE-2021-21315-PoC
CVE-2021-21315-systeminformation This is Proof of Concept for CVE-2021-21315 which affects The System Information Library for Node.JS npm package "systeminformation". npmjs.com/systeminformation "be sure to check or sanitize service parameters that are passed to si.inetLatency, si.inetChecksite,...
CVE-2026-119206
The pypdf Python PDF library is vulnerable to uncontrolled resource consumption (CWE-400) in versions prior to 6.21.3 . A crafted PDF containing a flat page-label number tree with many ranges can cause the page_labels property to take excessive time. This occurs because the property resolves each...
CVE-2026-119206 pypdf: Possible long runtimes when retrieving page labels
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.3, pypdf can take excessive time to retrieve page labels from a crafted PDF containing a flat page-label number tree with many ranges. The pagelabels property resolves each page independently and repeatedly scans the same /Num...
CVE-2019-8601
Exploiting CVE-2019-8601 This is an exploit for a WebKit vulnerability that was originally discovered by Fluoroacetate during the pwn2own competition in Vancouver. While I did not discover this bug, I wrote this exploit to practice my exploit development skills. The original writeup for this...
CVE-2022-24999
CVE-2022-24999 This repository contain exploits samples of the vulnerability we found in the JS library "qs" in december 2021. This vulnerability was fixed in express v4.17.3 & qs v6.10.3 v6.9.7, v6.8.3, v6.7.3, v6.6.1, v6.5.3, v6.4.1, v6.3.3, and v6.2.4. qs Array & String Bombs Vulnerable versio...
CVE-2026-1281-CVE-2026-1340-Ivanti-EPMM-RCE
Ivanti EPMM pre-auth RCE Dummy Target A simple demo application that shows how to reproduce the Ivanti EPMM pre-auth RCE vulnerability CVE-2026-1281 / CVE-2026-1340 for educational and security research purposes. Vulnerability Overview This vulnerability exploits Bash arithmetic expansion behavio...
CVE-2020-0674
CVE-2020-0674 CVE-2020-0674 is a use-after-free vulnerability in the legacy jscript engine. It can be triggered in Internet Explorer. The exploit here is written by maxpl0it but the vulnerability itself was discovered by Qihoo 360 being used in the wild. This exploit simply pops calc. Exploit...
meltdown-exploit
MELTDOWN EXPLOIT POC Speculative optimizations execute code in a non-secure manner leaving data traces in microarchitecture such as cache. Lipp et. al 2018 published their code 2018-01-09 at https://github.com/IAIK/meltdown. Look at their paper for details: https://meltdownattack.com/meltdown.pdf...
CVE-2026-104727
The Sequential Order Numbers for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'condition' Post Meta Array Keys in all versions up to, and including, 3.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated...
EUVD-2026-112689
The Sequential Order Numbers for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'condition' Post Meta Array Keys in all versions up to, and including, 3.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated...
CVE-2026-104727
The Sequential Order Numbers for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting (XSS) in all versions up to and including 3.6.5 . The root cause is insufficient input sanitization and output escaping within the 'condition' Post Meta Array Keys . This allows authenti...