14984 matches found
Unbounded loop on array can lead to DoS
Lines of code Vulnerability details Description: As this array can grow quite large, the transaction’s gas cost could exceed the block gas limit and make it impossible to call this function at all Actual Codes used: src/Swap/BaseV1-core.sol:96: observations.pushObservationblock.timestamp, 0, 0,0;...
Unbounded loop on array can lead to DoS
Lines of code Vulnerability details Description: As this array can grow quite large, the transaction’s gas cost could exceed the block gas limit and make it impossible to call this function at all a push exist but there's no pop in the solution, that means it will continuously only push which wil...
Firefox Insufficient Validation
The vulnerability of Firefox browsers is related to insufficient validation of input data when processing values of array elements. Exploiting this vulnerability can allow a remote attacker to bypass security restrictions...
Denial Of Service (DoS)
radare2 is vulnerable to denial of service. The vulnerability exists due to an off-by-one overflow flaw caused by mismatched array length in corejava.c which allows an attacker to crash the application via malicious input...
CVE-2022-22099
Memory corruption in multimedia due to improper validation of array index in Snapdragon Auto...
CVE-2022-22099
Memory corruption in multimedia due to improper validation of array index in Snapdragon Auto...
CVE-2022-22099
Memory corruption in multimedia due to improper validation of array index in Snapdragon Auto...
CVE-2022-22099
The CVE-2022-22099 entry concerns Qualcomm Snapdragon Auto multimedia code, where memory corruption is triggered by improper validation of an array index in the multimedia path. The vulnerability is characterized as high impact (confidentiality, integrity, and availability affected) with local ac...
Qualcomm Multimedia Input Verification Error Vulnerability
Qualcomm Multimedia is a camera driver component from Qualcomm Incorporated USA. A security vulnerability exists in Qualcomm Multimedia that originates from an improper array index validation leading to multimedia memory corruption...
CVE-2022-22099: Improper Validation of Array Index
Memory corruption in multimedia due to improper validation of array index in Snapdragon Auto...
ASB-A-238379819
a function called 'nlaparse', do not check the len of para, it will check nlatype which can be controlled by userspace with 'maxtype' in this case, it is GSCANMAX, then it access polciy array 'policytype', which OOB access happens...
PT-2025-49464
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description An integer overflow exists in the dfl feature ioctl set irq function when handling the multiplication of hdr.count and sizeofs32 on 32-bit systems. This calculation can overflow, leading...
Denial of service through string value parsing
Fuzz testing, by Ada Logics and sponsored by the CNCF, identified input to functions in the strvals package that can cause an out of memory panic. Out of memory panics cannot be recovered from. Applications that use functions from the strvals package in the Helm SDK can have a Denial of Service...
PHP pg_queryParams Code Execution
The vulnerability of the pgqueryParams function in the PHP programming language is related to the misuse of an uninitialized array. Exploiting this vulnerability allows a remote attacker to execute arbitrary code...
PT-2025-25871
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A vulnerability in the Linux kernel has been identified, specifically in the gpio-fan driver. The issue arises from the driver's failure to check if the cooling state passed to gpio fan...
SUSE SLED15 / SLES15 / openSUSE 15 Security Update : raptor (SUSE-SU-2022:2896-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2022:2896-1 advisory. - CVE-2020-25713: Fixed an out of bounds access triggered via a malformed input file bsc1178903. Tenable...
Ubuntu: Security Advisory (USN-2023-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
PT-2025-25911
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 5.19.0 Description The issue is related to the use of tnum range in array range checking for poke descriptors in the Linux kernel. A problem arises when a range of tnum range0, map-max entries - 1 has limited...
RHEL 8 : php:7.4 (RHSA-2022:6158)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2022:6158 advisory. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. Security Fixes: php: uninitialized array in pgqueryparams leadi...
Moderate: Red Hat Security Advisory: php:7.4 security update
An update for the php:7.4 module is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each...