14982 matches found
CVE-2022-41884: Always-Incorrect Control Flow Implementation
TensorFlow is an open source platform for machine learning. If a numpy array is created with a shape such that one element is zero and the others sum to a large number, an error will be raised. We have patched the issue in GitHub commit 2b56169c16e375c521a3bc8ea658811cc0793784. The fix will be...
CVE-2022-41884 Seg fault in `ndarray_tensor_bridge` due to zero and large inputs in Tensorflow
TensorFlow is an open source platform for machine learning. If a numpy array is created with a shape such that one element is zero and the others sum to a large number, an error will be raised. We have patched the issue in GitHub commit 2b56169c16e375c521a3bc8ea658811cc0793784. The fix will be...
CVE-2022-41884
TensorFlow is an open source platform for machine learning. If a numpy array is created with a shape such that one element is zero and the others sum to a large number, an error will be raised. We have patched the issue in GitHub commit 2b56169c16e375c521a3bc8ea658811cc0793784. The fix will be...
PT-2022-26115
Name of the Vulnerable Software and Affected Versions TensorFlow versions prior to 2.11 TensorFlow version 2.10.1 TensorFlow version 2.9.3 TensorFlow version 2.8.4 Description The issue arises when a numpy array is created with a shape such that one element is zero and the others sum to a large...
Google TensorFlow security vulnerabilities
Google TensorFlow is an end-to-end open source platform for machine learning from Google, Inc. A security vulnerability exists in Google TensorFlow, which stems from an error that can be raised if a numpy array is created with the shape of one element being zero and the sum of the other elements...
SUSE-SU-2022:3995-1 Security update for jackson-databind
This update for jackson-databind fixes the following issues: Update to version 2.13.4.2: - CVE-2022-42003: Fixed missing check in primitive value deserializers to avoid deep wrapper array nesting wrt 'UNWRAPSINGLEVALUEARRAYS' bsc1204370. - CVE-2022-42004: Fixed missing check in...
kernel: drm/virtio: Ensure that objs is not NULL in virtio_gpu_array_put_free()
A flaw was found in the virtio-gpu module in the Linux kernel. If the initialization fails, for example, due to a fault injection, a missing check in the virtiogpuarrayputfree function can cause a NULL pointer dereference, resulting in a denial of service...
kernel: ASoC: cs35l41: Fix an out-of-bounds access in otp_packed_element_t
A vulnerability was found in the Linux kernel's CS35L41 driver. The constant CS35L41NUMOTPELEM is defined as 100 but is used by the arrays otpmap1 and otpmap2, which are both expected to contain only 99 elements. This mismatch causes the code to access memory past the array boundaries when...
kernel: dm ioctl: prevent potential spectre v1 gadget
A vulnerability was found in the Linux kernel's dm-ioctl interface in the lookupioctl function, which accepts a user-provided cmd value that is used to index the ioctls array directly. This issue could lead to an out-of-bounds access if the CPU speculatively executes the array access before cmd i...
kernel: hv_netvsc: NULL pointer dereference in netvsc_get_ethtool_stats()
An issue was discovered in the Linux kernel through 5.16-rc6. netvscgetethtoolstats in drivers/net/hyperv/netvscdrv.c lacks check of the return value of kvmallocarray and will cause the null pointer dereference...
kernel: hv_netvsc: NULL pointer dereference in netvsc_get_ethtool_stats()
An issue was discovered in the Linux kernel through 5.16-rc6. netvscgetethtoolstats in drivers/net/hyperv/netvscdrv.c lacks check of the return value of kvmallocarray and will cause the null pointer dereference...
php: Uninitialized array in pg_query_params() leading to RCE
A vulnerability was found in PHP due to an uninitialized array in pgqueryparams function. When using the Postgres database extension, supplying invalid parameters to the parameterized query may lead to PHP attempting to free memory, using uninitialized data as pointers. This flaw allows a remote...
GSD-2022-1007002 ext2: Use kvmalloc() for group descriptor array
ext2: Use kvmalloc for group descriptor array This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.15.75 by commit...
GSD-2022-1006717 ext2: Use kvmalloc() for group descriptor array
ext2: Use kvmalloc for group descriptor array This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v6.0.3 by commit...
EulerOS 2.0 SP9 : sqlite (EulerOS-SA-2022-2779)
According to the versions of the sqlite package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : An issue was found in fts5UnicodeTokenize in ext/fts5/fts5tokenize.c in Sqlite. A unicode61 tokenizer configured to treat unicode...
Huawei EulerOS: Security Advisory for sqlite (EulerOS-SA-2022-2779)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
PT-2022-34972
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v6.0.3 Description The issue is related to the use of kvmalloc for the group descriptor array in ext2. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel versions...
PT-2022-35555 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions prior to v5.10.150 Description: The issue concerns the use of char for section boundaries in the machvec component. It was introduced in version v2.6.23 and fixed in version v5.10.150. The actual impact and attack...
EulerOS 2.0 SP9 : sqlite (EulerOS-SA-2022-2744)
According to the versions of the sqlite package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : An issue was found in fts5UnicodeTokenize in ext/fts5/fts5tokenize.c in Sqlite. A unicode61 tokenizer configured to treat unicode...
PT-2024-11889
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description The issue is related to an out-of-bounds read in the afe4404 read|write raw function. A KASAN report indicates a global-out-of-bounds read in afe4404 read raw+0x2ce/0x380. The bug is...