134 matches found
CVE-2014-1398
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on comment, user and node statistics properties via unspecified vectors...
CVE-2014-1398
CVE-2014-1398 affects Drupal: the Entity API module (7.x-1.x) before 7.x-1.3 may let remote authenticated users bypass access restrictions on comment, user and node statistics properties via unspecified vectors. Connected documents confirm fixes in 7.x-1.3 (e.g., Fedora updates for drupal7-entity...
CVE-2014-1400
CVE-2014-1400 affects Drupal’s Entity API module (7.x-1.x) before 7.x-1.3. The entity_access API flaw could allow remote authenticated users to bypass access restrictions and read unpublished comments via unspecified vectors. The issue has a published remediation: upgrade to 7.x-1.3. If exploitat...
PT-2018-4168
Name of the Vulnerable Software and Affected Versions Entity API module versions 7.x-1.x before 7.x-1.3 Description The issue concerns the entity wrapper access API in the Entity API module for Drupal, which might allow remote authenticated users to bypass intended access restrictions on certain...
PT-2018-4170
Name of the Vulnerable Software and Affected Versions Entity API module versions 7.x-1.x through 7.x-1.2 Description The issue allows remote authenticated users to bypass intended access restrictions and read unpublished comments. Recommendations For Entity API module versions 7.x-1.x through...
CVE-2014-5170
The Storage API module 7.x before 7.x-1.6 for Drupal might allow remote attackers to execute arbitrary code by leveraging failure to update .htaccess file contents after SA-CORE-2013-003...
PT-2017-8715
Name of the Vulnerable Software and Affected Versions Apache Sling versions prior to 1.0.12 Description The issue arises from the XSS Protection API module, where the encoding performed by the XSSAPI.encodeForJSString method is not restrictive enough. This allows script tags to pass through...
CVE-2015-5498
The Shipwire Drupal module 7.x-1.x is vulnerable (before 7.x-1.03) because it does not enforce the view permission for the shipments overview (admin/shipwire/shipments), allowing remote access to sensitive information. Affected: Shipwire 7.x-1.x prior to 7.x-1.03. Exploitation details are not pro...
CVE-2015-5498
The Shipwire API module 7.x-1.x before 7.x-1.03 for Drupal does not check the view permission for the shipments overview admin/shipwire/shipments, which allows remote attackers to obtain sensitive information via a request to the page...
CVE-2015-5498: Undefined Security Weakness
The Shipwire API module 7.x-1.x before 7.x-1.03 for Drupal does not check the view permission for the shipments overview admin/shipwire/shipments, which allows remote attackers to obtain sensitive information via a request to the page...
PT-2015-6950
Name of the Vulnerable Software and Affected Versions Shipwire API module versions 7.x-1.x before 7.x-1.03 Description The issue allows remote attackers to obtain sensitive information due to a lack of view permission check for the shipments overview page, accessible via a request to the...
Shipwire - Critical - Cross Site Scripting (XSS) - SA-CONTRIB-2015-111
The Shipwire API module handles communication with the Shipwire shipping service. The Shipwire module doesn't check view permission for the shipments overview page when installed admin/shipwire/shipments. Limited non-public information is displayed on the page. CVE identifiers issued CVE-2015-549...
CVE-2015-2197
Cross-site scripting XSS vulnerability in the Entity API module before 7.x-1.6 for Drupal allows remote authenticated users to inject arbitrary web script or HTML via a field label in the Token API...
PT-2015-5658
Name of the Vulnerable Software and Affected Versions Entity API module versions prior to 7.x-1.6 Description A cross-site scripting XSS issue exists, allowing remote authenticated users to inject arbitrary web script or HTML via a field label in the Token API. Recommendations For versions prior ...
Drupal Entity API Module Field Label Cross-Site Scripting Vulnerability
Drupal is an open source content management platform. A cross-site scripting vulnerability exists in the Drupal Entity API module field labels due to the program failing to properly filter user-supplied input. An attacker could be allowed to exploit this vulnerability to steal cookie-based...
Design/Logic Flaw
The Entity API module 7.x-1.x before 7.x-1.2 for Drupal, when using the a Views field or b area plugins, allows remote attackers to read restricted entities via the 1 field, 2 header, or 3 footer of a View. NOTE: this identifier was SPLIT from CVE-2013-4273 per ADT5 due to different researcher...
CVE-2013-7391
The Entity API module 7.x-1.x before 7.x-1.2 for Drupal, when using the a Views field or b area plugins, allows remote attackers to read restricted entities via the 1 field, 2 header, or 3 footer of a View. NOTE: this identifier was SPLIT from CVE-2013-4273 per ADT5 due to different researcher...
CVE-2013-7391
The vulnerability CVE-2013-7391 affects the Drupal contributed Entity API module (7.x-1.x) prior to 7.x-1.2. When using the Views field or area plugins, it allows remote attackers to read restricted entities via the View’s field, header, or footer. This is caused by insufficient access checks in ...
CVE-2013-4273
The Drupal Entity API module (7.x-1.x) before 7.x-1.2 fails to properly enforce access restrictions for node comments when used with Views field/area plugins, allowing remote authenticated users to read restricted comments via a View (and is split from CVE-2013-4273’s View vector). The issue spec...
PT-2014-3414
Name of the Vulnerable Software and Affected Versions Entity API module versions 7.x-1.x before 7.x-1.2 for Drupal Description The issue allows remote attackers to read restricted entities via the field, header, or footer of a View when using the Views field or area plugins. Recommendations For...