Lucene search
+L

1928 matches found

Positive Technologies
Positive Technologies
•added 2026/09/27 12:00 a.m.•1 views

PT-2026-99515

Name of the Vulnerable Software and Affected Versions wolfSSL versions prior to 5.9.3 Description An issue exists when an application enables both Online Certificate Status Protocol OCSP and Certificate Revocation List CRL revocation checking on one WOLFSSL CTX or certificate manager. In this...

5.3CVSS5.8AI score0.0015EPSS
SaveExploits0References6
Positive Technologies
Positive Technologies
•added 2026/09/27 12:00 a.m.•4 views

PT-2026-99517

Name of the Vulnerable Software and Affected Versions wolfSSL versions 5.3.0 through 5.9.2 Description When NO SESSION CACHE REF is undefined, the wolfSSL get session function returns a ClientSession reference to the process-global SessionCache instead of a session object. The...

5.4CVSS5.8AI score0.00096EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2026/09/27 12:00 a.m.•11 views

Linux Distros Unpatched Vulnerability : CVE-2026-94418

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Under WOLFSSLSMALLCERTVERIFY, ProcessPeerCertParse runs the certificate signature check separately from the parse to keep peak memory down, then merges the two...

7.5CVSS6AI score0.00093EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2026/09/27 12:00 a.m.•11 views

Linux Distros Unpatched Vulnerability : CVE-2026-15442

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - In all builds that make use of DTLS, including default builds, there is a series of conditional states during the TLS shutdown which could lead to a...

5.3CVSS6AI score0.00304EPSS
SaveExploits0References3
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/09/27 12:00 a.m.•5 views

CVE-2026-15442: Use After Free

In all builds that make use of DTLS, including default builds, there is a series of conditional states during the TLS shutdown which could lead to a heap-use-after free. If an application ended up getting a partial wolfSSLread which is sometimes caused by a small user buffer passed in, then calle...

2.3CVSS6.1AI score0.00304EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2026/09/27 12:00 a.m.•3 views

PT-2026-99516

Name of the Vulnerable Software and Affected Versions wolfSSL affected versions not specified Description When the WOLFSSL SMALL CERT VERIFY option is enabled, the ProcessPeerCertParse function executes the certificate signature check separately from the parsing process to reduce peak memory usag...

2.3CVSS5.9AI score0.00093EPSS
SaveExploits0References4
Tenable Nessus
Tenable Nessus
•added 2026/09/27 12:00 a.m.•11 views

Linux Distros Unpatched Vulnerability : CVE-2026-93302

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - MatchTrustedPeer ignores the public key used, leading to forged CA clones passing verification. Affected builds are any that enable the macro WOLFSSLTRUSTPEERCE...

8.3CVSS5.9AI score0.00201EPSS
SaveExploits0References3
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/09/27 12:00 a.m.•6 views

CVE-2026-89102: Improper Certificate Validation

In wolfSSL versions 5.7.2 through 5.9.2 there is a client-side implementation flaw in RFC 6961, multiple OCSP response stapling, which can lead to certificate forgery. When a wolfSSL client enables OCSP stapling with the HAVECERTIFICATESTATUSREQUESTV2 feature and calls wolfSSLUseOCSPStaplingV2ssl...

8.3CVSS5.9AI score0.00175EPSS
SaveExploits0References3
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/09/27 12:00 a.m.•5 views

CVE-2026-94417: Improper Check for Certificate Revocation

When an application enables both OCSP and CRL revocation checking on one WOLFSSLCTX or certificate manager, wolfSSL skips the CRL check for any peer certificate that carries no Authority Information Access OCSP URL, and accepts a certificate the loaded CRL lists as revoked. The soft-fail policy f...

5.3CVSS5.8AI score0.0015EPSS
SaveExploits0References2
RedhatCVE
RedhatCVE
•added 2026/09/22 6:06 a.m.•7 views

CVE-2026-82208

A flaw was found in libcurl when using the wolfSSL backend. When CA Certificate Authority caching is enabled and a CURLOPTSSLCTXFUNCTION callback is used to replace the trust store, libcurl can silently reinstall the cached store. This can lead to a scenario where a certificate that should be...

7.5CVSS7.1AI score0.00407EPSS
SaveExploits1References6
Kitploit
Kitploit
•added 2026/09/19 9:08 a.m.•10 views

wolfCOSE v2.0.0

wolfCOSE wolfCOSE is a lightweight C library implementing CBOR RFC 8949, COSE RFC 9052/9053, and post-quantum ML-DSA for COSE RFC 9964 using wolfSSL as the crypto backend. Main Features Complete RFC 9052 message set : all six COSE message types, including multi-signer COSESign and multi-recipient...

6.1AI score
SaveExploits0References3
AstraLinux
AstraLinux
•added 2026/09/14 12:41 p.m.•6 views

Astra Linux – Vulnerability in curl

With the wolfSSL backend, when CA caching is enabled and a CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. This results in a certificate trusted by the cached store but rejected by the callback-selected store bei...

7.5CVSS5.9AI score0.00407EPSS
SaveExploits1References1
Snyk
Snyk
•added 2026/09/06 7:14 p.m.•5 views

Improper Certificate Validation

Overview Affected versions of this package are vulnerable to Improper Certificate Validation in the CURLOPTSSLCTXFUNCTION callback process when CA caching is enabled with the wolfSSL backend. An attacker can bypass intended trust store restrictions by presenting a certificate that is trusted by t...

8.3CVSS5.8AI score0.00407EPSS
SaveExploits1References2
OSV
OSV
•added 2026/09/06 6:17 p.m.•9 views

AZL-99756 CVE-2026-82208 affecting package curl 8.11.1-11

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•13 views

AZL-99849 CVE-2026-82208 affecting package rust 1.90.0-10

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•12 views

ALPINE-CVE-2026-82208

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
OSV
OSV
•added 2026/09/06 6:17 p.m.•8 views

AZL-99798 CVE-2026-82208 affecting package mysql 8.0.46-1

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
NVD
NVD
•added 2026/09/06 6:17 p.m.•14 views

CVE-2026-82208

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS0.00407EPSS
SaveExploits1References3
OSV
OSV
•added 2026/09/06 6:17 p.m.•11 views

AZL-99840 CVE-2026-82208 affecting package rust 1.75.0-30

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

7.5CVSS7.2AI score0.00407EPSS
SaveExploits1References1
Cvelist
Cvelist
•added 2026/09/06 5:49 p.m.•64 views

CVE-2026-82208 wolfSSL CA-cache hit overrides callback

With the wolfSSL backend, when CA caching is enabled and an CURLOPTSSLCTXFUNCTION callback replaces the trust store, libcurl can silently reinstall the cached store after the callback returns. A certificate trusted by the cached store but rejected by the callback-selected store is then incorrectl...

0.00407EPSS
SaveExploits1References3
Rows per page
Query Builder