Lucene search
+L

2490 matches found

Kitploit
Kitploit
•added 2026/11/14 8:19 a.m.•42 views

wolfCOSE

wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...

6.3AI score
SaveExploits0References1
Kitploit
Kitploit
•added 2026/11/14 5:31 a.m.•74 views

ml-kem-key-recovery

Full key recovery from a partial Fujisaki-Okamoto comparison in wolfSSL ML-KEM CVE-2026-6330 NEON and CVE-2026-10097 AVX2. Fixed in wolfSSL 5.9.2. The full technical write-up is published as Cryptology ePrint Archive, Paper 2026/1682 local copy in paper/. See Citation below. Introduction ML-KEM...

8.3CVSS6AI score0.00262EPSS
SaveExploits0References7
Kitploit
Kitploit
•added 2026/11/14 5:21 a.m.•37 views

wolfssl

wolfSSL Embedded SSL/TLS Library The wolfSSL embedded SSL library formerly CyaSSL is a lightweight SSL/TLS library written in ANSI C and targeted for embedded, RTOS, and resource-constrained environments - primarily because of its small size, speed, and feature set. It is commonly used in standar...

6AI score
SaveExploits0References1
Kitploit
Kitploit
•added 2026/11/11 3:51 p.m.•37 views

cve-2022-25640-exploit

Exploiting CVE-2022-25640 using scapy See CVE-2022-25640.ipynb. CVE-2022-25640 is a vulnerability in wolfSSL before 5.2. It allows a client to circumvent mututation authentication in TLS 1.3 connections...

7.5CVSS7.6AI score0.01364EPSS
SaveExploits0References1
osv_cleanstart
osv_cleanstart
•added 2026/10/31 2:07 p.m.•13 views

CLEANSTART-2024-UF62109 In wolfSSL before 5

Security vulnerability affects the wolfssl package. In wolfSSL before 5...

7.5CVSS7.2AI score0.05763EPSS
SaveExploits2References3
osv_cleanstart
osv_cleanstart
•added 2026/10/31 2:07 p.m.•15 views

CLEANSTART-2024-SD53431 wolfSSL prior to 5

Security vulnerability affects the wolfssl package. wolfSSL prior to 5...

5.3CVSS5.9AI score0.00513EPSS
SaveExploits0References3
osv_cleanstart
osv_cleanstart
•added 2026/10/31 2:07 p.m.•14 views

CLEANSTART-2024-SU62102 Fault Injection vulnerability in RsaPrivateDecryption function in wolfssl/wolfcrypt/src/rsa

Security vulnerability affects the wolfssl package. Fault Injection vulnerability in RsaPrivateDecryption function in wolfssl/wolfcrypt/src/rsa...

8.8CVSS6AI score0.00576EPSS
SaveExploits0References3
F5 Networks
F5 Networks
•added 2026/10/22 3:36 a.m.•27 views

K000163835: wolfSSL vulnerability CVE-2026-3547

Security Advisory Description Out-of-bounds read in ALPN parsing due to incomplete validation. wolfSSL 5.8.4 and earlier contained an out-of-bounds read in ALPN handling when built with ALPN enabled HAVEALPN / --enable-alpn. A crafted ALPN protocol list could trigger an out-of-bounds read, leadin...

7.5CVSS5.8AI score0.00296EPSS
SaveExploits0
osv_azl
osv_azl
•added 2026/10/20 9:17 p.m.•17 views

AZL-109953 CVE-2026-87866 affecting package curl 8.11.1-11

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

6.1AI score0.0051EPSS
SaveExploits0References1
osv_alpine
osv_alpine
•added 2026/10/20 9:17 p.m.•26 views

ALPINE-CVE-2026-87866

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

9.1CVSS6.1AI score0.0051EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2026/10/20 9:17 p.m.•16 views

AZL-110028 CVE-2026-87866 affecting package mysql 8.0.46-2

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

6.1AI score0.0051EPSS
SaveExploits0References1
NVD
NVD
•added 2026/10/20 9:17 p.m.•16 views

CVE-2026-87866

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

9.1CVSS0.0051EPSS
SaveExploits0References3
osv_debian
osv_debian
•added 2026/10/20 9:17 p.m.•33 views

DEBIAN-CVE-2026-87866

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

9.1CVSS6.1AI score0.0051EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2026/10/20 9:17 p.m.•31 views

AZL-110211 CVE-2026-87866 affecting package rust 1.96.1-2

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

6.1AI score0.0051EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2026/10/20 9:17 p.m.•17 views

AZL-110133 CVE-2026-87866 affecting package rust 1.75.0-31

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

6.1AI score0.0051EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2026/10/20 9:17 p.m.•18 views

AZL-110286 CVE-2026-87866 affecting package tensorflow 2.16.1-11

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

6.1AI score0.0051EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2026/10/20 9:17 p.m.•17 views

AZL-109920 CVE-2026-87866 affecting package cmake 3.30.3-15

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

6.1AI score0.0051EPSS
SaveExploits0References1
UbuntuCve
UbuntuCve
•added 2026/10/20 9:17 p.m.•21 views

CVE-2026-87866

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

9.1CVSS6.1AI score0.0051EPSS
SaveExploits0References2
CVE
CVE
•added 2026/10/20 8:16 p.m.•90 views

CVE-2026-87866

When built with wolfSSL , curl is vulnerable to a public-key pinning bypass. During a TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the certificate—tricked by a manipulated validity length field —extracts and matches a different embedded key. This results in...

9.1CVSS6.1AI score0.0051EPSS
SaveExploits0References3
Mend
Mend
•added 2026/10/20 8:16 p.m.•17 views

CVE-2026-87866

When built with wolfSSL, curl can successfully validate a pinned public key hash against a key the TLS peer does not possess. During the TLS handshake, wolfSSL validates the connection, but curl's subsequent re-parsing of the same certificate - tricked by a manipulated validity length field -...

8.2CVSS6.1AI score0.0051EPSS
SaveExploits0References4
Rows per page
Query Builder