87 matches found
org.springframework:spring-aop (2.0-m1), org.springframework:spring-beans (2.0-m1) +13 more potentially affected by CVE-2018-1271 via org.springframework:spring-core (2.0-m1)
org.springframework:spring-core MAVEN version 2.0-m1 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 2.0-m1 - org.springframework:spring-beans 2.0-m1 -...
org.acegisecurity:acegi-security (>=1.0.0-rc2, <=1.0.0), org.acegisecurity:acegi-security-adapters (1.0.0) +20 more potentially affected by CVE-2018-1271 via org.springframework:spring-core (2.0-m2)
org.springframework:spring-core MAVEN version 2.0-m2 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.acegisecurity:acegi-security =1.0.0-rc2, =1.0.0 - org.acegisecurity:acegi-security-adapters...
org.acegisecurity:acegi-security (1.0.4), org.acegisecurity:acegi-security-adapters (1.0.4) +34 more potentially affected by CVE-2018-1271 via org.springframework:spring-core (2.0.4)
org.springframework:spring-core MAVEN version 2.0.4 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.acegisecurity:acegi-security 1.0.4 - org.acegisecurity:acegi-security-adapters 1.0.4 -...
org.jasig.service:person-directory (1.0.1), org.jasig:person-directory (1.0.0) +26 more potentially affected by CVE-2018-1271 via org.springframework:spring-core (2.0.3)
org.springframework:spring-core MAVEN version 2.0.3 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.jasig.service:person-directory 1.0.1 - org.jasig:person-directory 1.0.0 -...
com.gestalt.common.injection:common-injection-spring-impl (0.8), com.google.code.struts2webflow:struts2webflow-parent (1.0.4) +39 more potentially affected by CVE-2018-1271 via org.springframework:spring-core (2.0.1)
org.springframework:spring-core MAVEN version 2.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - com.gestalt.common.injection:common-injection-spring-impl 0.8 -...
org.springframework:spring-aop (2.0-m4), org.springframework:spring-beans (2.0-m4) +7 more potentially affected by CVE-2018-1271 via org.springframework:spring-core (2.0-m4)
org.springframework:spring-core MAVEN version 2.0-m4 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 2.0-m4 - org.springframework:spring-beans 2.0-m4 -...
org.springframework:spring-aop (1.2.2), org.springframework:spring-beans (1.2.2) +10 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (1.2.2)
org.springframework:spring-core MAVEN version 1.2.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 1.2.2 - org.springframework:spring-beans 1.2.2 -...
org.springframework:spring-aop (1.2.3), org.springframework:spring-beans (1.2.3) +10 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (1.2.3)
org.springframework:spring-core MAVEN version 1.2.3 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 1.2.3 - org.springframework:spring-beans 1.2.3 -...
org.springframework:spring-aop (1.2.4), org.springframework:spring-beans (1.2.4) +10 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (1.2.4)
org.springframework:spring-core MAVEN version 1.2.4 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 1.2.4 - org.springframework:spring-beans 1.2.4 -...
org.springframework:spring-aop (2.0-m1), org.springframework:spring-beans (2.0-m1) +13 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (2.0-m1)
org.springframework:spring-core MAVEN version 2.0-m1 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 2.0-m1 - org.springframework:spring-beans 2.0-m1 -...
org.springframework:spring-aop (2.0-m4), org.springframework:spring-beans (2.0-m4) +7 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (2.0-m4)
org.springframework:spring-core MAVEN version 2.0-m4 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.springframework:spring-aop 2.0-m4 - org.springframework:spring-beans 2.0-m4 -...
com.gestalt.common.injection:common-injection-spring-impl (0.8), com.google.code.struts2webflow:struts2webflow-parent (1.0.4) +39 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (2.0.1)
org.springframework:spring-core MAVEN version 2.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - com.gestalt.common.injection:common-injection-spring-impl 0.8 -...
org.jasig.service:person-directory (1.0.1), org.jasig:person-directory (1.0.0) +26 more potentially affected by CVE-2018-1257 via org.springframework:spring-core (2.0.3)
org.springframework:spring-core MAVEN version 2.0.3 is affected by a known vulnerability. The following packages have a transitive dependency on org.springframework:spring-core and may be impacted: - org.jasig.service:person-directory 1.0.1 - org.jasig:person-directory 1.0.0 -...
GHSA-8MR5-H28G-36QX Spring AOP functionality (Struts) vulnerable to DoS attack
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
Spring AOP functionality (Struts) vulnerable to DoS attack
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
CVE-2017-9787
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
Apache Struts Spring AOP DoS Vulnerability (S2-049) - Linux
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack when user was properly authenticated. This VT has been deprecated and merged into the VT SPDX-FileCopyrightText: 2017 Greenbone AG Some text descriptions might be excerpted from a referenced...
Apache Struts 2.5.x < 2.5.12 Multiple DoS (S2-047) (S2-049)
The version of Apache Struts running on the remote host is 2.5.x prior to 2.5.12. It is, therefore, affected by multiple vulnerabilities : - A denial of service vulnerability exists when handling a specially crafted URL in a form field when the built-in URL validator is used. An unauthenticated,...