28723 matches found
CVE-2025-29268
ALLNET ALL-RUT22GW v3.3.8 was discovered to store hardcoded credentials in the libicos.so library...
PT-2025-49113
Name of the Vulnerable Software and Affected Versions H3C Magic B0 versions up to 100R002 Description A weakness exists in H3C Magic B0 up to version 100R002. The issue involves the EditWlanMacList function within the /goform/aspForm file. Manipulation of the param argument can lead to a buffer...
ZEIT Next.js Remote Code Execution Vulnerability
Next.js is a React framework for building full-stack web applications. ZEIT Next.js suffers from a remote code execution vulnerability that stems from Next.js versions 15.x and 16.x relying on a flawed React server-side DOM package when using App Router, which can be exploited by an attacker to...
CVE-2025-29268
ALLNET ALL-RUT22GW v3.3.8 was discovered to store hardcoded credentials in the libicos.so library...
Synology Router Manager path traversal vulnerability
Synology Router Manager SRM is a software used to configure and manage Synology routers from China-based Synology. A path traversal vulnerability exists in Synology Router Manager SRM, which originates from a remote authenticated user being able to read .srt files...
ALLNET ALL-RUT22GW security vulnerabilities
ALLNET ALL-RUT22GW is a wireless router from ALLNET Germany. A security vulnerability exists in ALLNET ALL-RUT22GW version v3.3.8, which stems from the incorrect operation of the parameter command in the popen.cgi endpoint, and could lead to OS command injection...
CVE-2025-65883: Insufficient Session Expiration
A vulnerability has been identified in Genexis Platinum P4410 router Firmware P4410-V2–1.41 that allows a local network attacker to achieve Remote Code Execution RCE with root privileges. The issue occurs due to improper session invalidation after administrator logout. When an administrator logs...
Next.js is vulnerable to RCE in React flight protocol
A vulnerability affects certain React packages1 for versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as CVE-2025-55182. Fixed in: React: 19.0.1, 19.1.2, 19.2.1 Next.js:...
GHSA-9QR9-H5GF-34MP Next.js is vulnerable to RCE in React flight protocol
A vulnerability affects certain React packages1 for versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as CVE-2025-55182. Fixed in: React: 19.0.1, 19.1.2, 19.2.1 Next.js:...
CVE-2025-34319 TOTOLINK N300RT <= V2.1.8-B20201030.1539 Boa formWsc RCE
TOTOLINK N300RT wireless router firmware versions prior to V3.4.0-B20250430 discovered in V2.1.8-B20201030.1539 contain an OS command injection vulnerability in the Boa formWsc handling functionality. An unauthenticated attacker can send specially crafted requests to trigger command execution via...
EUVD-2025-200722
Malicious code in kwp-router npm...
Malicious code in kwp-router (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 0b9ede748713472b716d7f508167d66d972607368a0674962d092728ee8ed184 The package kwp-router was found to contain malicious code. Source: ghsa-malware a55b4e54ef732ba70cdf1b376d19fe90c45e48f36c812166e99545e9e798b807 Any...
Malicious Package
Overview kwp-router is a malicious package. This package contains malicious code, and its content was removed from the official package manager. While this package might be attempting to impersonate a valid organization, there is no connection between that organization and this package authorship...
Malware in kwp-router
Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outsid...
MAL-2025-191970 Malicious code in kwp-router (npm)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector 0b9ede748713472b716d7f508167d66d972607368a0674962d092728ee8ed184 The package kwp-router was found to contain malicious code. Source: ghsa-malware a55b4e54ef732ba70cdf1b376d19fe90c45e48f36c812166e99545e9e798b807 Any...
CVE-2025-60854
A vulnerability has been found in D-Link R15 AX1500 1.20.01 and below. By manipulating the model name parameter during a password change request in the web administrator page, it is possible to trigger a command injection in httpd...
Next.js Framework React Server Components Remote Code Execution (CVE-2025-55182)
The Next.js Framework on the remote host is affected by a remote code execution vulnerability: - A pre-authentication remote code execution vulnerability exists in React Server Components versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 including the following packages: react-server-dom-parcel,...
EUVD-2025-200290
A vulnerability has been found in D-Link R15 AX1500 1.20.01 and below. By manipulating the model name parameter during a password change request in the web administrator page, it is possible to trigger a command injection in httpd...
PT-2026-2533
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 6.18.0-rc4-virtme-g36b21a067510 Description The Linux kernel contains a use-after-free flaw within the mlxsw spectrum router component. This issue occurs when dereferencing a neighbour, potentially leading to...
Tenda HG9 Router auth RCE
Tenda ONT GPON AC1200 Dual band WiFi HG9 v1.0.1 is vulnerable to Command Injection via the Ping function. from kittysploit import from lib.protocols.http.httpclient import Httpclient from lib.protocols.http.httplogin import Httplogin from lib.exploit.handler import Handler from urllib.parse impor...