5829 matches found
CVE-2026-40260 pypdf: Manipulated XMP metadata entity declarations can exhaust RAM
pypdf is a free and open-source pure-python PDF library. In versions prior to 6.10.0, manipulated XMP metadata entity declarations can exhaust RAM. An attacker who exploits this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the XMP metadata. This issue has...
a-data-processing (0.0.1), ab-data-processing (0.0.1) +622 more potentially affected by CVE-2026-40260 via pypdf (>=3.1.0, <=6.9.2)
pypdf PYPI version =3.1.0, =0.1.1, =0.9.1, =0.0.2, =0.0.1, =0.1.4, =0.1.0a0.dev0, =0.2.0a0, =0.0.1, =0.0.4, =0.0.9 and more Source cves: CVE-2026-40260 Source advisory: MEND:CVE-2026-40260...
CVE-2026-40260
CVE-2026-40260 affects the Python library pypdf (formerly PyPDF2). The issue arises when parsing manipulated XMP metadata declarations within a PDF, causing excessive memory (RAM) usage for memory-constrained parsing workloads. Impact is described as potential large memory consumption during XMP ...
CVE-2026-40260
pypdf is a free and open-source pure-python PDF library. In versions prior to 6.10.0, manipulated XMP metadata entity declarations can exhaust RAM. An attacker who exploits this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the XMP metadata. This issue has...
CVE-2026-40260
pypdf is a free and open-source pure-python PDF library. In versions prior to 6.10.0, manipulated XMP metadata entity declarations can exhaust RAM. An attacker who exploits this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the XMP metadata. This issue has...
agatta (>=1.0.0, <=1.0.2), agentbuddy (0.1.1.dev33) +102 more potentially affected by CVE-2026-41314 via pypdf (3.17.4)
pypdf PYPI version 3.17.4 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agatta =1.0.0, =0.0.3, =0.0.1, =1.1.0, =0.0.2, =1.2.0, =0.6.7, =1.2.1, =0.1.3, =0.0.1, =0.8.2 - cadenai 0.1.0 and more Source cves: CVE-2026-41314...
docrx (>=0.0.1, <=0.0.10), paperreview (0.1.0) +1 more potentially affected by CVE-2026-41314 via pypdf (3.15.0)
pypdf PYPI version 3.15.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docrx =0.0.1, =1.1.11, =1.1.13 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
calibreweb (0.6.20) potentially affected by CVE-2026-41314 via pypdf (3.5.2)
pypdf PYPI version 3.5.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - calibreweb 0.6.20 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
agatta (>=0.9.1, <=0.9.4), automate3 (2023.11.7) +5 more potentially affected by CVE-2026-41314 via pypdf (3.17.0)
pypdf PYPI version 3.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agatta =0.9.1, =1698926697.0.0, =9.2.3, =9.2.6 - uniflow 0.0.7 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
automateboringstuff3 (2024.10.1), calibreweb (0.6.24) +6 more potentially affected by CVE-2026-41314 via pypdf (5.0.1)
pypdf PYPI version 5.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - automateboringstuff3 2024.10.1 - calibreweb 0.6.24 - forgy =0.1.0, =0.1.0rc1, =0.0.12, =0.0.16 Source cves: CVE-2026-41314 Source advisory:...
chellow (>=1688456919.0.0, <=1692616986.0.0), cybrex (>=1.0.1, <=1.0.7) potentially affected by CVE-2026-41314 via pypdf (3.12.0)
pypdf PYPI version 3.12.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1688456919.0.0, =1.0.1, =1.0.7 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
cocpyth (>=0.1.1, <=0.1.2), pretix (>=4.19.0, <=4.20.4) potentially affected by CVE-2026-41314 via pypdf (3.8.1)
pypdf PYPI version 3.8.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cocpyth =0.1.1, =4.19.0, =4.20.4 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
aiagents4pharma (>=0.0.0, <=1.49.1), aiagents4pharma-ansh (0.0.0) +67 more potentially affected by CVE-2026-41314 via pypdf (>=6.0.0, <=6.10.1)
pypdf PYPI version =6.0.0, =0.0.0, =1.1.0, =1.0.0a3, =0.2.0, =3.1.0, =0.2.0, =0.2.0, =0.0.3, =0.4.1, =6.2.61, =1.0.20, =1.0.31 and more Source cves: CVE-2026-41314 Source advisory: SNYK:PYTHON-PYPDF-16097899...
pypdf: Manipulated FlateDecode image dimensions can exhaust RAM
Impact An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing an image using /FlateDecode with large size values. Patches This has been fixed in pypdf==6.10.2. Workarounds If you cannot upgrade yet, consider applying the changes fro...
pymorant (>=1.0.145, <=1.0.156) potentially affected by CVE-2026-41314 via pypdf (3.16.1)
pypdf PYPI version 3.16.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - pymorant =1.0.145, =1.0.156 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
smart-pdf (2023.9.11.1) potentially affected by CVE-2026-41314 via pypdf (3.16.0)
pypdf PYPI version 3.16.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - smart-pdf 2023.9.11.1 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
add-staves (>=0.1.1, <=0.2.4), agentix-agent-sdk (0.1.0) +135 more potentially affected by CVE-2026-41314 via pypdf (4.3.1)
pypdf PYPI version 4.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - add-staves =0.1.1, =0.0.1, =0.0.1.dev1, =3.0.0, =0.1.0, =1.0.0, =0.3.8.0, =0.3.2, =0.1.6, =1725528079.0.0, =0.1.4, =0.1.9 and more Source cves:...
criscostack (1.0.0), neumai (>=0.0.9, <=0.0.36) +2 more potentially affected by CVE-2026-41314 via pypdf (3.9.1)
pypdf PYPI version 3.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - criscostack 1.0.0 - neumai =0.0.9, =0.0.17, =2023.6.0, =2024.4.0 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...
GHSA-X284-J5P8-9C5P pypdf: Manipulated FlateDecode image dimensions can exhaust RAM
Impact An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing an image using /FlateDecode with large size values. Patches This has been fixed in pypdf==6.10.2. Workarounds If you cannot upgrade yet, consider applying the changes fro...
iiiflow (>=0.1.0, <=1.3.2), mayan-edms (>=4.5.0, <=4.5.8) potentially affected by CVE-2026-41314 via pypdf (3.14.0)
pypdf PYPI version 3.14.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - iiiflow =0.1.0, =4.5.0, =4.5.8 Source cves: CVE-2026-41314 Source advisory: OSV:GHSA-X284-J5P8-9C5P...