5814 matches found
Excessive Iteration
Overview pypdf is an A pure-python PDF library capable of splitting, merging, cropping, and transforming PDF files Affected versions of this package are vulnerable to Excessive Iteration in its text extraction of pages that contain XForm objects, which processes those objects without limiting the...
sereto (0.2.1), ten8t (>=0.0.14, <=0.0.21) potentially affected by CVE-2026-84309 via pypdf (5.3.1)
pypdf PYPI version 5.3.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - sereto 0.2.1 - ten8t =0.0.14, =0.0.21 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
docrx (>=0.0.1, <=0.0.10), paperreview (0.1.0) +1 more potentially affected by CVE-2026-84309 via pypdf (3.15.0)
pypdf PYPI version 3.15.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docrx =0.0.1, =1.1.11, =1.1.13 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
docat (1.0.0) potentially affected by CVE-2026-84309 via pypdf (4.0.0)
pypdf PYPI version 4.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - docat 1.0.0 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-84309 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
calibreweb (0.6.25), cewler (>=1.3.0, <=1.3.1) +8 more potentially affected by CVE-2026-84309 via pypdf (5.4.0)
pypdf PYPI version 5.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - calibreweb 0.6.25 - cewler =1.3.0, =1.1.2, =1.1.0, =1.2.0, =2025.3.0, =0.2.2, =28.3.2, =29.1.2 - ten8t 0.0.22 Source cves: CVE-2026-84309 Source...
athena-starship (>=0.0.3, <=0.0.6), conflare (>=0.1.2, <=0.1.3) +11 more potentially affected by CVE-2026-84309 via pypdf (4.1.0)
pypdf PYPI version 4.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - athena-starship =0.0.3, =0.1.2, =2.2.0, =0.0.1, =3.3.0, =1.14.0, =0.1.4, =4.6.2, =0.1.0, =0.1.58 Source cves: CVE-2026-84309 Source advisory:...
nerxiv (>=0.0.1, <=1.1.0), osfexport (>=0.1.4, <=1.0.1) +3 more potentially affected by CVE-2026-84309 via pypdf (5.7.0)
pypdf PYPI version 5.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - nerxiv =0.0.1, =0.1.4, =0.0.1, =0.3.3, =30.0.8, =30.0.9 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
agentyc (>=0.1.0, <=0.3.3), aiagents4pharma (>=0.0.0, <=1.49.1) +103 more potentially affected by CVE-2026-84309 via pypdf (>=6.0.0, <=6.15.0)
pypdf PYPI version =6.0.0, =0.1.0, =0.0.0, =1.1.0, =1.0.0a3, =0.2.0, =1.1.0, =3.1.0, =3.9.11, =0.12.6.post1, =0.2.0, =0.2.0, =0.0.3, =0.0.5 and more Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
ai-enterprise-agent (>=0.0.4, <=0.0.9), almax-common (>=1.0.5.dev20240601224039, <=1.0.7.dev20240801212517) +25 more potentially affected by CVE-2026-84309 via pypdf (4.2.0)
pypdf PYPI version 4.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - ai-enterprise-agent =0.0.4, =1.0.5.dev20240601224039, =2024.7.4, =0.6.22, =0.2.1, =0.2.0, =0.0.5, =0.2.1, =3.3.2, =0.1.0, =0.0.1, =4.7.1, =0.1.0, =0.1...
mimir-ai (0.0.3), rara-digitizer (>=1.0.0, <=1.5.8) potentially affected by CVE-2026-84309 via pypdf (5.0.0)
pypdf PYPI version 5.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - mimir-ai 0.0.3 - rara-digitizer =1.0.0, =1.5.8 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
bondai (>=0.1.0, <=0.3.0b2) potentially affected by CVE-2026-84309 via pypdf (3.15.1)
pypdf PYPI version 3.15.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - bondai =0.1.0, =0.3.0b2 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
chat-with-mlx (>=0.1.0, <=0.1.11), crewai-files (>=1.9.0, <=1.10.1a1) +9 more potentially affected by CVE-2026-84309 via pypdf (4.0.2)
pypdf PYPI version 4.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chat-with-mlx =0.1.0, =1.9.0, =3.2.0, =1.2.1, =1.0.9, =0.0.0, =0.1.2, =0.73.0, =0.94.0 Source cves: CVE-2026-84309 Source advisory:...
py40kie (>=0.1.0, <=0.2.2) potentially affected by CVE-2026-84309 via pypdf (3.12.2)
pypdf PYPI version 3.12.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - py40kie =0.1.0, =0.2.2 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
aiexec-base (0.6.4), ano-code (>=0.1.6, <=0.1.11) +38 more potentially affected by CVE-2026-84309 via pypdf (5.1.0)
pypdf PYPI version 5.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - aiexec-base 0.6.4 - ano-code =0.1.6, =0.0.1, =1.0.0, =0.6.0, =0.0.3, =0.1.0, =0.3.1, =3.3.6, =1.0.16, =0.2.37, =1.0.0, =0.1.11, =0.1.24 and more Sourc...
cocpyth (>=0.1.1, <=0.1.2), pretix (>=4.19.0, <=4.20.4) potentially affected by CVE-2026-84309 via pypdf (3.8.1)
pypdf PYPI version 3.8.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cocpyth =0.1.1, =4.19.0, =4.20.4 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
pretix (>=4.17.0, <=4.17.1), providentia (2.4.0) potentially affected by CVE-2026-84309 via pypdf (3.4.1)
pypdf PYPI version 3.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - pretix =4.17.0, =4.17.1 - providentia 2.4.0 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...
pypdf: Possible infinite loop for TreeObject.insert_child
Impact An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires a usually writing code path where TreeObject.insertchild is involved. Patches This has been fixed in pypdf==6.16.0. Workarounds If you cannot upgrade yet, consider applying the changes fr...
automateboringstuff3 (2024.10.1), calibreweb (0.6.24) +6 more potentially affected by CVE-2026-84309 via pypdf (5.0.1)
pypdf PYPI version 5.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - automateboringstuff3 2024.10.1 - calibreweb 0.6.24 - forgy =0.1.0, =0.1.0rc1, =0.0.12, =0.0.16 Source cves: CVE-2026-84309 Source advisory:...
indico (>=3.2.6, <=3.2.9) potentially affected by CVE-2026-84309 via pypdf (3.12.1)
pypdf PYPI version 3.12.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - indico =3.2.6, =3.2.9 Source cves: CVE-2026-84309 Source advisory: OSV:GHSA-JP53-MHQP-8XCG...