5814 matches found
ai-enterprise-agent (>=0.0.4, <=0.0.9), almax-common (>=1.0.5.dev20240601224039, <=1.0.7.dev20240801212517) +25 more potentially affected by CVE-2026-84311 via pypdf (4.2.0)
pypdf PYPI version 4.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - ai-enterprise-agent =0.0.4, =1.0.5.dev20240601224039, =2024.7.4, =0.6.22, =0.2.1, =0.2.0, =0.0.5, =0.2.1, =3.3.2, =0.1.0, =0.0.1, =4.7.1, =0.1.0, =0.1...
agentyc (>=0.1.0, <=0.3.3), aiagents4pharma (>=0.0.0, <=1.49.1) +103 more potentially affected by CVE-2026-84311 via pypdf (>=6.0.0, <=6.15.0)
pypdf PYPI version =6.0.0, =0.1.0, =0.0.0, =1.1.0, =1.0.0a3, =0.2.0, =1.1.0, =3.1.0, =3.9.11, =0.12.6.post1, =0.2.0, =0.2.0, =0.0.3, =0.0.5 and more Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
assert-files (>=0.1.0, <=0.1.3), vpplib (0.0.4) +1 more potentially affected by CVE-2026-84311 via pypdf (3.16.4)
pypdf PYPI version 3.16.4 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - assert-files =0.1.0, =0.61.0, =0.65.0 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
pypdf: Possible long runtimes/large memory usage when extracting XForm objects
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes and large memory consumption. This requires extracting the text of a page with lots of XForm objects, where some of them might be re-used. Patches This has been fixed in pypdf==6.16.1. Workarounds If you...
gpt3discord (>=11.7.3, <=12.3.8) potentially affected by CVE-2026-84311 via pypdf (3.11.1)
pypdf PYPI version 3.11.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - gpt3discord =11.7.3, =12.3.8 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
athena-starship (>=0.0.3, <=0.0.6), conflare (>=0.1.2, <=0.1.3) +11 more potentially affected by CVE-2026-84311 via pypdf (4.1.0)
pypdf PYPI version 4.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - athena-starship =0.0.3, =0.1.2, =2.2.0, =0.0.1, =3.3.0, =1.14.0, =0.1.4, =4.6.2, =0.1.0, =0.1.58 Source cves: CVE-2026-84311 Source advisory:...
chellow (>=1692799408.0.0, <=1698672999.0.0), pspdfutils (>=3.1.2, <=3.2.0) potentially affected by CVE-2026-84311 via pypdf (3.15.2)
pypdf PYPI version 3.15.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chellow =1692799408.0.0, =3.1.2, =3.2.0 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
aiagents4pharma (>=1.15.0, <=1.44.0), pypdftotext (>=0.0.6, <=0.0.9) +3 more potentially affected by CVE-2026-84311 via pypdf (5.2.0)
pypdf PYPI version 5.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - aiagents4pharma =1.15.0, =0.0.6, =1.0.1, =1.0.1, =1.0.5 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
calibreweb (0.6.25), cewler (>=1.3.0, <=1.3.1) +8 more potentially affected by CVE-2026-84311 via pypdf (5.4.0)
pypdf PYPI version 5.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - calibreweb 0.6.25 - cewler =1.3.0, =1.1.2, =1.1.0, =1.2.0, =2025.3.0, =0.2.2, =28.3.2, =29.1.2 - ten8t 0.0.22 Source cves: CVE-2026-84311 Source...
render50 (9.2.2) potentially affected by CVE-2026-84311 via pypdf (3.15.3)
pypdf PYPI version 3.15.3 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - render50 9.2.2 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
smart-pdf (2023.9.11.1) potentially affected by CVE-2026-84311 via pypdf (3.16.0)
pypdf PYPI version 3.16.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - smart-pdf 2023.9.11.1 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
chat-with-mlx (>=0.1.0, <=0.1.11), crewai-files (>=1.9.0, <=1.10.1a1) +9 more potentially affected by CVE-2026-84311 via pypdf (4.0.2)
pypdf PYPI version 4.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - chat-with-mlx =0.1.0, =1.9.0, =3.2.0, =1.2.1, =1.0.9, =0.0.0, =0.1.2, =0.73.0, =0.94.0 Source cves: CVE-2026-84311 Source advisory:...
GHSA-763M-79HH-57F2 pypdf: Possible long runtimes/large memory usage when extracting XForm objects
Impact An attacker who uses this vulnerability can craft a PDF which leads to long runtimes and large memory consumption. This requires extracting the text of a page with lots of XForm objects, where some of them might be re-used. Patches This has been fixed in pypdf==6.16.1. Workarounds If you...
criscostack (1.0.0), neumai (>=0.0.9, <=0.0.36) +2 more potentially affected by CVE-2026-84311 via pypdf (3.9.1)
pypdf PYPI version 3.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - criscostack 1.0.0 - neumai =0.0.9, =0.0.17, =2023.6.0, =2024.4.0 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
py40kie (>=0.1.0, <=0.2.2) potentially affected by CVE-2026-84311 via pypdf (3.12.2)
pypdf PYPI version 3.12.2 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - py40kie =0.1.0, =0.2.2 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
agatta (>=0.9.1, <=0.9.4), automate3 (2023.11.7) +5 more potentially affected by CVE-2026-84311 via pypdf (3.17.0)
pypdf PYPI version 3.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - agatta =0.9.1, =1698926697.0.0, =9.2.3, =9.2.6 - uniflow 0.0.7 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
cocpyth (>=0.1.1, <=0.1.2), pretix (>=4.19.0, <=4.20.4) potentially affected by CVE-2026-84311 via pypdf (3.8.1)
pypdf PYPI version 3.8.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cocpyth =0.1.1, =4.19.0, =4.20.4 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-84311 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
centricube-langchain (>=1.2.3, <=1.3.0), centricube-pyautogen (>=0.3.2, <=0.3.3) +5 more potentially affected by CVE-2026-84311 via pypdf (5.6.1)
pypdf PYPI version 5.6.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - centricube-langchain =1.2.3, =0.3.2, =0.3.0, =0.1.0, =0.0.11, =0.0.3, =0.0.5 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...
nerxiv (>=0.0.1, <=1.1.0), osfexport (>=0.1.4, <=1.0.1) +3 more potentially affected by CVE-2026-84311 via pypdf (5.7.0)
pypdf PYPI version 5.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - nerxiv =0.0.1, =0.1.4, =0.0.1, =0.3.3, =30.0.8, =30.0.9 Source cves: CVE-2026-84311 Source advisory: OSV:GHSA-763M-79HH-57F2...