1669 matches found
postgresql:12 security update
pgaudit pgrepack postgres-decoderbufs postgresql 12.20-1 - Update to 12.20 - Fix CVE-2024-7348...
Oracle Linux 8 : postgresql:12 (ELSA-2024-6000)
The remote Oracle Linux 8 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2024-6000 advisory. pgaudit pgrepack postgres-decoderbufs postgresql 12.20-1 - Update to 12.20 - Fix CVE-2024-7348 Tenable has extracted the preceding description block directly fr...
postgresql:13 security update
pgaudit pgrepack postgres-decoderbufs postgresql 13.16-1 - Update to 13.16 - Fix CVE-2024-7348...
Oracle Linux 8 : postgresql:15 (ELSA-2024-6001)
The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-6001 advisory. pgaudit pgrepack postgres-decoderbufs postgresql 15.8-1 - Update to 15.8 - Fix CVE-2024-7348 Tenable has extracted the preceding description block...
Oracle Linux 8 : postgresql:13 (ELSA-2024-6018)
The remote Oracle Linux 8 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2024-6018 advisory. pgaudit pgrepack postgres-decoderbufs postgresql 13.16-1 - Update to 13.16 - Fix CVE-2024-7348 Tenable has extracted the preceding description block directly fr...
Oracle Linux 8 : postgresql:16 (ELSA-2024-5927)
The remote Oracle Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-5927 advisory. pgaudit 16.0-1 - Update to 16.0 - Support postgresql 16 - Initial import for PG 16 module - Resolves: RHEL-3636 pgrepack postgres-decoderbufs...
postgresql:16 security update
pgaudit 16.0-1 - Update to 16.0 - Support postgresql 16 - Initial import for PG 16 module - Resolves: RHEL-3636 pgrepack postgres-decoderbufs 2.4.0-1.Final - Initial import for postgresql 16 stream - Related: RHEL-3636 postgresql 16.4-1 - Update to 16.4 - Fix CVE-2024-7348...
UBUNTU-CVE-2024-7348
Time-of-check Time-of-use TOCTOU race condition in pgdump in PostgreSQL allows an object creator to execute arbitrary SQL functions as the user running pgdump, which is often a superuser. The attack involves replacing another relation type with a view or foreign table. The attack requires waiting...
Security Bulletin: Common vulnerabilities fixed in EDB Postgres Advanced Server (EPAS)
Summary Common vulnerabilities fixed in EDB Postgres Advanced Server EPAS Vulnerability Details CVEID:CVE-2023-41113 DESCRIPTION: EnterpriseDB Postgres Advanced Server could allow a remote authenticated attacker to obtain sensitive information, caused by a flaw in the accesshistory function. By...
pREST vulnerable to jwt bypass + sql injection
Summary Probably jwt bypass + sql injection or what i'm doing wrong? PoC how to reproduce 1. Create following files: docker-compose.yml: services: postgres: image: postgres containername: postgrescontainermre environment: POSTGRESUSER: testuserpg POSTGRESPASSWORD: testpasspg POSTGRESDB: testdb...
dbt-loom (>=0.1.2, <=0.3.1), dbt-postgres (>=1.6.0, <=1.6.13) +5 more potentially affected by CVE-2024-40637 via dbt-core (>=1.6.0, <=1.6.13)
dbt-core PYPI version =1.6.0, =0.1.2, =1.6.0, =1.3.0, =1.6.0, =1.6.0, =0.0.1, =0.0.11 Source cves: CVE-2024-40637 Source advisory: GHSA-P3F3-5CCG-83XQ...
dbt-loom (>=0.1.2, <=0.3.1), dbt-postgres (>=1.6.0, <=1.6.13) +5 more potentially affected by CVE-2024-40637 via dbt-core (>=1.6.0, <=1.6.13)
dbt-core PYPI version =1.6.0, =0.1.2, =1.6.0, =1.3.0, =1.6.0, =1.6.0, =0.0.1, =0.0.11 Source cves: CVE-2024-40637 Source advisory: OSV:GHSA-P3F3-5CCG-83XQ...
dbt (0.16.0b2), dbt-bigquery (0.16.0b2) +3 more potentially affected by CVE-2024-40637 via dbt-core (0.16.0b2)
dbt-core PYPI version 0.16.0b2 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.16.0b2 - dbt-bigquery 0.16.0b2 - dbt-postgres 0.16.0b2 - dbt-redshift 0.16.0b2 - dbt-snowflake 0.16.0b2 Source cves: CVE-2024-40637...
dbt (0.16.0rc2), dbt-bigquery (0.16.0rc2) +3 more potentially affected by CVE-2024-40637 via dbt-core (0.16.0rc2)
dbt-core PYPI version 0.16.0rc2 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.16.0rc2 - dbt-bigquery 0.16.0rc2 - dbt-postgres 0.16.0rc2 - dbt-redshift 0.16.0rc2 - dbt-snowflake 0.16.0rc2 Source cves: CVE-2024-406...
dbt (0.19.1rc1), dbt-bigquery (0.19.1rc1) +3 more potentially affected by CVE-2024-40637 via dbt-core (0.19.1rc1)
dbt-core PYPI version 0.19.1rc1 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.19.1rc1 - dbt-bigquery 0.19.1rc1 - dbt-postgres 0.19.1rc1 - dbt-redshift 0.19.1rc1 - dbt-spark 0.19.1rc1 Source cves: CVE-2024-40637...
dbt (0.20.0rc2), dbt-bigquery (0.20.0rc2) +5 more potentially affected by CVE-2024-40637 via dbt-core (0.20.0rc2)
dbt-core PYPI version 0.20.0rc2 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.20.0rc2 - dbt-bigquery 0.20.0rc2 - dbt-postgres 0.20.0rc2 - dbt-presto 0.20.0rc2 - dbt-redshift 0.20.0rc2 - dbt-snowflake 0.20.0rc2 -...
dbt (0.20.2rc2), dbt-bigquery (0.20.2rc2) +5 more potentially affected by CVE-2024-40637 via dbt-core (0.20.2rc2)
dbt-core PYPI version 0.20.2rc2 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.20.2rc2 - dbt-bigquery 0.20.2rc2 - dbt-postgres 0.20.2rc2 - dbt-presto 0.20.2rc2 - dbt-redshift 0.20.2rc2 - dbt-snowflake 0.20.2rc2 -...
airflow-dbt-python (>=0.5.1, <=0.7.2), dbt (0.20.2) +12 more potentially affected by CVE-2024-40637 via dbt-core (0.20.2)
dbt-core PYPI version 0.20.2 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - airflow-dbt-python =0.5.1, =0.2.0, =0.2.0, =0.20.0rc1, =0.2.0a0, =0.2.0 Source cves: CVE-2024-40637 Source advisory: OSV:PYSEC-2024-66...
dbt (0.17.0rc2), dbt-bigquery (0.17.0rc2) +3 more potentially affected by CVE-2024-40637 via dbt-core (0.17.0rc2)
dbt-core PYPI version 0.17.0rc2 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.17.0rc2 - dbt-bigquery 0.17.0rc2 - dbt-postgres 0.17.0rc2 - dbt-redshift 0.17.0rc2 - dbt-snowflake 0.17.0rc2 Source cves: CVE-2024-406...
dbt (0.17.1rc3), dbt-bigquery (0.17.1rc3) +3 more potentially affected by CVE-2024-40637 via dbt-core (0.17.1rc3)
dbt-core PYPI version 0.17.1rc3 is affected by a known vulnerability. The following packages have a transitive dependency on dbt-core and may be impacted: - dbt 0.17.1rc3 - dbt-bigquery 0.17.1rc3 - dbt-postgres 0.17.1rc3 - dbt-redshift 0.17.1rc3 - dbt-snowflake 0.17.1rc3 Source cves: CVE-2024-406...