11043 matches found
Aker
Aker SSH Gateway What is Aker? Aker is a security tool that helps you configure your own Linux ssh jump/bastion host. Named after an Egyptian mythology deity who guarded the borders, Aker would act as choke point through which all your sysadmins and support staff access Linux production servers...
sshhipot
Version 2 is under development. Please switch to the v2 branch, build, and run with -h. SSHHiPot High-interaction SSH honeypot ok, it's really a logging ssh proxy. Still more or less a work-in-progress. Feel free to go install this repository if you'd like to try it. Run it with -h to see more...
etl-parser
etl-parser Event Trace Log file reader in pure Python etl-parser is a pure Python 3 parser library for ETL Windows log files. ETL is the default format for ETW as well as the default format for the Kernel logger. etl-parser has no system dependencies, and will work well on both Windows and Linux...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
scopeblind-gateway
⚠️ This repository has moved. Active development continues at ScopeBlind/scopeblind-gateway. This personal fork may be behind the canonical repository. Please use the org repo for issues, pull requests, and the latest code. protect-mcp Security gateway for MCP servers. Shadow-mode logs by default,...
wetland
Wetland Wetland is a high interaction SSH honeypot,designed to log brute force attacks.What's more, wetland will log shell、scp、sftp、exec-command、direct-forward、reverse-forward interation performded by the attacker. Wetland is based on python ssh module paramiko. And wetland runs as a...
Pulse
Pulse is a powerful logging system for Apple Platforms. Native. Built with SwiftUI. Record and inspect logs and URLSession network requests right from your iOS app. Share logs and view them in Pulse Pro or use remote logging to see them in real time. Logs are stored locally and never leave your...
ndaal_public_auditd
Linux Audit Daemon Auditd Best Practices and Deployment English · Deutsch · Français · Español · Italiano This repository provides comprehensive best practices for Linux Audit Daemon Auditd configuration and deployment, including an extensive set of security-focused audit rules, an Ansible role f...
redshell
RedShell An interactive command prompt for red teaming and pentesting. Automatically pushes commands through SOCKS4/5 proxies via proxychains. Optional Cobalt Strike integration pulls beacon SOCKS4/5 proxies from the team server. Automatically logs activities to a local CSV file and a Cobalt Stri...
Stracciatella
Stracciatella v0.7 Powershell runspace from within C aka SharpPick technique with AMSI, ETW and Script Block Logging disabled for your pleasure. Nowadays, when Powershell got severly instrumented by use of techniques such as: AMSI ETW Script Block Logging Transcript file Modules logging Constrain...
Empire
Empire Empire is a post-exploitation and adversary emulation framework that is used to aid Red Teams and Penetration Testers. The Empire server is written in Python 3 and is modular to allow operator flexibility. Empire comes built-in with a client that can be used remotely to access the server...
penelope
Penelope is a modern shell handler for penetration testers and CTF players. It provides a more capable alternative to basic netcat listeners, adding automatic PTY upgrades, session management, logging, file transfers and helper modules. Table of Contents 📥 Installation ⚙️ Features 🖥️ Session...
log4j_checker_beta
log4jcheckerbeta - Linux, macOS and Windows Scripts If you want to use the windows/linux download cradles below, please review the scripts beforehand. Loading code from the internet and execute it is what brought us here with Log4Shell - right? ;- Linux and macOS servers or clients The...
Ghost-In-The-Logs
Ghost In The Logs This tool allows you to evade sysmon and windows event logging, my blog post about it can be found here Usage You can grab the lastest release here Starting off Once you've got the latest version execute it with no arguments to see the avalible commands $ gitl.exe Loading the ho...
attack_range
Splunk Attack Range v5 The Splunk Attack Range builds instrumented cloud environments AWS, Azure, GCP, simulates attacks, and forwards data into Splunk for detection development and testing. What it does: Build labs — Deploy a small, production-like lab Splunk, Windows/Linux servers, optional Kal...
Log4Shell-CVE-2021-44228-Demo
CVE-2021–44228 Demo 1. CVE-2021–44228 Introduction At the end of 2021, the biggest news in the cybersecurity world was the Log4j vulnerability, numbered CVE-2021-44228, also known as Log4Shell. In the CVSS vulnerability scoring system, it was rated the most severe 10 out of 10 , and it is also...
SnitchDNS
!CAUTION This repo is unmaintained, visit https://github.com/sadreck/SnitchDNS for the latest version. SnitchDNS SnitchDNS is a database driven DNS Server with a Web UI, written in Python and Twisted, that makes DNS administration easier with all configuration changed applied instantly without...
SteppingStones
Stepping Stones Purpose A hub for Red Team activity to aid in record keeping, situational awareness and reporting. Stepping Stones provides a web based UI for the team to log activity and generate report snippets. The UI is intended to be rapid enough to be used throughout the engagement, not jus...
AiSOC
AiSOC An open-source, self-hostable AI Security Operations Center. It ingests your security telemetry, detects and correlates threats, investigates them with AI agents whose reasoning is fully auditable, and proposes responses a human approves. Technical Guide PDF · Docs · Architecture · What...
log4j-CVE-2021-44228
Apache Log4j Zero Day aka Log4Shell aka CVE-2021-44228 Introduction Reproducing the problem in k8s env Setting up k8s env with the vulnerability Possible Solutions KubeArmor Security Policy Not allowing any execs from the JVM/Java Default Deny based rules KubeArmor Visibility/Observability into t...