8759 matches found
PT-2023-15128 · WordPress · Royal Elementor Addons
Name of the Vulnerable Software and Affected Versions: The Royal Elementor Addons plugin for WordPress versions up to, and including, 1.3.59 Description: The issue is related to insufficient access control in the 'wpr activate required theme' AJAX action. This allows any authenticated user,...
PT-2023-15134 · WordPress · Royal Elementor Addons
Name of the Vulnerable Software and Affected Versions: The Royal Elementor Addons plugin for WordPress versions up to, and including, 1.3.59 Description: The issue is related to insufficient access control in the 'wpr fix royal compatibility' AJAX action. This allows any authenticated user,...
terminal-kit Inefficient Regular Expression Complexity vulnerability
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 can address this issue. The name of the patch is...
GHSA-WXGH-8GMR-3QH3 terminal-kit Inefficient Regular Expression Complexity vulnerability
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 can address this issue. The name of the patch is...
ulcap-cli (>=1.0.8, <=1.0.31), zyzx-cli (1.0.31) potentially affected by CVE-2021-4306 via terminal-kit (2.1.0)
terminal-kit NPM version 2.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on terminal-kit and may be impacted: - ulcap-cli =1.0.8, =1.0.31 - zyzx-cli 1.0.31 Source cves: CVE-2021-4306 Source advisory: GHSA-WXGH-8GMR-3QH3...
ulcap-cli (>=1.0.8, <=1.0.31), zyzx-cli (1.0.31) potentially affected by CVE-2021-4306 via terminal-kit (2.1.0)
terminal-kit NPM version 2.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on terminal-kit and may be impacted: - ulcap-cli =1.0.8, =1.0.31 - zyzx-cli 1.0.31 Source cves: CVE-2021-4306 Source advisory: OSV:GHSA-WXGH-8GMR-3QH3...
CVE-2021-4306
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is...
CVE-2021-4306
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is...
Design/Logic Flaw
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is...
@0x4447/broccoli (>=1.0.0, <=1.0.16), @0x4447/potato (>=2.0.0, <=2.4.7) +399 more potentially affected by CVE-2021-4306 via terminal-kit (>=0.1.28, <=2.1.0)
terminal-kit NPM version =0.1.28, =1.0.0, =2.0.0, =1.0.0, =1.18.0, =0.0.1, =0.1.0, =1.0.0, =0.1.0, =1.0.5-master.20190403074739, =1.0.0-M.5a, =0.1.0-master.20191109234452, =0.1.0-ipcrm-custom-event.20191122150318, =1.0.0-M.3, =1.2.2-master.20191206162119 - @atomist/sdm-pack-k8s...
CVE-2021-4306 cronvel terminal-kit redos
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is...
CVE-2021-4306
The CVE-2021-4306 issue affects cronvel terminal-kit up to 2.1.7, with vulnerability to inefficient regular expression complexity (ReDoS) due to an unknown function. Impact is described as HIGH for availability (per CVSS) with network attack vector and no user interaction required. A fix is avail...
CVE-2021-4306
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is...
CVE-2021-4306: Inefficient Regular Expression Complexity
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is...
PT-2023-12410 · Unknown · Cronvel Terminal-Kit
Name of the Vulnerable Software and Affected Versions: cronvel terminal-kit versions up to 2.1.7 Description: A vulnerability has been found in cronvel terminal-kit, where the manipulation leads to inefficient regular expression complexity. This issue affects an unknown function. Recommendations:...
Terminal Kit security vulnerabilities
Terminal Kit is a command line tool for Node.js. A security vulnerability exists in Terminal Kit versions prior to 2.1.8, which stems from an unknown feature that operates to cause inefficient regular expression complexity...
Prototype Pollution
tree-kit is vulnerable to prototype pollution. The vulnerability exists in the op function of browser/tree-kit.js, due to the improper checks for the key variable which allows an attacker to modify object prototype attributes...
WordPress Jeg Elementor Kit Plugin < 2.5.7 is vulnerable to Broken Access Control
Software Jeg Elementor Kit Type Plugin Vulnerable versions 2.5.7 Fixed in 2.5.7 OWASP Top 10 A5: Broken Access Control Classification Broken Access Control CVE CVE-2022-3805 Patch priority High CVSS severity High 6.5 Developer Claim ownership PSID cb8e3a1233cd Credits Ramuel Gall Required privile...
VulnCheck KEV: CVE-2022-3805
The Jeg Elementor Kit plugin for WordPress is vulnerable to authorization bypass in various functions used to update the plugin settings in versions up to, and including, 2.5.6. Unauthenticated users can use an easily available nonce, obtained from pages edited by the plugin, to update the...
GHSA-PFRM-4RJW-G9Q5 string-kit Inefficient Regular Expression Complexity vulnerability
A vulnerability classified as problematic was found in cronvel string-kit up to 0.12.7. This vulnerability affects the function naturalSort of the file lib/naturalSort.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. Upgrading to versi...