147587 matches found
Amazon Linux 2 : php (ALASPHP8.2-2026-014)
The version of php installed on the remote host is prior to 8.2.34-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2PHP8.2-2026-014 advisory. The mysqlnd wire protocol parser reads fields out of server packets before checking that the packet still holds enough...
AlmaLinux 9.6 [TuxCare] Security Update: ignition / ignition-edge / ignition-grub / ignition-validate (ALMALINUX9.6:CLSA-2026:1791487723)
"The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1791487723 advisory. - gRPC-Go is the Go language implementation of gRPC. Versions prior to 1.79.3 have an authorization bypass resulting from improper input...
TencentOS Server 3: nodejs:22 (TSSA-2026:1141)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2026:1141 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities...
Amazon Linux 2 : perl-HTTP-Date (ALAS-2026-3996)
The version of perl-HTTP-Date installed on the remote host is prior to 6.02-8. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2026-3996 advisory. parsedate -- and str2time, which delegates to it -- used regexes withambiguous adjacent greedy runs year/clock/timezone digit...
Amazon Linux 2023 : perl-HTTP-Date, perl-HTTP-Date-tests (ALAS2023-2026-3210)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2026-3210 advisory. parsedate -- and str2time, which delegates to it -- used regexes withambiguous adjacent greedy runs year/clock/timezone digits andtimezone/ASCII-timezone letters before a trailing anchor. A valid-...
httpgrep
Descripción Una herramienta Python rápida y asíncrona que escanea servidores HTTPS y busca cadenas o patrones regex en cuerpos y cabeceras de respuestas HTTP. Acepta hosts individuales, URLs, rangos CIDR, rangos IP o archivos; escanea múltiples puertos por objetivo único, listas separadas por com...
curl: FTP authentication options leak to a cross-origin FTP redirect with unrestricted auth disabled
Summary libcurl 8.22.0 sends values configured with CURLOPTFTPACCOUNT and CURLOPTFTPALTERNATIVETOUSER to a different origin reached through an HTTP-to-FTP redirect even when unrestricted authentication is disabled. I reproduced this after a successful legitimate FTP download by reusing the same...
http-desync-guardian
Resumen HTTP/1.1 experimentó una larga evolución desde 1991 hasta 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 Esto significa que existe una variedad de servidores y clientes, los cuales pueden tener diferentes puntos de vista sobre los límites de...
lulzbuster
Descripción Un potente, rápido e inteligente forzador de directorios y archivos HTTPS con múltiples hilos, escrito en C sobre libcurl. Dada una URL objetivo y una lista de palabras, enumera rutas válidas lanzando peticiones HTTP concurrentes e informando las respuestas que parecen aciertos reales...
hoaxshell
hoaxshell ⚡ La última versión de este proyecto es el listener independiente de HoaxShell, que incluye plantillas de payload actualizadas. También puedes usarlo directamente desde https://revshells.com asegúrate de seleccionar hoaxshell como listener. ⚠️ A partir del 18-10-2022, hoaxshell es...
nomore403
NoMore403 nomore403 es una herramienta de línea de comandos para probar bypass de control de acceso HTTP e inconsistencias en analizadores alrededor de respuestas 401, 403 y relacionadas. La herramienta está diseñada para trabajo práctico en seguridad web: bug bounty, pruebas de penetración,...
slowloris
slowloris.py - Slowloris simple en Python ¿Qué es Slowloris? Slowloris es básicamente un ataque de Denegación de Servicio HTTP que afecta a servidores con hilos. Funciona así: 1. Comenzamos a hacer muchas solicitudes HTTP. 2. Enviamos encabezados periódicamente cada 15 segundos para mantener las...
smuggler
/ | | | | \ | | | | |/ |/ | || |/ | | | || | | | || | | /||||/ \ |\ || | @defparam Smuggler Una herramienta de prueba de HTTP Request Smuggling / Desync escrita en Python 3 Agradecimientos Un agradecimiento especial a James Kettle por su investigación y métodos sobre desincronizaciones HTTP Y un...
http2smugl
http2smugl Esta herramienta ayuda a detectar y explotar el contrabando de solicitudes HTTP en aquellos casos en que se puede lograr mediante la conversión HTTP/2 - HTTP/1.1 por parte del servidor frontend. El esquema es el siguiente: 1. Un atacante envía una solicitud HTTP/2 manipulada al servido...
Malicious code in nested-lib (npm)
Source: amazon-inspector 0a0b849de5330a4a4984a855f83ce1638b17e459d359312319ff35dc0e02f928 The package declares scripts.postinstall = "node beacon.cjs" and index.js also invokes require'./beacon.cjs'.fire at module load. beacon.cjs POSTs a JSON payload containing os.hostname, dirname, process.cwd,...
Malicious code in pay-methods-kmf (npm)
Source: amazon-inspector 07a616a1db0408a0570000c6514224d22e71c3ecee0f08268b5dd9bc96761fd2 [email protected] is a trivial stub empty index.js, manifest description 'Frontend utilities' that ships a prebuilt Linux x64 native addon at prebuilds/linux-x64/addon.node and loads it from...
Malicious code in some-very-long-package-name (npm)
Source: amazon-inspector 1ce120698c1be7e98866ccdff0987f7b77f53377e525284f311363b79f5ea397 Package ships a postinstall lifecycle hook node beacon.cjs and a top-level require'./beacon.cjs'.fire call in index.js, so both npm install and any require of the package trigger an outbound HTTP POST to the...
sslyze
SSLyze SSLyze es una herramienta de escaneo SSL/TLS rápida y potente, así como una biblioteca de Python. SSLyze puede analizar la configuración SSL/TLS de un servidor conectándose a él, para asegurarse de que utiliza configuraciones de cifrado sólidas certificado, suites de cifrado, curvas...
wshlient
Wshlient Cliente de Web Shell Descripción y Demo Wshlient es un cliente de web shell diseñado para ser bastante simple pero versátil. Solo necesitas crear un archivo de texto que contenga una solicitud HTTP e indicar dónde Wshlient inyecta los comandos, luego puedes disfrutar de una shell...
wfuzz
Wfuzz - El Fuzzer Web Wfuzz ha sido creado para facilitar la tarea en evaluaciones de aplicaciones web y se basa en un concepto simple: reemplaza cualquier referencia a la palabra clave FUZZ por el valor de un payload dado. Un payload en Wfuzz es una fuente de datos. Este simple concepto permite...