Lucene search
+L

48 matches found

Kitploit
Kitploit
•added 2026/10/04 2:08 a.m.•44 views

http-desync-guardian

Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...

5.9AI score
SaveExploits0References11
Kitploit
Kitploit
•added 2026/10/03 5:59 p.m.•22 views

crlf-powered-desync-scanner

CRLF-Powered Desync Scanner This is the Burp Extension we used to detect all cases from our research CRLF-Powered Desync Attacks: Beheading HTTP Streams. It's a research-first scanner built using BulkScan similar to HTTP Request Smuggler and others. Implementation Request Header Injection probe...

6.1AI score
SaveExploits0References2
Kitploit
Kitploit
•added 2026/10/03 12:51 p.m.•15 views

http-desync-guardian

Aperçu HTTP/1.1 a connu une longue évolution de 1991 à 2014 : HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 Cela signifie qu'il existe une variété de serveurs et de clients, qui peuvent avoir des vues différentes sur les limites des requêtes, créant des...

6AI score
SaveExploits0References11
Kitploit
Kitploit
•added 2026/10/03 8:12 a.m.•69 views

smuggler

/ | | | | \ | | | | |/ |/ | || |/ | | | || | | | || | | /||||/ \ |\ || | @defparam Smuggler An HTTP Request Smuggling / Desync testing tool written in Python 3 Acknowledgements A special thanks to James Kettle for his research and methods into HTTP desyncs And a special thanks to Ben Sadeghipour...

6.1AI score
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2026/09/21 12:00 a.m.•3 views

PT-2026-96111

AI HTTP Terminator - New Desync Technique - Zero-Day Attack Path - 1. Feed an autonomous security system small fragments of HTTP RFCs as attack inspiration. 2. Generate and mutate thousands of unusual HTTP request patterns. 3. Test the candidates against live infrastructure and use anomaly...

5.8AI score
SaveExploits0References1
OSV
OSV
•added 2026/09/15 7:54 p.m.•8 views

GHSA-9998-894R-FWVR Http4s Ember Transfer-Encoding value parsing (TE.CL / TE.0 request smuggling)

Summary Ember's HTTP/1.1 header parser matches the Transfer-Encoding header value with a case-sensitive substring test hValue.contains"chunked". RFC 9112 §7 requires transfer-coding names to be compared case-insensitively. A request carrying Transfer-Encoding: Chunked capital C is therefore not...

8.7CVSS6AI score0.0048EPSS
SaveExploits0References5
OSV
OSV
•added 2026/09/04 5:15 p.m.•25 views

CVE-2026-18540 undici vulnerable to downstream response splitting via retry interceptor

undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume...

3.7CVSS5.7AI score
SaveExploits0References4
Cvelist
Cvelist
•added 2026/09/04 5:15 p.m.•46 views

CVE-2026-18540 undici vulnerable to downstream response splitting via retry interceptor

undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume...

3.7CVSS0.00239EPSS
SaveExploits0References2
Imperva Blog
Imperva Blog
•added 2026/08/07 6:17 p.m.•17 views

Imperva Customers Protected Against Novel HTTP Desync Attacks

TL;DR: Recent Portswigger research introduced novel HTTP desync techniques discovered through an AI-assisted research system called the HTTP Terminator. The findings expand the range of unusual HTTP behaviors that can cause front-end and back-end systems to interpret the same traffic differently...

5.8AI score
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2026/02/06 12:00 a.m.•10 views

Unity Linux 20.1050e / 20.1060e / 20.1070e Security Update: varnish (UTSA-2026-005275)

The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-005275 advisory. Varnish Cache before 7.6.2 and Varnish Enterprise before 6.0.13r10 allow client-side desync via HTTP/1 requests. Tenable has extracted the preceding description bloc...

5.4CVSS5.4AI score0.00306EPSS
SaveExploits0References4
EUVD
EUVD
•added 2025/10/07 12:30 a.m.•13 views

EUVD-2020-29078

Malware in sbrugna...

7.4CVSS6.1AI score0.05299EPSS
SaveExploits0References12
Tenable Nessus
Tenable Nessus
•added 2025/03/04 12:00 a.m.•16 views

Linux Distros Unpatched Vulnerability : CVE-2020-8201

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Node.js 12.18.4 and 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by a...

7.4CVSS6.3AI score0.05299EPSS
SaveExploits0References2
OSV
OSV
•added 2024/12/16 2:07 p.m.•42 views

BIT-NODE-MIN-2020-8201

Node.js 12.18.4 and 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture ...

7.4CVSS7.2AI score0.05299EPSS
SaveExploits0References7
OSV
OSV
•added 2024/03/06 11:08 a.m.•51 views

BIT-NODE-2020-8201

Node.js 12.18.4 and 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture ...

7.4CVSS7.3AI score0.05299EPSS
SaveExploits0References7
OSV
OSV
•added 2023/12/22 11:06 a.m.•11 views

OESA-2023-1970 python-twisted security update

Twisted is an event-based framework for internet applications, supporting Python 2.7 and Python 3.5+. It includes modules for many different purposes, including the following: Security Fixes: twisted is an event-driven networking engine written in Python. In affected versions twisted exposes...

8.1CVSS6.5AI score0.0351EPSS
SaveExploits2References5
Tenable Nessus
Tenable Nessus
•added 2023/11/06 12:00 a.m.•43 views

Rocky Linux 8 : nodejs:12 (RLSA-2020:4272)

The remote Rocky Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RLSA-2020:4272 advisory. - Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like ://:@::/...

7.8CVSS6.9AI score0.05299EPSS
SaveExploits1References10
SUSE CVE
SUSE CVE
•added 2023/02/15 4:01 a.m.•12 views

SUSE CVE-2020-8201

Node.js 12.18.4 and 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture ...

5.6CVSS6.9AI score0.05299EPSS
SaveExploits0References6
OSV
OSV
•added 2022/07/07 4:15 p.m.•16 views

CVE-2021-46825

Symantec Advanced Secure Gateway ASG and ProxySG are susceptible to an HTTP desync vulnerability. When a remote unauthenticated attacker and other web clients communicate through the proxy with the same web server, the attacker can send crafted HTTP requests and cause the proxy to forward web...

9.1CVSS5.8AI score0.01642EPSS
SaveExploits0References1
NVD
NVD
•added 2022/07/07 4:15 p.m.•31 views

CVE-2021-46825

Symantec Advanced Secure Gateway ASG and ProxySG are susceptible to an HTTP desync vulnerability. When a remote unauthenticated attacker and other web clients communicate through the proxy with the same web server, the attacker can send crafted HTTP requests and cause the proxy to forward web...

9.1CVSS0.01642EPSS
SaveExploits0References1
Prion
Prion
•added 2022/07/07 4:15 p.m.•24 views

Design/Logic Flaw

Symantec Advanced Secure Gateway ASG and ProxySG are susceptible to an HTTP desync vulnerability. When a remote unauthenticated attacker and other web clients communicate through the proxy with the same web server, the attacker can send crafted HTTP requests and cause the proxy to forward web...

6.4CVSS9AI score0.01642EPSS
SaveExploits0References1Affected Software2
Rows per page
Query Builder