808 matches found
UBUNTU-CVE-2021-32677
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
CVE-2021-32677
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
CVE-2021-32677
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
accidental-vulnerability (>=2.0.4, <=3.0.0), agrothon (>=1.1.5, <=1.3.2) +332 more potentially affected by CVE-2021-32677 via fastapi (>=0.1.17, <=0.65.1)
fastapi PYPI version =0.1.17, =2.0.4, =1.1.5, =0.1.0, =0.1.0, =0.0.2, =0.1.7, =0.1.39, =0.1.21, =0.1.0, =19.1.2, =0.0.3, =0.0.5 and more Source cves: CVE-2021-32677 Source advisory: OSV:PYSEC-2021-100...
PYSEC-2021-100
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
CVE-2021-32677 Cross-Site Request Forgery (CSRF) in FastAPI
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
CVE-2021-32677
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
accidental-vulnerability (>=2.0.4, <=3.0.0), agrothon (>=1.1.5, <=1.3.2) +332 more potentially affected by CVE-2021-32677 via fastapi (>=0.1.17, <=0.65.1)
fastapi PYPI version =0.1.17, =2.0.4, =1.1.5, =0.1.0, =0.1.0, =0.0.2, =0.1.7, =0.1.39, =0.1.21, =0.1.0, =19.1.2, =0.0.3, =0.0.5 and more Source cves: CVE-2021-32677 Source advisory: MEND:CVE-2021-32677...
CVE-2021-32677
CVE-2021-32677 affects FastAPI
CVE-2021-32677
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
Fastapi-Utils cross-site request forgeing vulnerability
fastapi-utils is a software application. The reusable tool is FastAPI A cross-site request forgery vulnerability exists in fastapi-utils, which stems from the use of cookies for authentication in the path operation of receiving JSON loads from browsers in FastAPI version 0.65.2 and below, making ...
CVE-2021-32677: Cross-Site Request Forgery (CSRF)
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery CSRF attack. I...
PT-2021-4289 · Fastapi +1 · Fastapi +1
Name of the Vulnerable Software and Affected Versions: FastAPI versions prior to 0.65.2 Description: The issue is related to a Cross-Site Request Forgery CSRF attack in FastAPI, a web framework for building APIs with Python. In versions lower than 0.65.2, FastAPI would try to read the request...
Fedora: Security Advisory for python-fastapi (FEDORA-2021-e7fabd81fb)
The remote host is missing an update for the Copyright C 2021 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This program is free software; you can...
Fedora: Security Advisory for python-databases (FEDORA-2021-e7fabd81fb)
The remote host is missing an update for the Copyright C 2021 Greenbone Networks GmbH Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-or-later This program is free software; you can...
[SECURITY] Fedora 34 Update: python-fastapi-0.65.1-2.fc34
FastAPI is a modern, fast high-performance, web framework for building AP Is with Python 3.6+ based on standard Python type hints. The key features are: =EF=BF=BD=EF=BF=BD=EF=BF=BD Fast: Very high performance, on par with Node JS and Go thanks to Starlette and Pydantic. One of the fastest Python...
accidental-vulnerability (>=2.0.4, <=2.0.5), fastapi (>=0.1.18, <=0.8.0) +1 more potentially affected by CVE-2021-29510 via pydantic (0.18.2)
pydantic PYPI version 0.18.2 is affected by a known vulnerability. The following packages have a transitive dependency on pydantic and may be impacted: - accidental-vulnerability =2.0.4, =0.1.18, =2.1.0, =2.3.0 Source cves: CVE-2021-29510 Source advisory: OSV:GHSA-5JQP-QGF6-3PVH...
fastapi (>=0.9.0, <=0.15.0) potentially affected by CVE-2021-29510 via pydantic (0.21.0)
pydantic PYPI version 0.21.0 is affected by a known vulnerability. The following packages have a transitive dependency on pydantic and may be impacted: - fastapi =0.9.0, =0.15.0 Source cves: CVE-2021-29510 Source advisory: OSV:GHSA-5JQP-QGF6-3PVH...
fastapi (>=0.16.0, <=0.20.1), pyartifactory (>=1.0.1, <=1.0.2) potentially affected by CVE-2021-29510 via pydantic (0.23.0)
pydantic PYPI version 0.23.0 is affected by a known vulnerability. The following packages have a transitive dependency on pydantic and may be impacted: - fastapi =0.16.0, =1.0.1, =1.0.2 Source cves: CVE-2021-29510 Source advisory: OSV:GHSA-5JQP-QGF6-3PVH...
asynql (0.1.0), botx (>=0.11.0, <=0.11.3) +2 more potentially affected by CVE-2021-29510 via pydantic (0.28.0)
pydantic PYPI version 0.28.0 is affected by a known vulnerability. The following packages have a transitive dependency on pydantic and may be impacted: - asynql 0.1.0 - botx =0.11.0, =0.30.0, =0.1.4, =0.4.1 Source cves: CVE-2021-29510 Source advisory: OSV:GHSA-5JQP-QGF6-3PVH...