89572 matches found
Apache Camel input validation error vulnerability
Security vulnerabilities exist in Apache Camel versions 4.0.0 through 4.18.5 and 4.19.0 through 4.22.2. These stem from the XQueryBuilder in camel-saxon, which uses the default Saxon Configuration to parse stream-based Source message bodies. No restrictions are placed on DOCTYPE declarations or...
Apple iOS buffer error vulnerability
Buffer error vulnerabilities exist in Apple iOS versions prior to 26.7.2 and 27.2, Apple iPadOS versions prior to 26.7.2 and 27.2, Apple macOS Golden Gate versions prior to 27.2, Apple macOS Sequoia versions prior to 15.8.2, Apple macOS Tahoe versions prior to 26.7.2, and Apple visionOS versions...
PT-2026-123244
A vulnerability was identified in rathena FluxCP up to 98cd4b8fd83228c11b36fb3d097b8e0f7c105a8d. This issue affects the function verifyiprange of the file lib/Flux/PaymentNotifyRequest.php of the component PayPal IPN Handler. The manipulation of the argument X-Real-IP leads to origin validation...
Libyal libfvde buffer error vulnerability
Versions of libyal libfvde prior to 20260923 contain a buffer error vulnerability. This vulnerability arises because libfvdeencryptedmetadatareadtype0x001a performs an unbounded strlen operation on embedded XML plist data. An attacker can supply a specially crafted FileVault 2 volume containing...
lxsmnsyc seroval resource management error vulnerability
In versions lxsmnsyc seroval from 1.4.1 up to but including 1.6.8, there is a resource management error vulnerability. This vulnerability arises because fromJSON and fromCrossJSON fail to require that the list of elements in array nodes be an actual array. A specially crafted payload can allow...
2K Games Sid Meier’s Civilization IV buffer error vulnerability
Version 1.0.12.68 of Civilization IV by 2K Games contains a buffer error vulnerability. This vulnerability arises from type confusion occurring during manipulation in the loadstring function within the Lua sandbox component, and it may be exploited remotely to carry out attacks...
Mattermost resource management error vulnerability
Mattermost versions 11.9.1 and earlier within the 11.9.x series, 11.8.5 and earlier within the 11.8.x series, 11.7.10 and earlier within the 11.7.x series, and 11.10.1 and earlier within the 11.10.x series contain a resource management error vulnerability. This vulnerability arises from the lack ...
UBUNTU-CVE-2026-49442
Cacti is an open source performance and fault management framework. Prior to version 1.2.31, a User Enumeration vulnerability allows an attacker to identify valid usernames on the Cacti service. When a user attempts to log in, the application returns slightly different error messages depending on...
ROS-20261026-73-0106
The vulnerability in openssh is related to a memory reclamation error. Exploiting this vulnerability can allow an attacker to cause a service failure...
ROS-20261026-73-0030
The vulnerability in openssh is related to a single shift error. Exploiting this vulnerability can allow an attacker to cause a service failure...
vLLM resource management error vulnerability
Versions prior to vLLM 0.32.0 contain a resource management error vulnerability. This vulnerability arises because the Phi-4 multimodal audio encoder defaults to using eager attention in phi4mmaudio.py and phi4mmutils.py. A remote client can submit a valid long audio segment, causing the full...
HashiCorp Consul input validation error vulnerability
Versions prior to HashiCorp Consul 2.1.0, as well as versions prior to HashiCorp Consul Enterprise 1.21.19 and 2.1.0, contain an input validation error vulnerability. This vulnerability stems from authorization bypass in service mesh proxy registration, potentially allowing users with write acces...
Netty-TCNative digital error vulnerability
Versions of netty-tcnative prior to 2.0.84.Final and Netty netty-tcnative-boringsl-static prior to 2.0.84.Final contain a numeric error vulnerability. This vulnerability arises from an excessive reporting of consumed bytes within the BIO write callback tcnwritetobytebuffer. Remote TLS 1.3 clients...
PT-2026-123448
Name of the Vulnerable Software and Affected Versions vLLM versions prior to 0.32.0 Description An off-by-one error in the calculation of max token id within vllm/tokenizers/hf.py allows a pre-tokenized prompt ID equal to the vocabulary size to pass validation. When the tensor-parallel size is on...
Libimobiledevice buffer error vulnerability
Versions 1.4.0 and earlier of libimobiledevice contain a buffer error vulnerability. This vulnerability stems from how the afcfileopen function in the src/afc.c file within the AFC File Handler component handles the bytes parameter, potentially leading to an out-of-bounds read...
BenoitC Hackney resource management error vulnerability
Versions 2.0.0-beta.1 through 4.9.0 of benoitc hackney contain a resource management error vulnerability. This vulnerability arises because hackneyconn fails to restrict or throttle resource allocation; as a result, hackney:request/5 and hackney:body/1 return full response bodies without limiting...
Go JOSE input validation error vulnerability
Versions of Go JOSE prior to 4.1.5 contain an input validation error vulnerability. This vulnerability arises when, during decryption of untrusted JWE ciphertexts using algorithms such as A128CBC-HS256, A192CBC-HS384, or A256CBC-HS512, an empty ciphertext buffer is passed to the CBC-HMAC componen...
Python Social Auth - Core input validation error vulnerability
Python Social Auth versions prior to Core 6.2.0 contain a security vulnerability. This vulnerability arises because OpenIdConnectAuth stores the OpenID Connect nonce in a shared OpenIdConnectAssociation table. It only verifies that the nonce exists and has not expired; it fails to bind this nonce...
Turboderp ExLlamaV2 buffer error vulnerability
Turboderp ExLlamaV2 versions 0.3.2 and earlier contain a buffer error vulnerability. This vulnerability stems from improper handling of the parameter gidx in the QMatrix::makesequential function within the file exllamav2/exllamav2ext/cuda/qmatrix.cu in the GPTQ Index Handler component. It may all...
PT-2026-125105
A flaw has been found in a2aproject a2a-java up to 1.2.0.Final. This impacts the function getMessage of the component JSON-RPC Error Handler. This manipulation causes information exposure through error message. The attack can be initiated remotely. Upgrading to version 1.3.0.Final will fix this...