70 matches found
Design/Logic Flaw
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on comment, user and node statistics properties via unspecified vectors...
CVE-2014-1398
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on comment, user and node statistics properties via unspecified vectors...
CVE-2014-1400
The entityaccess API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions and read unpublished comments via unspecified vectors...
CVE-2014-1399
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on referenced entities via unspecified vectors...
CVE-2014-1399
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on referenced entities via unspecified vectors...
CVE-2014-1400
CVE-2014-1400 affects Drupal’s Entity API module (7.x-1.x) before 7.x-1.3. The entity_access API flaw could allow remote authenticated users to bypass access restrictions and read unpublished comments via unspecified vectors. The issue has a published remediation: upgrade to 7.x-1.3. If exploitat...
CVE-2014-1400
The entityaccess API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions and read unpublished comments via unspecified vectors...
CVE-2014-1399
CVE-2014-1399 affects Drupal’s Entity API module (Entity API, 7.x-1.x) prior to 7.x-1.3. The vulnerability in the entity wrapper access API may allow remote authenticated users to bypass intended access restrictions on referenced entities via unspecified vectors. The NVD entry notes remote authen...
CVE-2014-1398
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on comment, user and node statistics properties via unspecified vectors...
CVE-2014-1398
CVE-2014-1398 affects Drupal: the Entity API module (7.x-1.x) before 7.x-1.3 may let remote authenticated users bypass access restrictions on comment, user and node statistics properties via unspecified vectors. Connected documents confirm fixes in 7.x-1.3 (e.g., Fedora updates for drupal7-entity...
PT-2018-4168
Name of the Vulnerable Software and Affected Versions Entity API module versions 7.x-1.x before 7.x-1.3 Description The issue concerns the entity wrapper access API in the Entity API module for Drupal, which might allow remote authenticated users to bypass intended access restrictions on certain...
CVE-2014-1398: Improper Access Control
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on comment, user and node statistics properties via unspecified vectors...
CVE-2014-1400: Improper Access Control
The entityaccess API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions and read unpublished comments via unspecified vectors...
CVE-2014-1399: Improper Access Control
The entity wrapper access API in the Entity API module 7.x-1.x before 7.x-1.3 for Drupal might allow remote authenticated users to bypass intended access restrictions on referenced entities via unspecified vectors...
PT-2018-4169
Name of the Vulnerable Software and Affected Versions Entity API module versions 7.x-1.x before 7.x-1.3 Description The issue concerns the entity wrapper access API in the Entity API module for Drupal, which might allow remote authenticated users to bypass intended access restrictions on referenc...
PT-2018-4170
Name of the Vulnerable Software and Affected Versions Entity API module versions 7.x-1.x through 7.x-1.2 Description The issue allows remote authenticated users to bypass intended access restrictions and read unpublished comments. Recommendations For Entity API module versions 7.x-1.x through...
Entity API - Moderately critical - Information Disclosure - SA-CONTRIB-2018-013
The Entity API module extends the entity API of Drupal core in order to provide a unified way to deal with entities and their properties. The module prints debugging information to the HTML output in certain error conditions thereby causing an information disclosure vulnerability. This...
Fedora 21 : drupal7-entity-1.6-1.fc21 (2015-2849)
7.x-1.6 See SA-CONTRIB-2015-053 - Entity API - Cross Site Scripting XSS Changes since 7.x-1.5 : - by klausi: Sanitize field labels before passing them to the Token API. - Issue 2264079 by Amitaibu, fago: Fixed $wrapper-access might be wrong for single entity reference field. - Issue 2039601 by...
[SECURITY] Fedora 20 Update: drupal7-entity-1.6-1.fc20
This module extends the entity API of Drupal core in order to provide a uni fied way to deal with entities and their properties. Additionally, it provides an entity CRUD controller, which helps simplifying the creation of new entity types. This package provides the following Drupal modules: entit...
[SECURITY] Fedora 21 Update: drupal7-entity-1.6-1.fc21
This module extends the entity API of Drupal core in order to provide a uni fied way to deal with entities and their properties. Additionally, it provides an entity CRUD controller, which helps simplifying the creation of new entity types. This package provides the following Drupal modules: entit...