5976 matches found
AZL-34353 CVE-2023-4408 affecting package bind for versions less than 9.16.48-1
The DNS message parsing code in named includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected named instance by exploiting this flaw. This issue affects bot...
AZL-34564 CVE-2023-5679 affecting package bind for versions less than 9.19.21-1
A bad interaction between DNS64 and serve-stale may cause named to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.16.12-S1 through...
ALPINE-CVE-2023-4408
The DNS message parsing code in named includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected named instance by exploiting this flaw. This issue affects bot...
ISC BIND Security Vulnerability
ISC BIND is a suite of open source software that implements the DNS protocol from the US company ISC. A security vulnerability exists in ISC BIND that stems from a problem in the query processing code that could lead to an assertion failure...
ISC BIND Security Vulnerability
ISC BIND is a suite of open source software from ISC that implements the DNS protocol. A security vulnerability exists in ISC BIND versions 9.11.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1, which stems from the fact that clearing a cached database node...
UBUNTU-CVE-2023-4408
The DNS message parsing code in named includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected named instance by exploiting this flaw. This issue affects bot...
UBUNTU-CVE-2023-50868
The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of service CPU consumption for SHA-1 computations via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification...
Microsoft Windows DNS Security Vulnerability
Microsoft Windows DNS is a domain name resolution service from Microsoft. The Domain Name System DNS is one of the industry-standard suite of protocols that encompasses TCP/IP, and DNS clients and DNS servers work together to provide computers and users with name resolution services that map...
UBUNTU-CVE-2023-5679
A bad interaction between DNS64 and serve-stale may cause named to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.16.12-S1 through...
ISC BIND Security Vulnerability
ISC BIND is a suite of open source software that implements the DNS protocol from the US company ISC. A security vulnerability exists in ISC BIND that stems from the possibility that carefully crafted queries and responses may cause excessive CPU load...
ISC BIND Security Vulnerability
ISC BIND is a suite of open source software that implements the DNS protocol from the US company ISC. A security vulnerability exists in ISC BIND that stems from the presence of bad interactions that could lead to assertion failures...
Microsoft DNS Server Security Vulnerability
Microsoft DNS Server is a service of Microsoft Corporation USA. A security vulnerability exists in Microsoft DNS Server. The following products and editions are affected: Windows 11 Version 22H2 for ARM64-based Systems,Windows 11 Version 22H2 for x64-based Systems,Windows 11 Version 23H2 for...
UBUNTU-CVE-2023-50387
Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...
Microsoft DNS Server Security Vulnerability
Microsoft DNS Server is a service of Microsoft Corporation USA. A security vulnerability exists in Microsoft DNS Server. The following products and editions are affected:Windows Server 2019,Windows Server 2019 Server Core installation,Windows Server 2022,Windows Server 2022 Server Core installati...
My Cloud Multiple Products Code Issue Vulnerability
Western Digital My Cloud and others are products of Western Digital, Inc.Western Digital My Cloud is a personal cloud storage device.Western Digital My Cloud Home is an easy-to-use personal cloud storage device.Western Digital My Cloud Home Duo is an easy-to-use personal cloud storage...
CVE-2024-22107
An issue was discovered in GTB Central Console 15.17.1-30814.NG. The method systemSettingsDnsDataAction at /opt/webapp/src/AppBundle/Controller/React/SystemSettingsController.php is vulnerable to command injection via the /old/react/v1/api/system/dns/data endpoint. An authenticated attacker can...
systemd-resolved DNSSEC Modification
The vulnerability of the systemd-resolved service for managing network connections and domain name system DNS resolutions is related to deficiencies in verifying the authenticity of messages sent from DNS clients. Exploiting this vulnerability allows a malicious actor to alter DNS records protect...
UBUNTU-CVE-2023-38318
An issue was discovered in OpenNDS before 10.1.3. It fails to sanitize the gateway FQDN entry in the configuration file, allowing attackers that have direct or indirect access to this file to execute arbitrary OS commands...
CVE-2023-7227
SystemK NVR 504/508/516 versions 2.3.5SK.30084998 and prior are vulnerable to a command injection vulnerability in the dynamic domain name system DDNS settings that could allow an attacker to execute arbitrary commands with root privileges...