Lucene search
+L

5976 matches found

RedHat Linux
RedHat Linux
•added 2024/02/27 12:30 a.m.•12 views

bind9: KeyTrap - Extreme CPU consumption in DNSSEC validator

Processing specially crafted responses coming from DNSSEC-signed zones can lead to uncontrolled CPU usage, leading to a Denial of Service in the DNSSEC-validating resolver side. This vulnerability applies only for systems where DNSSEC validation is enabled...

7.5CVSS6.7AI score0.99988EPSS
SaveExploits0References7
osv_usn
osv_usn
•added 2024/02/26 1:52 p.m.•20 views

USN-6657-1 dnsmasq vulnerabilities

Elias Heftrig, Haya Schulmann, Niklas Vogel, and Michael Waidner discovered that Dnsmasq icorrectly handled validating DNSSEC messages. A remote attacker could possibly use this issue to cause Dnsmasq to consume resources, leading to a denial of service. CVE-2023-50387 It was discovered that...

7.5CVSS6.8AI score0.99988EPSS
SaveExploits1References4
RedHat Linux
RedHat Linux
•added 2024/02/26 8:46 a.m.•22 views

bind9: KeyTrap - Extreme CPU consumption in DNSSEC validator

Processing specially crafted responses coming from DNSSEC-signed zones can lead to uncontrolled CPU usage, leading to a Denial of Service in the DNSSEC-validating resolver side. This vulnerability applies only for systems where DNSSEC validation is enabled...

7.5CVSS6.7AI score0.99988EPSS
SaveExploits0References7
RedHat Linux
RedHat Linux
•added 2024/02/26 2:21 a.m.•22 views

bind9: Preparing an NSEC3 closest encloser proof can exhaust CPU resources

A flaw was found in bind9. By flooding a DNSSEC resolver with responses coming from a DNSEC-signed zone using NSEC3, an attacker can lead the targeted resolver to a CPU exhaustion, further leading to a Denial of Service on the targeted host. This vulnerability applies only for systems where DNSSE...

7.5CVSS6.7AI score0.73725EPSS
SaveExploits1References7
RedHat Linux
RedHat Linux
•added 2024/02/26 2:21 a.m.•19 views

bind9: KeyTrap - Extreme CPU consumption in DNSSEC validator

Processing specially crafted responses coming from DNSSEC-signed zones can lead to uncontrolled CPU usage, leading to a Denial of Service in the DNSSEC-validating resolver side. This vulnerability applies only for systems where DNSSEC validation is enabled...

7.5CVSS6.7AI score0.99988EPSS
SaveExploits0References7
Fedora
Fedora
•added 2024/02/26 12:47 a.m.•48 views

[SECURITY] Fedora 38 Update: bind9-next-9.19.21-1.fc38

BIND Berkeley Internet Name Domain is an implementation of the DNS Domain Name System protocols. BIND includes a DNS server named, which resolves host names to IP addresses; a resolver library routines for applications to use when interfacing with DNS; and tools for verifying that the DNS server ...

7.5CVSS7.7AI score0.99988EPSS
SaveExploits1
BDU FSTEC
BDU FSTEC
•added 2024/02/20 12:00 a.m.•15 views

DNSSEC BIND DoS

The vulnerability of DNSSEC implementation in DNS server BIND is related to algorithmic complexity and unlimited resource distribution during the creation of a DNS zone. Exploiting this vulnerability can allow a malicious actor to cause service failures...

7.8CVSS6.8AI score0.73725EPSS
SaveExploits1References26Affected Software12
Microsoft CVE
Microsoft CVE
•added 2024/02/19 8:00 a.m.•15 views

Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution

...

7.5CVSS7.4AI score0.01242EPSS
SaveExploits0
Fedora
Fedora
•added 2024/02/19 2:29 a.m.•60 views

[SECURITY] Fedora 39 Update: bind-9.18.24-1.fc39

BIND Berkeley Internet Name Domain is an implementation of the DNS Domain Name System protocols. BIND includes a DNS server named, which resolves host names to IP addresses; a resolver library routines for applications to use when interfacing with DNS; and tools for verifying that the DNS server ...

7.5CVSS7.2AI score0.99988EPSS
SaveExploits1
BDU FSTEC
BDU FSTEC
•added 2024/02/19 12:00 a.m.•14 views

DNSSEC BIND DoS

The vulnerability of DNSSEC implementation in DNS server BIND is related to algorithmic complexity and unlimited resource distribution during the creation of a DNS zone. Exploiting this vulnerability can allow a malicious actor to cause service failures...

7.8CVSS6.9AI score0.99988EPSS
SaveExploits0References30Affected Software13
SUSE CVE
SUSE CVE
•added 2024/02/17 3:27 a.m.•17 views

SUSE CVE-2023-5679

A bad interaction between DNS64 and serve-stale may cause named to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.16.12-S1 through...

7.5CVSS8AI score0.01242EPSS
SaveExploits0References5
SUSE CVE
SUSE CVE
•added 2024/02/15 4:11 a.m.•9 views

SUSE CVE-2023-50868

The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of service CPU consumption for SHA-1 computations via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification...

7.5CVSS6.7AI score0.73725EPSS
SaveExploits1References19
osv_alpine
osv_alpine
•added 2024/02/14 4:15 p.m.•16 views

ALPINE-CVE-2023-50868

The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of service CPU consumption for SHA-1 computations via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification...

7.5CVSS6.8AI score0.73725EPSS
SaveExploits1References1
osv_azl
osv_azl
•added 2024/02/14 4:15 p.m.•11 views

AZL-34419 CVE-2023-50387 affecting package dnsmasq for versions less than 2.90-1

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS6.7AI score0.99988EPSS
SaveExploits0References1
osv_debian
osv_debian
•added 2024/02/14 4:15 p.m.•4 views

DEBIAN-CVE-2023-50387

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS7AI score0.99988EPSS
SaveExploits0References1
osv_azl
osv_azl
•added 2024/02/14 4:15 p.m.•21 views

AZL-34350 CVE-2023-50387 affecting package bind for versions less than 9.16.48-1

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits0References1
osv_cve
osv_cve
•added 2024/02/13 6:15 p.m.•16 views

CVE-2024-21342

Windows DNS Client Denial of Service Vulnerability...

7.5CVSS7.3AI score0.02535EPSS
SaveExploits0References1
osv_usn
osv_usn
•added 2024/02/13 3:30 p.m.•38 views

USN-6633-1 bind9 vulnerabilities

Shoham Danino, Anat Bremler-Barr, Yehuda Afek, and Yuval Shavitt discovered that Bind incorrectly handled parsing large DNS messages. A remote attacker could possibly use this issue to cause Bind to consume resources, leading to a denial of service. CVE-2023-4408 Elias Heftrig, Haya Schulmann,...

7.5CVSS7AI score0.99988EPSS
SaveExploits1References6
osv_debian
osv_debian
•added 2024/02/13 2:15 p.m.•8 views

DEBIAN-CVE-2023-5517

A flaw in query-handling code can cause named to exit prematurely with an assertion failure when: - nxdomain-redirect ; is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative NXDOMAIN response. This issue affects BIND 9 versio...

7.5CVSS7.5AI score0.01242EPSS
SaveExploits0References1
osv_debian
osv_debian
•added 2024/02/13 2:15 p.m.•10 views

DEBIAN-CVE-2023-4408

The DNS message parsing code in named includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected named instance by exploiting this flaw. This issue affects bot...

7.5CVSS6.5AI score0.01338EPSS
SaveExploits0References1
Rows per page
Query Builder