375 matches found
SUSE: Security Advisory (SUSE-SU-2025:01815-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Important: Red Hat Security Advisory: Red Hat build of Cryostat 4.0.1: new RHEL 9 container image security update
New Red Hat build of Cryostat 4.0.1 on RHEL 9 container images are now available. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each...
SUSE SLES15 / openSUSE 15 Security Update : apache-commons-beanutils (SUSE-SU-2025:01815-1)
The remote SUSE Linux SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2025:01815-1 advisory. Update to 1.11.0 - CVE-2025-48734: Fixed possible arbitrary code execution vulnerability bsc1243793 Full changelog:...
SUSE-SU-2025:01815-1 Security update for apache-commons-beanutils
This update for apache-commons-beanutils fixes the following issues: Update to 1.11.0 - CVE-2025-48734: Fixed possible arbitrary code execution vulnerability bsc1243793 Full changelog: https://commons.apache.org/proper/commons-beanutils/changes.htmla1.11.0...
Improper Access Control
Apache Commons BeanUtils is vulnerable to Improper Access Control. The vulnerability is due to insecure property access due to failure to restrict access to the declaredClass property of Java enums, allowing attackers to access the classloader and potentially execute arbitrary code...
OPENSUSE-SU-2025:15175-1 apache-commons-beanutils-1.11.0-1.1 on GA media
These are all security issues fixed in the apache-commons-beanutils-1.11.0-1.1 package on the GA media of openSUSE Tumbleweed...
Apache Commons BeanUtils 1.x < 1.11.0, 2.0.0-M1 < 2.0.0-M2 Improper Access Control Vulnerability
The Apache Commons BeanUtils library is prone to an improper access control vulnerability. SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only CPE ...
acegisecurity:acegi-security-domain (0.9.0), ae.teletronics.nlp:entityextraction (1.3) +42498 more potentially affected by CVE-2025-48734 via commons-beanutils:commons-beanutils (>=1.0, <=1.10.1)
commons-beanutils:commons-beanutils MAVEN version =1.0, =0.0.1, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =0.25-rc1, =0.25-rc1, =0.25, =0.25, =0.25, =0.25, =1.0.1, =1.2.8 and more Source cves: CVE-2025-48734 Source advisory: GHSA-WXR5-93PH-8WR9...
acegisecurity:acegi-security-domain (0.9.0), ae.teletronics.nlp:entityextraction (1.3) +42498 more potentially affected by CVE-2025-48734 via commons-beanutils:commons-beanutils (>=1.0, <=1.10.1)
commons-beanutils:commons-beanutils MAVEN version =1.0, =0.0.1, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =0.25-rc1, =0.25-rc1, =0.25, =0.25, =0.25, =0.25, =1.0.1, =1.2.8 and more Source cves: CVE-2025-48734 Source advisory: OSV:GHSA-WXR5-93PH-8WR9...
acegisecurity:acegi-security-domain (0.9.0), ae.teletronics.nlp:entityextraction (1.3) +42498 more potentially affected by CVE-2025-48734 via commons-beanutils:commons-beanutils (>=1.0, <=1.10.1)
commons-beanutils:commons-beanutils MAVEN version =1.0, =0.0.1, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =0.25-rc1, =0.25-rc1, =0.25, =0.25, =0.25, =0.25, =1.0.1, =1.2.8 and more Source cves: CVE-2025-48734 Source advisory: SNYK:JAVA-COMMONSBEANUTILS-10259368...
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection')
Overview commons-beanutils:commons-beanutils is a provides an easy-to-use but flexible wrapper around reflection and introspection. Affected versions of this package are vulnerable to Use of Externally-Controlled Input to Select Classes or Code 'Unsafe Reflection' via the getProperty and...
AZL-109472 CVE-2025-48734 affecting package apache-commons-beanutils 1.9.4-5
Improper Access Control vulnerability in Apache Commons. A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default...
CVE-2025-48734 Apache Commons BeanUtils: PropertyUtilsBean does not suppresses an enum's declaredClass property by default
Improper Access Control vulnerability in Apache Commons. A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default...
acegisecurity:acegi-security-domain (0.9.0), ae.teletronics.nlp:entityextraction (1.3) +42498 more potentially affected by CVE-2025-48734 via commons-beanutils:commons-beanutils (>=1.0, <=1.10.1)
commons-beanutils:commons-beanutils MAVEN version =1.0, =0.0.1, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =0.25-rc1, =0.25-rc1, =0.25, =0.25, =0.25, =0.25, =1.0.1, =1.2.8 and more Source cves: CVE-2025-48734 Source advisory: MEND:CVE-2025-48734...
CVE-2025-48734
Improper Access Control vulnerability in Apache Commons. A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default...
CVE-2025-48734 Apache Commons BeanUtils: PropertyUtilsBean does not suppresses an enum's declaredClass property by default
Improper Access Control vulnerability in Apache Commons. A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default...
CVE-2025-48734: Improper Access Control
Improper Access Control vulnerability in Apache Commons. A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default...
PT-2025-23085
Name of the Vulnerable Software and Affected Versions Apache Commons BeanUtils versions 1.x before 1.11.0 Apache Commons BeanUtils versions 2.x before 2.0.0-M2 Description The issue is related to improper access control in Apache Commons BeanUtils, where an attacker can access the enum's class...
Exploit for Deserialization of Untrusted Data in Apache Tomcat
CVE-2025-24813-vulhub POC script for the vulhub environment of...
Security Bulletin: IBM Operational Decision Manager for April 2024 - Multiple CVEs addressed
Summary IBM Operational Decision Manager is vulnerable to multiple remote code execution and denial of service attacks in third party and open source used in the product for various functions. See full list below. The vulnerabilities have been addressed. Vulnerability Details CVEID:CVE-2014-0114...