22592 matches found
OESA-2026-3958 xmlrpc-c security update
XML-RPC is a quick-and-easy way to make procedure calls over the Internet. It converts the procedure call into an XML document, sends it to a remote server using HTTP, and gets back the response as XML. Security Fixes: libexpat before 2.8.3 has an out-of-bounds read and resultant infinite loop...
OESA-2026-3957 xmlrpc-c security update
XML-RPC is a quick-and-easy way to make procedure calls over the Internet. It converts the procedure call into an XML document, sends it to a remote server using HTTP, and gets back the response as XML. Security Fixes: libexpat before 2.8.3 has an out-of-bounds read and resultant infinite loop...
TRACTOR Benchmark for Evaluating C to Rust Translators
Memory-safety vulnerabilities remain a persistent source of security risk in critical software, much of which is implemented in memory-unsafe languages such as C and C++. Recent advances in programming languages, program analysis, and artificial intelligence have created new opportunities to...
wolfCOSE v2.0.0
wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...
SUSE CVE-2026-8674
Initializing the DNS stub resolver from an /etc/resolv.conf file, or a LOCALDOMAIN environment variable, whose search list contains a domain of roughly 200 characters or more in the GNU C Library version 2.26 to 2.44 results in an assertion failure which aborts the process. The resolver truncates...
SUSE CVE-2026-44235
rabbitmq-c is a C-language AMQP client library for RabbitMQ. Prior to 0.16.0, a malicious AMQP server can send an undersized HEADER or METHOD frame during client login and cause unsigned sizet underflow in amqphandleinput in librabbitmq/amqpconnection.c. The parser subtracts HEADERSIZE, fixed...
SUSE CVE-2026-44236
rabbitmq-c is a C-language AMQP client library for RabbitMQ. Prior to 0.16.0, a malicious AMQP server can send an undersized connection.tune.framemax value during amqplogin, and rabbitmq-c accepts the value in amqplogininner in librabbitmq/amqpsocket.c. amqptuneconnection in...
[SECURITY] Fedora 44 Update: stb-0^20260802.2c980bb-2.fc44
Single-file public domain libraries for C/C++...
[SECURITY] Fedora 43 Update: stb-0^20260802.2c980bb-2.fc43
Single-file public domain libraries for C/C++...
[SECURITY] Fedora 45 Update: stb-0^20260802.2c980bb-2.fc45
Single-file public domain libraries for C/C++...
brpc v1.18.0
中文版 bRPC is an Industrial-grade RPC framework using C++ Language, which is often used in high performance system such as Search, Storage, Machine learning, Advertisement, Recommendation etc. "bRPC" means "better RPC". You can use it to: Build a server that can talk in multiple protocols on same...
CVE-2026-11727
IBM MQ for HPE NonStop 8.1.0 through 8.1.0.40 IBM MQ C client could allow a remote attacker to cause a denial of service or potentially execute arbitrary code due to improper validation of queue manager responses when requesting AMS policy data...
EUVD-2026-83376
FluidSynth is a software synthesizer based on the SoundFont 2 specifications. From 2.2.4 until 2.5.6, configuring synth.midi-channels above 16 allows the MIDI player to index fluidplayert::channelisplaying outside its fixed-size heap allocation while tracking active channels. The resulting...
CVE-2026-11727 IBM MQ for HPE NonStop is vulnerable to a denial of service issue
IBM MQ for HPE NonStop 8.1.0 through 8.1.0.40 IBM MQ C client could allow a remote attacker to cause a denial of service or potentially execute arbitrary code due to improper validation of queue manager responses when requesting AMS policy data...
EUVD-2026-83294
IBM MQ for HPE NonStop 8.1.0 through 8.1.0.40 IBM MQ C client could allow a remote attacker to cause a denial of service or potentially execute arbitrary code due to improper validation of queue manager responses when requesting AMS policy data...
CVE-2026-11727 IBM MQ for HPE NonStop is vulnerable to a denial of service issue
IBM MQ for HPE NonStop 8.1.0 through 8.1.0.40 IBM MQ C client could allow a remote attacker to cause a denial of service or potentially execute arbitrary code due to improper validation of queue manager responses when requesting AMS policy data...
CVE-2026-11727
IBM MQ for HPE NonStop 8.1.0 through 8.1.0.40 and IBM MQ 9.1 through 10.0.0.0 (Standard Client) are affected by a heap-based buffer overflow (CWE-122) in the MQ client's MQOPEN reply handler . Improper validation of queue manager responses when requesting AMS policy data allows a rogue queue mana...
AZL-103307 CVE-2026-69184 affecting package c-ares 1.30.0-2
c-ares is an asynchronous resolver library. Prior to 1.34.7, aresdnsnameparse enforces backward DNS compression pointers but does not bound the total pointer hops or assembled name length. A malicious DNS server can send a response containing a long descending pointer chain and many resource...
AZL-103304 CVE-2026-69186 affecting package c-ares 1.30.0-2
c-ares is an asynchronous resolver library. Prior to 1.34.7, aresdnsparse trusts the attacker-controlled ANCOUNT, NSCOUNT, and ARCOUNT fields before confirming that the DNS response contains enough bytes for the claimed records. Because processanswer invokes parsing before transaction ID and...
CVE-2026-69184
c-ares is an asynchronous resolver library. Prior to 1.34.7, aresdnsnameparse enforces backward DNS compression pointers but does not bound the total pointer hops or assembled name length. A malicious DNS server can send a response containing a long descending pointer chain and many resource...