20894 matches found
UnhookMe
UnhookMe - Dynamically unhooking imports resolver In the era of intrusive AVs and EDRs that introduce hot-patches to the running processes for their enhanced optics requirements, modern adversaries must have a robust tool to slide through these watchguards. The propsed implementation of dynamic...
schrodingers-toctou
Schrödinger's TOCTOU "...the definition of 'sane compiler' grows ever looser." The binary you run is not the program you wrote. The compiler optimizer rewrites your source in ways you never see — and some of those changes can silently and legally turn seemingly secure code into vulnerable binarie...
DuplexSpyCS
DuplexSpy DuplexSpyCS CS stands for CSharp is a open source RAT base on C/S Continuously update: Branch-Version2.1.0 Documents The online documents are here: DuplexSpy Fileless Execution DLL and shellcode injector and loader Remote Plugin Proxy Introduction DuplexSpy is a open-source Windows RAT...
chlonium
Chlonium Chlonium is an application designed for cloning Chromium Cookies. From Chromium 80 and upwards, cookies are encrypted using AES-256 GCM, with a state key which is stored in the Local State file. This state key is encrypted using DPAPI. This is a change from older versions, which used DPA...
honggfuzz
Honggfuzz A security-oriented, feedback-driven, evolutionary fuzzer. Honggfuzz is a general-purpose fuzzer that uses code coverage software and hardware-based to find bugs. It is multi-process, multi-threaded, and supports persistent fuzzing for extreme speed. Key Features Fast : Multi-process an...
resiprocate
Overview The reSIProcate repository contains the following C++ libraries and applications: resip library: comprehensive RFC3261 SIP stack dum Dialog Usage Manager library: high level SIP library for creating SIP user agents no media stack recon library: high level SIP UA library with media stack...
sylkie
sylkie A command line tool and library for testing networks for common address spoofing security vulnerabilities in IPv6 networks using the Neighbor Discovery Protocol. Getting Started Note: This project is still in the early phases of development. If you run into any problems, please consider...
ProxyBridge
ProxyBridge ProxyBridge is a lightweight, open-source universal proxy client Proxifier alternative that provides transparent proxy routing for applications on Windows , macOS , and Linux. It redirects TCP and UDP traffic from specific processes through SOCKS5 or HTTP proxies, with the ability to...
ImpulsiveDLLHijack
ImpulsiveDLLHijack C based tool which automates the process of discovering and exploiting DLL Hijacks in target binaries. The Hijacked paths discovered can later be weaponized during RedTeam Operations to evade EDR's. 1. Methodological Approach : The tool basically acts on automating following...
BridgeHead
BridgeHead Native C++ access to Active Directory over ADWS, no .NET, no WCF, no HTTP stack. BridgeHead is a C++20 static library implementing the full Active Directory Web Services ADWS protocol stack directly over TCP. Named after the AD bridgehead server, the gateway through which directory...
external_libexif_AOSP10_r33_CVE-2020-0198
libexif ------- DESCRIPTION libexif is a library for parsing, editing, and saving EXIF data. It is intended to replace lots of redundant implementations in command-line utilities and programs with GUIs. FEATURES libexif supports parsing, editing and saving of EXIF data. In addition, it has gettex...
CVE-2020-0688-Scanner
CVE-2020-0688-Scanner Quick C tool for checking CVE-2020-0688 on multiple hosts with a non-intrusive method. Features Scan hosts from an input file. Passive check : grab exchange version by scraping html content. Produces an output file. Demo How to use Prerequisite Windows .NET framework 4.5.2...
cpufetch
Simple yet fancy CPU architecture fetching tool cpufetch is a command-line tool written in C that displays the CPU information in a clean and beautiful way Table of contents 1. Support 2. Installation 2.1 Installing from a package 2.2 Building from source 2.3 Android 3. Examples 3.1 x8664 3.2...
KnockOutlook
KnockOutlook "The best feeling is to win by knockout." - Nonito Donaire Overview KnockOutlook is a C project that interacts with Outlook's COM object in order to perform a number of operations useful in red team engagements. Command Line Usage / /// / // \ / // / / / / , / / / / /// / / / / / / /...
SharpDNSExfil
SharpDNSExfil SharpDNSExfil is an exfiltration tool written in C. The main objective is to exfiltrate any "on disk" files without having to worry about restricted outbound connection. Prerequisite Remote machine should be able to resolve DNS Why did I do this? I got blind RCE during my engagement...
wolfCOSE
wolfCOSE wolfCOSE is a lightweight C library implementing CBOR RFC 8949, COSE RFC 9052/9053, and post-quantum ML-DSA for COSE RFC 9964 using wolfSSL as the crypto backend. Main Features Complete RFC 9052 message set : all six COSE message types, including multi-signer COSESign and multi-recipient...
Apache_Penetration_Tool
ApachePenetrationTool A vulnerability exploit tool developed using QT C++, for details of the vulnerability analysis, please refer to: https://www.hui-blog.cool/posts/de1f.html Tool interface At the vulnerability selection number, select the vulnerability that needs to be detected. Vulnerability...
SharpUp
SharpUp SharpUp is a C port of various PowerUp functionality. Currently, only the most common checks have been ported; no weaponization functions have yet been implemented. @harmj0y is the primary author. SharpUp is licensed under the BSD 3-Clause license. Usage SharpUp.exe audit check1 check2...
EXCELntDonut
| \ / / | | | | || \ | | | | \ / | | | | | | ' | | | | |/ | ' | | | | | | | / \ || || || | | | || || | | | | | || | | |//\|||| |||/ /|| ||,|| by @JoeLeonJr @FortyNorthSec EXCELntDonut is a XLM Excel 4.0 macro generator. Start with C source code EXE and end with a XLM Excel 4.0 macro that...
darksword-kexploit
DarkSword Kernel Exploit Reimplemented in Objective-C. Supposed to support iOS 15.0 - 26.0.1. Offsets hardcoded for 15.x? NOTE: THIS EXPLOIT WAS NOT DISCOVERED / LEAKED BY ME, THE ORIGINAL SOURCE FOR THE LEAK IS https://github.com/htimesnine/DarkSword-RCE THIS EXPLOIT IS ALSO COMPLETELY UNRELATED...