17815 matches found
CVE-2025-1094
I have written this exploit with reference to the PoC available at CVE-2025-1094 CVE‑2025‑1094 | PostgreSQL Input Sanitization Vulnerability Overview CVE‑2025‑1094 is an input sanitization vulnerability in PostgreSQL’s libpq escape functions and the psql interactive tool. It stems from the improp...
django_cve201919844
djangocve201919844poc PoC for CVE-2019-19844 Requirements Python 3.7.x PostgreSQL 9.5 or higher Setup 1. Create databasee.g. djangocve201919844poc 2. Set the database name to the environment variable DJANGODATABASENAMEe.g. export DJANGODATABASENAME=djangocve201919844poc 3. Run pip install -r...
POC_SQL_injection_in_Parse_Server_prior_6.5.7_-_7.1.0
Database Ghost 🔥 Advanced PostgreSQL SQL Injection Exploitation Tool 🚨 DISCLAIMER FOR AUTHORIZED SECURITY TESTING ONLY Unauthorized use is illegal. Use only on systems you own or have explicit permission to test. ⚡ QUICK START Install & Run git clone...
[SECURITY] Fedora 45 Update: barman-3.20.1-3.fc45
Barman Backup and Recovery Manager is an open-source administration tool for disaster recovery of PostgreSQL servers written in Python. It allows your organization to perform remote backups of multiple servers in business critical environments to reduce risk and help DBAs during the recove ry pha...
CVE-2025-8714-POC
CVE-2025-8714-POC PoC de RCE en PostgreSQL — CVE-2025-8714 PoC de Ejecución Remota de Código en PostgreSQL — CVE-2025-8714 pgdump Reverse Shell Este repositorio presenta una prueba de concepto PoC para la vulnerabilidad crítica CVE-2025-8714 que afecta a versiones PostgreSQL anteriores a: 17.6,...
CVE-2026-52887-NocoBase-SQLi-RCE
CVE-2026-52887 — NocoBase SQL Injection → PostgreSQL-superuser RCE SQL injection in the myInAppChannels:list action of NocoBase's @nocobase/plugin-notification-in-app-message ≤ 2.0.60. The filterlatestMsgReceiveTimestamp$lt request parameter is interpolated directly into a raw Sequelize.literal S...
CVE-2020-7471
CVE-2020-7471 This repository provides the environment and POC for CVE-2020-7471 Potential SQL injection via StringAggdelimiter vulnerability. Affected Django versions 1.11 to 1.11.28 exclusive 2.2 to 2.2.10 exclusive 3.0 to 3.0.3 exclusive The following steps are required before downloading and...
CVE-2026-51992
CVE-2026-51992 Within ClickHouse, a feature exists that allows a user with the correct permissions to create dictionaries in order to interact with different databases and run specific queries on them. For PostgreSQL, SELECT queries are wrapped in a COPY QUERY TO STDOUT statement before being...
CVE-2024-46636-SQLi-MODAPS
CVE-2024-46636 is a SQL Injection vulnerability identified in the MODAPS system of NASA EOSDIS, caused by improper input validation in the category parameter. This vulnerability allow attackers to access sensitive data, and execute arbitrary SQL queries through HTTP GET parameter manipulation usi...
CVE-2025-59470-PostgreSQL-Command-Injection
Affected Software: PostgreSQL 15.x before 15.7, 16.x before 16.3. Vulnerability Type: Command injection in the pgbackup extension. Description: The pgbackup extension fails to properly sanitize user‑supplied parameters, allowing a backup operator to inject arbitrary commands that are executed as...
CVE-2019-9193
CVE-2019–9193 - PostgreSQL 9.6.1 Remote Code Execution Authenticated Proof of Concept PostgreSQL Database from version 9.6.1 are vulnerable to Authenticated Remote Code Execution. Even if it isn't considered to be a vulnerability itself by the development team, this could be leveraged to gain...
CVE-2020-7471-Django
CVE-2020-7471-PoC Django PoC for the SQL injection vulnerability in PostgreSQL with Django, found in Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 The class django.contrib.postgres.aggregates.StringAgg for using the PostgreSQL STRINGAGG function had a SQL injection...
briefr
BRIEFR Self-hosted CVE intelligence for analysts who need answers, not another raw feed Live demo · Documentation · Quick start · Screenshots What is BRIEFR? BRIEFR is a self-hosted CVE intelligence dashboard. It pulls public vulnerability and threat feeds into your PostgreSQL database, then give...
CVE-2026-76904
GeoServer SQL Injection to RCE Zero-Day CVE: CVE-2026-76904 | CVSS: 9.8 Critical CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H This vulnerability has been assigned GHSA-mqjf-5f49-2fjh by the GeoServer/GeoTools team and is actively being exploited in the wild as of August 2026. The vulnerability ha...
cve-2026-9082-drupal-postgresql-rce
CVE-2026-9082 Drupal PostgreSQL SQLi to RCE This repository contains a local lab and a short exploit for the Drupal JSON:API PostgreSQL SQL injection described in the Ambionics article. The important part of the exploit is the PostgreSQL escalation: once the injection can evaluate a SELECT...
watchTowr-vs-Splunk-CVE-2026-20253
CVE-2026-20253 Splunk Pre-Auth RCE Splunk Pre-Auth RCE 1day Detection Artifact Generator Tool Detection in Action Detection Artifact Generator attempts to access the /v1/postgres/recovery/backup endpoint of PostgreSQL Sidecar Service to verify if it is accessible or not: 400 response - probably...
CLEANSTART-2024-BJ87056 PostgreSQL JDBC Driver (aka PgJDBC) before 42
Security vulnerability affects the java-postgresql-jdbc package. PostgreSQL JDBC Driver aka PgJDBC before 42...
CLEANSTART-2024-BR64621 PostgreSQL JDBC Driver (PgJDBC for short) allows Java programs to connect to a PostgreSQL database using standard, database independent Java code
Security vulnerability affects the java-postgresql-jdbc package. PostgreSQL JDBC Driver PgJDBC for short allows Java programs to connect to a PostgreSQL database using standard, database independent Java code...
CLEANSTART-2024-DM91288 pgjdbc, the PostgreSQL JDBC Driver, allows attacker to inject SQL if using PreferQueryMode=SIMPLE
Security vulnerability affects the java-postgresql-jdbc package. pgjdbc, the PostgreSQL JDBC Driver, allows attacker to inject SQL if using PreferQueryMode=SIMPLE...
CLEANSTART-2024-RW94589 TimescaleDB, an open-source time-series SQL database, has a privilege escalation vulnerability in versions 2
Security vulnerability affects the postgresql-timescaledb package. TimescaleDB, an open-source time-series SQL database, has a privilege escalation vulnerability in versions 2...