17815 matches found
CVE-2026-119922
The Babelfish for PostgreSQL extension versions 1.2-1.5 , 2.1-2.15 , 3.1-3.12 , 4.0-4.8 , and 5.1-5.4 are susceptible to a privilege escalation vulnerability due to improper access control . This flaw could allow remote authenticated users to elevate their privileges. To remediate this issue, use...
vulnreport
Abandoned Project This project is not currently maintained and has been abandoned. Vulnreport Pentesting management and automation platform Vulnreport is a platform for managing penetration tests and generating well-formatted, actionable findings reports without the normal overhead that takes up...
CVE-2026-120065
creationtimestamp| type| source ---|---|--- 2026-11-03 06:24:17+00:00| seen| https://www.acn.gov.it/portale/w/risolte-vulnerabilita-in-prodotti-postgresql...
[SECURITY] Fedora 43 Update: barman-3.20.1-3.fc43
Barman Backup and Recovery Manager is an open-source administration tool for disaster recovery of PostgreSQL servers written in Python. It allows your organization to perform remote backups of multiple servers in business critical environments to reduce risk and help DBAs during the recove ry pha...
[SECURITY] Fedora 44 Update: barman-3.20.1-3.fc44
Barman Backup and Recovery Manager is an open-source administration tool for disaster recovery of PostgreSQL servers written in Python. It allows your organization to perform remote backups of multiple servers in business critical environments to reduce risk and help DBAs during the recove ry pha...
PT-2026-136334
Name of the Vulnerable Software and Affected Versions Babelfish for PostgreSQL extension versions 1.2 through 1.5 Babelfish for PostgreSQL extension versions 2.1 through 2.15 Babelfish for PostgreSQL extension versions 3.1 through 3.12 Babelfish for PostgreSQL extension versions 4.0 through 4.8...
CVE-2026-120067
A flaw was found in postgresql-odbc. When processing updatable database queries, the driver copies internal row metadata into a fixed-size memory buffer without verifying the data length sent by the server. A malicious database server or an untrusted user capable of creating custom database views...
CVE-2026-120066
A flaw was found in postgresql-odbc. This issue leads to information disclosure and potential unauthorized file modification due to insecure log file creation in shared temporary directories. When logging is enabled on Unix-like systems, the driver creates world-readable log files with predictabl...
CVE-2026-120059
A flaw was found in postgresql-odbc. When processing updatable cursors, the driver improperly uses a server-provided column name as a format string when constructing query statements. A malicious database server or an attacker able to create a table with a specially crafted column name can cause...
CVE-2026-120065
A flaw was found in postgresql-odbc. When handling updatable cursors, the driver fails to properly sanitize quotation marks in column names before inserting them into internal database queries. An authenticated database user with permission to create tables, or an untrusted database server, can...
CVE-2026-120062
A flaw was found in postgresql-odbc. When an application passes untrusted table or schema names to the SQLSpecialColumns catalog function, the driver fails to properly escape the input before concatenating it into internal database queries. An attacker able to supply crafted input can execute...
CVE-2026-120061
A flaw was found in postgresql-odbc. When processing Open Database Connectivity ODBC escape sequences in SQL statements, the parser fails to properly validate buffer boundaries. An attacker capable of submitting untrusted SQL text to an application using the driver can trigger a stack-based buffe...
CVE-2026-120058
A flaw was found in postgresql-odbc. An untrusted database server can exploit this vulnerability to execute arbitrary code or cause a denial of service DoS on the client system. When cursor-based fetching is enabled, the driver determines its row cache size using the column count from the initial...
Security Bulletin: IBM Maximo Application Suite - Visual Inspection component uses dependencies which is vulnerable to multiple High severity CVEs.
Summary Security Bulletin: IBM Maximo Application Suite - Visual Inspection component uses dependencies which is vulnerable to multiple High severity CVEs. This bulletin contains information regarding the vulnerability and its remediation. Vulnerability Details CVEID:CVE-2026-14673 DESCRIPTION:...
CVE-2026-57190
A flaw was found in Asterisk. When the PostgreSQL or TDS Channel Event Logging CEL backends are enabled and custom event data is logged without proper validation, an attacker can supply malicious input to trigger SQL injection. This vulnerability allows an attacker to execute arbitrary SQL comman...
Important: Red Hat Security Advisory: postgresql:16 security update
An update for the postgresql:16 module is now available for Red Hat Enterprise Linux 9.6 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating,...
PostgreSQL psqlODBC post-link vulnerability
A security vulnerability exists in PostgreSQL versions prior to psqlODBC 18.00.0006. This vulnerability arises when logging is enabled on Unix-like systems; by default, log files are created under /tmp with read permissions set to “read-only”. Local users can then read query texts and data from...
RHEL 9 : postgresql:16 (RHSA-2026:93460)
The remote Redhat Enterprise Linux 9 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2026:93460 advisory. PostgreSQL is an advanced object-relational database management system DBMS. Security Fixes: pgvector: pgvector: Arbitrary code execution via...
CVE-2019-9193
CVE-2019–9193 - PostgreSQL 9.3-12.3 Authenticated Remote Code Execution Proof of Concept PostgreSQL Database from version 9.3 to 12.3 latest tested are vulnerable to Authenticated Remote Code Execution. Even if it isn't considered to be a vulnerability itself by the development team, this could b...
cve-2019-9193
CVE-2019-9193 • CVE-2019-9193 Vulnerability PostgreSQL has a vulnerability that allows arbitrary code execution within the DB's operating system via the “COPY TO / FROM PROGRAM” feature. The attack vector involves users who are “SuperUser” or belong to the “pgexecuteserverprogram” group...