Lucene search

K
phpmyadminPhpMyAdminPHPMYADMIN:PMASA-2016-9
HistoryJan 24, 2016 - 12:00 a.m.

XSS vulnerability in SQL editor.

2016-01-2400:00:00
www.phpmyadmin.net
21

CVSS2

3.5

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

SINGLE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:M/Au:S/C:N/I:P/A:N

CVSS3

5.4

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

REQUIRED

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

EPSS

0.001

Percentile

45.9%

PMASA-2016-9

Announcement-ID: PMASA-2016-9

Date: 2016-01-24

Summary

XSS vulnerability in SQL editor.

Description

With a crafted SQL query, it is possible to trigger an XSS attack in the SQL editor.

Severity

We consider this vulnerability to be non-critical.

Mitigation factor

This vulnerability can be triggered only by someone who is logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required pages.

Affected Versions

Versions 4.5.x (prior to 4.5.4) are affected.

Solution

Upgrade to phpMyAdmin 4.5.4 or newer or apply patch listed below.

References

Thanks to Emanuel Bronshtein @e3amn2l for reporting these vulnerabilities.

Assigned CVE ids: CVE-2016-2045

CWE ids: CWE-661 CWE-79

Patches

The following commits have been made on the 4.5 branch to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.

CPENameOperatorVersion
phpmyadminle4.5.4

CVSS2

3.5

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

SINGLE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:M/Au:S/C:N/I:P/A:N

CVSS3

5.4

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

REQUIRED

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

EPSS

0.001

Percentile

45.9%