logo
DATABASE RESOURCES PRICING ABOUT US

Moderate severity vulnerability that affects i18n

Description

Cross-site scripting (XSS) vulnerability in exceptions.rb in the i18n gem before 0.6.6 for Ruby allows remote attackers to inject arbitrary web script or HTML via a crafted I18n::MissingTranslationData.new call.


Affected Software


CPE Name Name Version
i18n 0.1.0
i18n 0.2.0
i18n 0.2.1
i18n 0.3.0
i18n 0.3.1
i18n 0.3.2
i18n 0.3.3
i18n 0.3.4
i18n 0.3.5
i18n 0.3.6
i18n 0.3.6.pre
i18n 0.3.7
i18n 0.4.0
i18n 0.4.0.beta
i18n 0.4.0.beta1
i18n 0.4.1
i18n 0.4.2
i18n 0.5.0
i18n 0.5.0beta1
i18n 0.5.0beta2
i18n 0.5.0beta3
i18n 0.5.2
i18n 0.5.3
i18n 0.5.4
i18n 0.6.0
i18n 0.6.0beta1
i18n 0.6.1
i18n 0.6.2
i18n 0.6.3
i18n 0.6.4
i18n 0.6.5

Related