Gentoo Linux Local Check: https://security.gentoo.org/glsa/201408-15

2015-09-29T00:00:00
ID OPENVAS:1361412562310121259
Type openvas
Reporter Eero Volotinen
Modified 2018-04-06T00:00:00

Description

Gentoo Linux Local Security Checks https://security.gentoo.org/glsa/201408-15

                                        
                                            # OpenVAS Vulnerability Test
# Description: Gentoo Linux security check
# $Id: glsa-201408-15.nasl 9374 2018-04-06 08:58:12Z cfischer $

# Authors:
# Eero Volotinen <eero.volotinen@solinor.com>
#
# Copyright:
# Copyright (c) 2015 Eero Volotinen, http://solinor.com
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
# (or any later version), as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
#
if(description)
 {
script_oid("1.3.6.1.4.1.25623.1.0.121259");
script_version("$Revision: 9374 $");
script_tag(name:"creation_date", value:"2015-09-29 11:27:46 +0300 (Tue, 29 Sep 2015)");
script_tag(name:"last_modification", value:"$Date: 2018-04-06 10:58:12 +0200 (Fri, 06 Apr 2018) $");
script_name("Gentoo Linux Local Check: https://security.gentoo.org/glsa/201408-15");
script_tag(name: "insight", value: "Multiple vulnerabilities have been discovered in PostgreSQL. Please review the CVE identifiers referenced below for details."); 
script_tag(name : "solution", value : "update software");
script_tag(name : "solution_type", value : "VendorFix");
script_xref(name : "URL" , value : "https://security.gentoo.org/glsa/201408-15");
script_cve_id("CVE-2013-0255","CVE-2013-1899","CVE-2013-1900","CVE-2013-1901","CVE-2014-0060","CVE-2014-0061","CVE-2014-0062","CVE-2014-0063","CVE-2014-0064","CVE-2014-0065","CVE-2014-0066","CVE-2014-2669");
script_tag(name:"cvss_base", value:"8.5");
script_tag(name:"cvss_base_vector", value:"AV:N/AC:M/Au:S/C:C/I:C/A:C");
script_tag(name:"qod_type", value:"package");
script_dependencies("gather-package-list.nasl");
script_mandatory_keys("ssh/login/gentoo", "ssh/login/pkg");
script_category(ACT_GATHER_INFO);
script_tag(name:"summary", value:"Gentoo Linux Local Security Checks https://security.gentoo.org/glsa/201408-15");
script_copyright("Eero Volotinen");
script_family("Gentoo Local Security Checks");
exit(0);
}
include("revisions-lib.inc");

include("pkg-lib-gentoo.inc");

res = "";
report = "";

if((res=ispkgvuln(pkg:"dev-db/postgresql-server", unaffected: make_list("ge 9.3.3"), vulnerable: make_list() )) != NULL) {

  report += res;
}
if((res=ispkgvuln(pkg:"dev-db/postgresql-server", unaffected: make_list("ge 9.2.7"), vulnerable: make_list() )) != NULL) {

  report += res;
}
if((res=ispkgvuln(pkg:"dev-db/postgresql-server", unaffected: make_list("ge 9.1.12"), vulnerable: make_list() )) != NULL) {

  report += res;
}
if((res=ispkgvuln(pkg:"dev-db/postgresql-server", unaffected: make_list("ge 9.0.16"), vulnerable: make_list() )) != NULL) {

  report += res;
}
if((res=ispkgvuln(pkg:"dev-db/postgresql-server", unaffected: make_list("ge 8.4.20"), vulnerable: make_list() )) != NULL) {

  report += res;
}
if((res=ispkgvuln(pkg:"dev-db/postgresql-server", unaffected: make_list(), vulnerable: make_list("lt 9.3.3"))) != NULL) {

  report += res;
}

if(report != "") {
    security_message(data:report);
} else if (__pkg_match) {
    exit(99); # Not vulnerable.
}