WordPress 4.9.x < 4.9.2 MediaElement.js Flash Fallback XSS

2018-01-24T00:00:00
ID WORDPRESS_4_9_2.NASL
Type nessus
Reporter Tenable
Modified 2018-08-07T00:00:00

Description

According to its self-reported version number, the WordPress application running on the remote web server is 4.9.x prior to 4.9.2. It is, therefore, affected by a cross-site scripting vulnerability.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(106304);
  script_version("1.5");
  script_cvs_date("Date: 2018/08/07 16:46:49");

  script_cve_id("CVE-2018-5776");
  script_bugtraq_id(102730);

  script_name(english:"WordPress 4.9.x < 4.9.2 MediaElement.js Flash Fallback XSS");
  script_summary(english:"Checks the version of WordPress.");

  script_set_attribute(attribute:"synopsis", value:
"A PHP application running on the remote web server is affected by
a cross-site scripting vulnerability.");
  script_set_attribute(attribute:"description", value:
"According to its self-reported version number, the WordPress
application running on the remote web server is 4.9.x prior to 4.9.2.
It is, therefore, affected by a cross-site scripting vulnerability.");

  # https://wordpress.org/news/2018/01/wordpress-4-9-2-security-and-maintenance-release/
  script_set_attribute(attribute:"see_also", value:"http://www.nessus.org/u?7d2f97df");
  script_set_attribute(attribute:"solution", value:
"Upgrade to WordPress version 4.9.2 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N");
  script_set_cvss_temporal_vector("CVSS2#E:H/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:H/RL:O/RC:C");
  script_set_attribute(attribute:"exploitability_ease", value:"No exploit is required");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2018/01/16");
  script_set_attribute(attribute:"patch_publication_date", value:"2018/01/16");
  script_set_attribute(attribute:"plugin_publication_date", value:"2018/01/24");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:wordpress:wordpress");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2018 Tenable Network Security, Inc.");

  script_dependencies("wordpress_detect.nasl");
  script_require_keys("www/PHP", "installed_sw/WordPress", "Settings/ParanoidReport");
  script_require_ports("Services/www", 80, 443);

  exit(0);
}

include("vcf.inc");
include("http.inc");

app = "WordPress";
get_install_count(app_name:app, exit_if_zero:TRUE);

if (report_paranoia < 2) audit(AUDIT_PARANOID);

port = get_http_port(default:80, php:TRUE);

app_info = vcf::get_app_info(app:app, port:port, webapp:TRUE);

# Per https://wordpress.org/download/release-archive/
# only 4.9.x is currently supported :
# "None of these are safe to use, except the latest in the 4.9 series, which is actively maintained."
constraints = [
  { "min_version" : "4.9", "fixed_version" : "4.9.2" }
];

vcf::check_version_and_report(
  app_info:app_info,
  constraints:constraints,
  severity:SECURITY_WARNING,
  flags:{xss:TRUE}
);