WordPress < 3.1.1 Multiple Vulnerabilities

2018-01-24T00:00:00
ID WORDPRESS_3_1_1.NASL
Type nessus
Reporter Tenable
Modified 2018-11-28T00:00:00

Description

According to its self-reported version number, the WordPress application running on the remote web server is prior to 3.1.1. It is, therefore, affected by multiple vulnerabilities, including cross-site scripting (XSS) and cross-site request forgery (XSRF), and a denial of service (DoS) vulnerability.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

                                        
                                            #
# (C) Tenable Network Security, Inc.
#

include("compat.inc");

if (description)
{
  script_id(106307);
  script_version("1.5");
  script_cvs_date("Date: 2018/11/28 22:47:41");

  script_cve_id("CVE-2011-4956", "CVE-2011-4957");
  script_bugtraq_id(73868, 78357);

  script_name(english:"WordPress < 3.1.1 Multiple Vulnerabilities");
  script_summary(english:"Checks the version of WordPress.");

  script_set_attribute(attribute:"synopsis", value:
"The remote web server contains a PHP application that is
affected by multiple vulnerabilities.");
  script_set_attribute(attribute:"description", value:
"According to its self-reported version number, the WordPress
application running on the remote web server is prior to 3.1.1.
It is, therefore, affected by multiple vulnerabilities, including
cross-site scripting (XSS) and cross-site request forgery (XSRF),
and a denial of service (DoS) vulnerability.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.");
  script_set_attribute(attribute:"see_also", value:"https://wordpress.org/news/2011/04/wordpress-3-1-1/");
  script_set_attribute(attribute:"see_also", value:"https://codex.wordpress.org/Version_3.1.1");
  script_set_attribute(attribute:"solution", value:
"Upgrade to WordPress version 3.1.1 or later.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:U/RC:ND");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2011-4957");
  script_set_attribute(attribute:"cvss_score_rationale", value:"Wordpress release notes for 3.1.1 mention a hardening of CSRF prevention. This score reflects the potential for CSRF vulnerabilities in lower versions.");
  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2011/04/05");
  script_set_attribute(attribute:"patch_publication_date", value:"2011/04/05");
  script_set_attribute(attribute:"plugin_publication_date", value:"2018/01/24");

  script_set_attribute(attribute:"plugin_type", value:"remote");
  script_set_attribute(attribute:"cpe", value:"cpe:/a:wordpress:wordpress");
  script_set_attribute(attribute:"potential_vulnerability", value:"true");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"CGI abuses");

  script_copyright(english:"This script is Copyright (C) 2018 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("wordpress_detect.nasl");
  script_require_keys("www/PHP", "installed_sw/WordPress", "Settings/ParanoidReport");
  script_require_ports("Services/www", 80, 443);

  exit(0);
}

include("audit.inc");
include("global_settings.inc");
include("misc_func.inc");
include("http.inc");
include("install_func.inc");

app = "WordPress";
get_install_count(app_name:app, exit_if_zero:TRUE);

if (report_paranoia < 2) audit(AUDIT_PARANOID);

port = get_http_port(default:80, php:TRUE);

install = get_single_install(
  app_name : app,
  port     : port,
  exit_if_unknown_ver : TRUE
);

dir = install['path'];
version = install['version'];
install_url = build_url(port:port, qs:dir);

if (report_paranoia < 2) audit(AUDIT_PARANOID);

ver = split(version, sep:'.', keep:FALSE);
for (i=0; i<max_index(ver); i++)
  ver[i] = int(ver[i]);

# Versions < 3.1.1 are affected.
if (
  ver[0] < 3 ||
  (ver[0] == 3 && ver[1] < 1) ||
  (ver[0] == 3 && ver[1] == 1 && ver[2] < 1)
)
{
  report =
  '\n  URL               : ' + install_url +
  '\n  Installed version : ' + version +
  '\n  Fixed version     : 3.1.1' +
  '\n';
  security_report_v4(
    severity : SECURITY_WARNING,
    port     : port,
    extra    : report,
    xss      : TRUE,
    xsrf     : TRUE
  );
  exit(0);
}
audit(AUDIT_WEB_APP_NOT_AFFECTED, app, install_url, version);