Lucene search

K
nessusThis script is Copyright (C) 2019-2024 and is owned by Tenable, Inc. or an Affiliate thereof.OPENSUSE-2019-1163.NASL
HistoryApr 08, 2019 - 12:00 a.m.

openSUSE Security Update : ldb (openSUSE-2019-1163)

2019-04-0800:00:00
This script is Copyright (C) 2019-2024 and is owned by Tenable, Inc. or an Affiliate thereof.
www.tenable.com
20

CVSS2

4

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

SINGLE

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

PARTIAL

AV:N/AC:L/Au:S/C:N/I:N/A:P

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

AI Score

6

Confidence

High

EPSS

0.007

Percentile

80.1%

This update for ldb fixes the following issue :

Security issue fixed :

  • CVE-2019-3824: Fixed an out-of-bound read vulnerability in ldb_wildcard_compare (bsc#1125410).

This update was imported from the SUSE:SLE-15:Update update project.

#%NASL_MIN_LEVEL 70300
#
# (C) Tenable Network Security, Inc.
#
# The descriptive text and package checks in this plugin were
# extracted from openSUSE Security Update openSUSE-2019-1163.
#
# The text description of this plugin is (C) SUSE LLC.
#

include('deprecated_nasl_level.inc');
include('compat.inc');

if (description)
{
  script_id(123818);
  script_version("1.5");
  script_set_attribute(attribute:"plugin_modification_date", value:"2024/06/05");

  script_cve_id("CVE-2019-3824");

  script_name(english:"openSUSE Security Update : ldb (openSUSE-2019-1163)");

  script_set_attribute(attribute:"synopsis", value:
"The remote openSUSE host is missing a security update.");
  script_set_attribute(attribute:"description", value:
"This update for ldb fixes the following issue :

Security issue fixed :

  - CVE-2019-3824: Fixed an out-of-bound read vulnerability
    in ldb_wildcard_compare (bsc#1125410).

This update was imported from the SUSE:SLE-15:Update update project.");
  script_set_attribute(attribute:"see_also", value:"https://bugzilla.opensuse.org/show_bug.cgi?id=1125410");
  script_set_attribute(attribute:"solution", value:
"Update the affected ldb packages.");
  script_set_cvss_base_vector("CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P");
  script_set_cvss_temporal_vector("CVSS2#E:U/RL:OF/RC:C");
  script_set_cvss3_base_vector("CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H");
  script_set_cvss3_temporal_vector("CVSS:3.0/E:U/RL:O/RC:C");
  script_set_attribute(attribute:"cvss_score_source", value:"CVE-2019-3824");

  script_set_attribute(attribute:"exploitability_ease", value:"No known exploits are available");
  script_set_attribute(attribute:"exploit_available", value:"false");

  script_set_attribute(attribute:"vuln_publication_date", value:"2019/03/06");
  script_set_attribute(attribute:"patch_publication_date", value:"2019/04/05");
  script_set_attribute(attribute:"plugin_publication_date", value:"2019/04/08");

  script_set_attribute(attribute:"plugin_type", value:"local");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:ldb-debugsource");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:ldb-tools");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:ldb-tools-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:libldb-devel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:libldb1");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:libldb1-32bit");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:libldb1-32bit-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:libldb1-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python-ldb");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python-ldb-32bit");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python-ldb-32bit-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python-ldb-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python-ldb-devel");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python3-ldb");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python3-ldb-32bit");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python3-ldb-32bit-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python3-ldb-debuginfo");
  script_set_attribute(attribute:"cpe", value:"p-cpe:/a:novell:opensuse:python3-ldb-devel");
  script_set_attribute(attribute:"cpe", value:"cpe:/o:novell:opensuse:15.0");
  script_set_attribute(attribute:"generated_plugin", value:"current");
  script_end_attributes();

  script_category(ACT_GATHER_INFO);
  script_family(english:"SuSE Local Security Checks");

  script_copyright(english:"This script is Copyright (C) 2019-2024 and is owned by Tenable, Inc. or an Affiliate thereof.");

  script_dependencies("ssh_get_info.nasl");
  script_require_keys("Host/local_checks_enabled", "Host/SuSE/release", "Host/SuSE/rpm-list", "Host/cpu");

  exit(0);
}


include("audit.inc");
include("global_settings.inc");
include("rpm.inc");

if (!get_kb_item("Host/local_checks_enabled")) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
release = get_kb_item("Host/SuSE/release");
if (isnull(release) || release =~ "^(SLED|SLES)") audit(AUDIT_OS_NOT, "openSUSE");
if (release !~ "^(SUSE15\.0)$") audit(AUDIT_OS_RELEASE_NOT, "openSUSE", "15.0", release);
if (!get_kb_item("Host/SuSE/rpm-list")) audit(AUDIT_PACKAGE_LIST_MISSING);

ourarch = get_kb_item("Host/cpu");
if (!ourarch) audit(AUDIT_UNKNOWN_ARCH);
if (ourarch !~ "^(i586|i686|x86_64)$") audit(AUDIT_ARCH_NOT, "i586 / i686 / x86_64", ourarch);

flag = 0;

if ( rpm_check(release:"SUSE15.0", reference:"ldb-debugsource-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"ldb-tools-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"ldb-tools-debuginfo-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"libldb-devel-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"libldb1-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"libldb1-debuginfo-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"python-ldb-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"python-ldb-debuginfo-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"python-ldb-devel-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"python3-ldb-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"python3-ldb-debuginfo-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", reference:"python3-ldb-devel-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", cpu:"x86_64", reference:"libldb1-32bit-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", cpu:"x86_64", reference:"libldb1-32bit-debuginfo-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", cpu:"x86_64", reference:"python-ldb-32bit-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", cpu:"x86_64", reference:"python-ldb-32bit-debuginfo-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", cpu:"x86_64", reference:"python3-ldb-32bit-1.2.3-lp150.7.2") ) flag++;
if ( rpm_check(release:"SUSE15.0", cpu:"x86_64", reference:"python3-ldb-32bit-debuginfo-1.2.3-lp150.7.2") ) flag++;

if (flag)
{
  if (report_verbosity > 0) security_warning(port:0, extra:rpm_report_get());
  else security_warning(0);
  exit(0);
}
else
{
  tested = pkg_tests_get();
  if (tested) audit(AUDIT_PACKAGE_NOT_AFFECTED, tested);
  else audit(AUDIT_PACKAGE_NOT_INSTALLED, "ldb-debugsource / ldb-tools / ldb-tools-debuginfo / libldb-devel / etc");
}
VendorProductVersionCPE
novellopensuseldb-debugsourcep-cpe:/a:novell:opensuse:ldb-debugsource
novellopensuse15.0cpe:/o:novell:opensuse:15.0
novellopensusepython3-ldb-debuginfop-cpe:/a:novell:opensuse:python3-ldb-debuginfo
novellopensuselibldb1-32bit-debuginfop-cpe:/a:novell:opensuse:libldb1-32bit-debuginfo
novellopensuselibldb-develp-cpe:/a:novell:opensuse:libldb-devel
novellopensuselibldb1-32bitp-cpe:/a:novell:opensuse:libldb1-32bit
novellopensusepython-ldb-debuginfop-cpe:/a:novell:opensuse:python-ldb-debuginfo
novellopensusepython-ldb-develp-cpe:/a:novell:opensuse:python-ldb-devel
novellopensusepython-ldb-32bitp-cpe:/a:novell:opensuse:python-ldb-32bit
novellopensuselibldb1p-cpe:/a:novell:opensuse:libldb1
Rows per page:
1-10 of 191

CVSS2

4

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

SINGLE

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

PARTIAL

AV:N/AC:L/Au:S/C:N/I:N/A:P

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

AI Score

6

Confidence

High

EPSS

0.007

Percentile

80.1%