Lucene search

K
nessusTenable8707.PRM
HistoryApr 20, 2015 - 12:00 a.m.

Moodle 1.9.x < 1.9.11 Multiple Vulnerabilities

2015-04-2000:00:00
Tenable
www.tenable.com
6

CVSS2

6.8

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

EPSS

0.003

Percentile

70.3%

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle prior to 1.9.11 are potentially affected by multiple vulnerabilities :

  • Multiple cross-site scripting (XSS) vulnerabilities exist in the media-filter implementation. Specifically, this affects the ‘filter/mediaplugin/filter.php’ script. A remote attacker could inject arbitrary HTML or scripts via vectors involving Flash Video (FLV) and YouTube videos. (MSA-11-0011 / CVE-2011-4286)

  • A cross-site scripting vulnerability exists in ‘/tag/tag_autocomplete.php’ due to lack of input validation. (MSA-11-0003 / CVE-2011-4278)

  • A cross-site request forgery vulnerability flaw exists in RSS feeds contained within an RSS block. (MSA-11-0002 / CVE-2011-4133)

  • An information disclosure flaw exists in the IMS enterprise enrollment file when placed in the course files area. Specifically, this affects the ‘imsenterprise-enrol.xml’ file. (MSA-11-0008 / CVE-2011-4283)

Binary data 8707.prm
VendorProductVersionCPE
moodlemoodlecpe:/a:moodle:moodle

CVSS2

6.8

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

EPSS

0.003

Percentile

70.3%