Lucene search

K
ibmIBMBC2A443D24127892EC1969846551FE04BF14FA7FA712B1A12B52472A40C811E9
HistoryJun 18, 2018 - 1:37 a.m.

Security Bulletin: Vulnerabilities in libtasn1 affect PowerKVM

2018-06-1801:37:31
www.ibm.com
22

EPSS

0.924

Percentile

99.0%

Summary

PowerKVM is affected by vulnerabilities in libtasn1 library. IBM has now addressed these vulnerabilities.

Vulnerability Details

CVEID: CVE-2015-3622**
DESCRIPTION:** GNU Libtasn1 is vulnerable to a heap-based buffer overflow, caused by improper bounds checking by the _asn1_extract_der_octet() function. By sending an overly long string, a remote attacker could overflow a buffer and execute arbitrary code on the system or cause the application to crash.
CVSS Base Score: 7.5
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/102782 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVEID: CVE-2015-2806**
DESCRIPTION:** An unspecified error in libtasn1 related to asn1_der_decoding has an unknown impact and attack vector.
CVSS Base Score: 6.8
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/102548 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P

Affected Products and Versions

PowerKVM 2.1 and 3.1

Remediation/Fixes

Customers can update PowerKVM systems by using β€œyum update”.

Fix images are made available via Fix Central. For version 3.1, see https://ibm.biz/BdHggw. This issue is addressed starting with v3.1.0.2 update 10.

For version 2.1, see https://ibm.biz/BdEnT8. This issue is addressed starting with PowerKVM 2.1.1.3-65 update 19. Customers running v2.1 are, in any case, encouraged to upgrade to v3.1.

For v2.1 systems currently running fix levels of PowerKVM prior to 2.1.1, please see <http://download4.boulder.ibm.com/sar/CMA/OSA/05e4c/0/README&gt; for prerequisite fixes and instructions.

Workarounds and Mitigations

none

CPENameOperatorVersion
powerkvmeq2.1
powerkvmeq3.1