Lucene search

K
ibmIBM33A27D0AEEF8AACDAAF944915958F47DC11CB3D5A75E10B5DD25A353BD472C7D
HistoryJul 22, 2020 - 5:36 p.m.

Security Bulletin: IBM Cloud Kubernetes Service is affected by a Kubernetes API server security vulnerability (CVE-2020-8559)

2020-07-2217:36:34
www.ibm.com
9

0.003 Low

EPSS

Percentile

71.6%

Summary

IBM Cloud Kubernetes Service is affected by a security vulnerability in the Kubernetes API server that could enable a privilege escalation from a compromised node (CVE-2020-8559)

Vulnerability Details

CVEID: CVE-2020-8559
Description: Kubernetes kube-apiserver could allow a remote authenticated attacker to gain elevated privileges on the system, caused by a flaw when multiple clusters share the same certificate authority trusted by the client. By intercepting certain requests and sending a redirect response, an attacker could exploit this vulnerability to compromise other nodes.
CVSS Base Score: 6.4
CVSS Temporal Score: https://exchange.xforce.ibmcloud.com/vulnerabilities/185302 for more information
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H)

Affected Products and Versions

IBM Cloud Kubernetes Service 1.18.0-1.18.5
IBM Cloud Kubernetes Service 1.17.0-1.17.8
IBM Cloud Kubernetes Service 1.16.0-1.16.12
IBM Cloud Kubernetes Service 1.5-1.15

Remediation/Fixes

Updates for IBM Cloud Kubernetes Service clusters at versions 1.16 or later are available that fix this vulnerability. IBM Cloud Kubernetes Service will attempt to automatically apply the fix to your cluster master. There is no need to update cluster worker nodes for this vulnerability.

To verify your clusters are no longer exposed to this vulnerability, use the following IBM Cloud CLI command to confirm your cluster master versions:

ibmcloud ks clusters

If your cluster masters are at one of the following versions or later, they are no longer exposed to this vulnerability:

1.18.6
1.17.9
1.16.13

If one or more of your clusters has not had its master automatically updated then use the following IBM Cloud CLI command to complete the cluster master update, replacing 1.## with the target version.

ibmcloud ks cluster master update --cluster <cluster name or ID> --version 1.##

Customers running IBM Cloud Kubernetes Service clusters at version 1.14 or 1.15 must upgrade to version 1.16. Please review the documentation before starting an upgrade since additional actions may be required.

Customers running IBM Cloud Kubernetes Service clusters at version 1.13 or earlier must create a new cluster and deploy their apps to the new cluster.

IBM Cloud Kubernetes Service versions 1.14 and earlier are no longer supported, and version 1.15 is deprecated. See the IBM Cloud Kubernetes Service Version information and update actions documentation for more information about Kubernetes versions and version support policies.

Monitor IBM Cloud Status for Future Security Bulletins

Monitor the security notifications on the IBM Cloud Status page to be advised of future security bulletins.

References

Complete CVSS v3 Guide
On-line Calculator v3

Off

Kubernetes Security Announcement for CVE-2020-8559

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

Review the IBM security bulletin disclaimer and definitions regarding your responsibilities for assessing potential impact of security vulnerabilities to your environment.

[{“Business Unit”:{“code”:“BU059”,“label”:“IBM Software w/o TPS”},“Product”:{“code”:“SSJTBP”,“label”:“IBM Cloud Kubernetes Service”},“Component”:“–”,“Platform”:[{“code”:“PF025”,“label”:“Platform Independent”}],“Version”:“All Versions”,“Edition”:“”,“Line of Business”:{“code”:“LOB21”,“label”:“Public Cloud Platform”}}]

CPENameOperatorVersion
ibm cloud kubernetes serviceeqany