The Internet: Insufficient shell characters filtering leads to (potentially remote) code execution (CVE-2016-3714)

2016-04-21T00:00:00
ID H1:143966
Type hackerone
Reporter stewie
Modified 2016-05-03T00:00:00

Description

The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allow remote attackers to execute arbitrary code via shell metacharacters in a crafted image, aka "ImageTragick."

See also: http://www.openwall.com/lists/oss-security/2016/05/03/18 https://imagetragick.com/