Lucene search

K
githubGitHub Advisory DatabaseGHSA-QHXW-54M9-6WWC
HistoryMay 14, 2022 - 3:45 a.m.

MitM on Jenkins Maven Plugin

2022-05-1403:45:43
CWE-20
GitHub Advisory Database
github.com
8

0.001 Low

EPSS

Percentile

28.9%

Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.

CPENameOperatorVersion
org.jenkins-ci.main:maven-pluginlt3.0