Lucene search

K
gentooGentoo FoundationGLSA-202209-21
HistorySep 29, 2022 - 12:00 a.m.

Poppler: Arbitrary Code Execution

2022-09-2900:00:00
Gentoo Foundation
security.gentoo.org
12

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

6.8 Medium

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

0.003 Low

EPSS

Percentile

65.2%

Background

Poppler is a PDF rendering library based on the xpdf-3.0 code base.

Description

Multiple vulnerabilities have been discovered in Poppler. Please review the CVE identifiers referenced below for details.

Impact

Processing a specially crafted PDF file or JBIG2 image could lead to a crash or the execution of arbitrary code.

Workaround

Avoid opening untrusted PDFs.

Resolution

All Poppler users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/poppler-22.09.0"
OSVersionArchitecturePackageVersionFilename
Gentooanyallapp-text/poppler< 22.09.0UNKNOWN

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

6.8 Medium

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

0.003 Low

EPSS

Percentile

65.2%