Mailman: Member password disclosure vulnerability

2004-06-09T00:00:00
ID GLSA-200406-04
Type gentoo
Reporter Gentoo Foundation
Modified 2004-06-09T00:00:00

Description

Background

Mailman is a python-based mailing list server with an extensive web interface.

Description

Mailman contains an unspecified vulnerability in the handling of request emails.

Impact

By sending a carefully crafted email request to the mailman server an attacker could obtain member passwords.

Workaround

There is no known workaround at this time.

Resolution

All users of Mailman should upgrade to the latest stable version:

 # emerge sync

 # emerge -pv ">=net-mail/mailman-2.1.5"
 # emerge ">=net-mail/mailman-2.1.5"