SOL16865 - GNU C Library (glibc) vulnerability CVE-2015-1781

2015-07-08T00:00:00
ID SOL16865
Type f5
Reporter f5
Modified 2015-07-08T00:00:00

Description

Note: As of February 17, 2015, AskF5 Security Advisory articles include the Severity value. Security Advisory articles published before this date do not list a Severity value.

*Although the BIG-IP, BIG-IQ, and Enterprise Manager software contains the vulnerable code, BIG-IP, BIG-IQ, and Enterprise Manager do not use the vulnerable code in a way that exposes the vulnerability in a standard configuration. An attacker must have local access to BIG-IP, BIG-IQ, Enterprise Manager to upload a custom binary in order to trigger an exploit that the attacker can then crash the application or run arbitrary code. Therefore, F5 Product Development considers this vulnerability as Not Vulnerable in a standard configuration and Low Severity if management access to BIG-IP, BIG-IQ, and Enterprise Manager is not adequately protected; for example over a secure network.

Recommended Action

If the previous table lists a version in the Versions known to be not vulnerable column, you can eliminate this vulnerability by upgrading to the listed version. If the listed version is older than the version you are currently running, or if the table does not list any version in the column, then no upgrade candidate currently exists.

F5 responds to vulnerabilities in accordance with the Severity values published in the previous table. The Severity values and other security vulnerability parameters are defined in SOL4602: Overview of the F5 security vulnerability response policy.

To mitigate this vulnerability, you should only permit management access to F5 products over a secure network and limit shell access to trusted users.

For more information about securing access to BIG-IP and Enterprise Manager systems, refer to SOL13309: Restricting access to the Configuration utility by source IP address (11.x) and SOL13092: Overview of securing access to the BIG-IP system.

Supplemental Information

  • SOL9970: Subscribing to email notifications regarding F5 products
  • SOL9957: Creating a custom RSS feed to view new and updated documents
  • SOL4602: Overview of the F5 security vulnerability response policy
  • SOL4918: Overview of the F5 critical issue hotfix policy